Go Back   LS1TECH > RACING DEPARTMENT > 12 Second Club
Sign in using an external account
Register Forgot Password?
Search

12 Second Club In the 12s yet? Come inside!

12.667 @ 113

Reply
 
Thread Tools Search this Thread
Old 01-19-2011, 10:29 PM   #1
12 Second Club
 
Bludog's Avatar
 
Trader Rating: 0
Join Date: Jan 2011
Location: South Chicagoland
Posts: 12
Default 12.667 @ 113

Kook headers and x-pipe (cat delete), GM Performance exhaust, Hurricane CAI, Straight couplers, Ported throttle body, E3 spark plugs, MSD Wires, MGW Shifter, Dyno tuned by Straightline Performance.
Bludog is offline   Reply With Quote
Old 01-19-2011, 10:39 PM   #2
Restricted User
 
Trader Rating: 12
Join Date: Feb 2010
Location: kansas
Posts: 1,794
Default

Is this with the 2006 vette? Looks like you need some better traction. Did you spin? What is your 60ft? With the 113 trap speed I bet you could be real low 12's.
z99ls1 is offline   Reply With Quote
Old 01-19-2011, 10:54 PM   #3
12 Second Club
 
Fast T's Avatar
 
Trader Rating: 0
Join Date: Aug 2010
Posts: 265
Default

I would like to hear more about your car.Did you just get the car ? Is it the 2006 vette ?

Last edited by Fast T; 01-19-2011 at 10:59 PM..
Fast T is offline   Reply With Quote
Old 01-20-2011, 06:42 PM   #4
11 Second Club
 
jebuzws6's Avatar
 
Trader Rating: 5
Join Date: Nov 2006
Location: Dallas
Posts: 515
Send a message via AIM to jebuzws6
Default

+1 on what they asked???
__________________

11sec
Dirty30 347ci., H/C, plus more fun stuff
jebuzws6 is offline   Reply With Quote
Old 01-21-2011, 06:14 AM   #5
TECH Apprentice
 
demarco313's Avatar
 
Trader Rating: 0
Join Date: Jan 2009
Location: Michigan
Posts: 376
Send a message via Yahoo to demarco313
Default

Yes it is his vette. If you click the link that says 200 vette on the side it shows his mods and they are exactly what he said for the Vette. So yep it his the vette. Like z99ls1 said, you should be real low 12's high 11s with that trap speed. Either work on your launching or shifting man and you will have it in no time
__________________
[COLOR="Blue"][I][B] Corvette LS2 ENGINE HEADS EPS CAM Cutouts 4.10S PORTED FAST VARARAM ETC! Camaro ss 48,000miles(some goodies on it), Just bought a 03 Cobra 2.6 Kenne Bell etc.
demarco313 is offline   Reply With Quote
Old 01-22-2011, 12:28 AM   #6
12 Second Club
 
Bludog's Avatar
 
Trader Rating: 0
Join Date: Jan 2011
Location: South Chicagoland
Posts: 12
Default

I agree I should be quicker with the trap speeds I have. My best 60' time was 1.90's. I have about 20 runs in and definately need more practice. I have aired down my run flats to 24psi. Those 20 runs are spread out over 6 visits to the track. At Rt 66 your lucky if you can get 3 runs in per visit. One of the finest tracks in the country, but probably the most mis-managed and disorganized tracks in the country. Not to mention they treat you like crap.
Bludog is offline   Reply With Quote
Old 01-23-2011, 01:17 PM   #7
TECH Junkie
 
s346k's Avatar
 
Trader Rating: 4
Join Date: May 2005
Location: johnson co.
Posts: 3,433
Default

this car seems terribly slow for a m6 ls1 vette. the car in sig trapped 88 in the 8th with a lid and weld in flowmaster. stock everything else.
__________________
no more lsex in my garage. caught vette fever, though.
s346k is offline   Reply With Quote
Old 01-23-2011, 02:31 PM   #8
Restricted User
 
Trader Rating: 12
Join Date: Feb 2010
Location: kansas
Posts: 1,794
Default

Quote:
Originally Posted by s346k View Post
this car seems terribly slow for a m6 ls1 vette. the car in sig trapped 88 in the 8th with a lid and weld in flowmaster. stock everything else.
It is an ls2....
z99ls1 is offline   Reply With Quote
Old 01-23-2011, 02:47 PM   #9
12 Second Club
 
projectX's Avatar
 
Trader Rating: 49
Join Date: May 2010
Location: MI
Posts: 995
Default

Still yeah he should be low 12's I would think.
__________________
Lid/K&N: V-Force:TB Bypass:FRA: P-TB:3.73's: Heads/Cam : LCA Relo Brackets: air กก: HD LS2 Timing Chain:24k GVW B&M Trans cooler: LT Headers w 3" OR-Y: Poly MM: LS6 ported oil pumprilled/slotted rotors w/ceramic pads:Aluminum DS w safety loop: TR55 plugs w/8.5mm wires:UMI TA relo Cross member:32F/22R solid Sway bars: UMI non-adj TA/LCA/PH Bar: CAT SFI Flexplate: SFC: Stage II 4l60e: Yank SS3200: Catch can: Frost Tune
projectX is offline   Reply With Quote
Old 01-23-2011, 06:20 PM   #10
12 Second Club
 
Bludog's Avatar
 
Trader Rating: 0
Join Date: Jan 2011
Location: South Chicagoland
Posts: 12
Default

Quote:
Originally Posted by s346k View Post
this car seems terribly slow for a m6 ls1 vette. the car in sig trapped 88 in the 8th with a lid and weld in flowmaster. stock everything else.
I tried to read your sig, but don't see any posted times, et's, or what you did in the 1/4. I agree I probably should be low 12's, but I am running on run flats with a rear independent suspension and a 6 speed. Hell, if I come out of 1st into 2nd to hard, I can blow the tires off with those run craps.
Bludog is offline   Reply With Quote
Old 02-04-2011, 10:48 PM   #11
12 Second Club
 
Joeyelbows's Avatar
 
Trader Rating: 0
Join Date: Jul 2008
Posts: 119
Default

You should definitly be low 12's high 11's! With my heavy *** gto i did 12.1 at 114.35. So with your vette you should definitly be faster especially since you weigh like 800lbs lighter then me.
__________________
Mods: GT2-3 cam,patriot gold springs, Harland rockers, American racing headers and catted mids, Corsa exhaust, Ligenfelter CAI, pedder suspension, 385HP/380TQ tuned by tom, 12.18 at 114.35 PB with a 1.78 60' ft. Lost my gto on 1-28-12. RIP honeybee.
Joeyelbows is offline   Reply With Quote
Old 02-05-2011, 02:35 PM   #12
Launching!
 
z28camaro1090's Avatar
 
Trader Rating: 0
Join Date: Mar 2008
Location: West Chester PA
Posts: 208
Default

My friend went high 11's with just long tubes and exhaust definitely a high 11's car no doubt..
__________________
1993 Camaro Z28 --A4, 52mm BBK throttle body, cai, flowmaster exhaust
1998 Camaro Z28 -- SLP lid,FRA,smooth bellow, P&P TB, Magnaflow C/B,LS6 intake,Energy M&T mount,A4. before tune 13.18 @ 107.84 60ft 2.1 Tuned by CSP 322rwhp/333rwtq
2004 Saab 9-3 ARC-- Stock DD
z28camaro1090 is offline   Reply With Quote
Old 02-05-2011, 02:43 PM   #13
TECH Addict
 
Trader Rating: 7
Join Date: Sep 2010
Posts: 2,120
Default

There is way more left in that setup.. im stock ls1 with lid and exhaust A4 with 145k miles on drag radials and no tune... Youre only half a second faster???
__________________

ANTICOP RAM AIR is offline   Reply With Quote
Old 02-05-2011, 04:50 PM   #14
Restricted User
 
Trader Rating: 12
Join Date: Feb 2010
Location: kansas
Posts: 1,794
Default

half a second is actually alot... And like stated before, he needs sticky tires.
z99ls1 is offline   Reply With Quote
Old 02-19-2011, 08:34 AM   #15
TECH Junkie
 
s346k's Avatar
 
Trader Rating: 4
Join Date: May 2005
Location: johnson co.
Posts: 3,433
Default

Quote:
Originally Posted by Bludog View Post
I tried to read your sig, but don't see any posted times, et's, or what you did in the 1/4. I agree I probably should be low 12's, but I am running on run flats with a rear independent suspension and a 6 speed. Hell, if I come out of 1st into 2nd to hard, I can blow the tires off with those run craps.
the car was at an 1/8 mile track, so it's hard to tell what it would've ran on that pass, what was your 1/8 et and trap? and yes, i know you have an ls2 car, just mistyped. i'm not sure how bad the runflats are, but i know my bfg kdws aren't anything to write home about haha. there were a few bolt-on, fullweight m6 fbodies around here last year that were going 113-114 in the 1/4. just seems like a vette with a better motor would do...better, that's all. maybe the car just needs to get better acquainted with the 1/4 mile haha.
__________________
no more lsex in my garage. caught vette fever, though.
s346k is offline   Reply With Quote
Old 03-06-2011, 05:54 PM   #16
Launching!
 
BStowers023's Avatar
 
Trader Rating: 0
Join Date: Sep 2009
Location: Gulfport, MS / Columbus, OH
Posts: 227
Default

since when does a 113 trap speed = high 11s? Maybe with a 1.4 60ft
BStowers023 is offline   Reply With Quote
Old 03-06-2011, 08:31 PM   #17
12 Second Club
 
Bludog's Avatar
 
Trader Rating: 0
Join Date: Jan 2011
Location: South Chicagoland
Posts: 12
Default

Quote:
Originally Posted by BStowers023 View Post
since when does a 113 trap speed = high 11s? Maybe with a 1.4 60ft
I think the car should run low 12's. Not sure about high 11's. The F1 Supercar tires (run flats) are very hard to get good launches without wheel hop. (Even with the psi @ 24. The weakest link on a C6 Corvette is the rear differential. The transmission is actually bolted to the differential, so when you break a rear end, you are also destroying your transmission. I do enjoy going to the track, but I did not buy this car just to take it to the track. I am getting ready to build an F Body with a solid axle that I can enjoy alot more than an independant rear suspension vehicle at the drag strip.
Bludog is offline   Reply With Quote
Old 03-07-2011, 10:08 AM   #18
Launching!
 
BStowers023's Avatar
 
Trader Rating: 0
Join Date: Sep 2009
Location: Gulfport, MS / Columbus, OH
Posts: 227
Default

Not ******* on you man, those aren't bad times but I was just wondering why some people were saying with that trap you should easily be high 11s
BStowers023 is offline   Reply With Quote
Old 03-07-2011, 10:08 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
12, sec, vette


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 05:33 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details