Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Appearance & Detailing
Sign in using an external account
Register Forgot Password?
Search

Appearance & Detailing
Interior & Exterior Appearance Modifications
Sponsored by
Professional Car Care

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 05-04-2005, 01:52 PM   #1
TECH Junkie
Garage is empty, add now
 
verbs's Avatar
 
Trader Rating: 0
Join Date: Jan 2002
Location: At the office
Posts: 3,017
Send a message via AIM to verbs Send a message via Yahoo to verbs
Default Right side turn signal keeps going out, what gives? Something making it short/blow?

After my right signal went out, I replaced all the bulbs, and it worked fine for a few days. Then the bulb went out again, so I replaced the popcorn front bulb again, and it worked fine......and now it's busted again a few days later.

Is there something that could be causing it to blow/short? The bulb isn't black, cracked or melted ever, and the turn signal light on my car speedo just says on when it goes.
__________________
My overweight CTS-V posts on an Obesity Forum and doesn't fall for an African Mango Scam

Last edited by verbs; 05-04-2005 at 02:01 PM..
verbs is offline   Reply With Quote
Old 05-04-2005, 01:59 PM   #2
10 Second Club
Garage is empty, add now
 
Z'mnypit's Avatar
 
Trader Rating: 58
Join Date: Jan 2004
Posts: 2,712
Default

Does the lens have water in it? Mine used to do that & it had just a little bit of water, not much at all but as soon as the water hit the bulb it would blow.
__________________
2006 LS1tech Calendar cover car

Sold and missed: 99 Z28 M6 PICS AND INFO

http://i3.photobucket.com/albums/y98/99camaro/1testcopysig.gif
Z'mnypit is offline   Reply With Quote
Old 05-04-2005, 02:01 PM   #3
TECH Junkie
Garage is empty, add now
 
verbs's Avatar
 
Trader Rating: 0
Join Date: Jan 2002
Location: At the office
Posts: 3,017
Send a message via AIM to verbs Send a message via Yahoo to verbs
Default

Quote:
Originally Posted by 99PewterZ28
Does the lens have water in it? Mine used to do that & it had just a little bit of water, not much at all but as soon as the water hit the bulb it would blow.
No, I had that problem years ago but drilled holes in the lens housing so no worries there. I also didn't see any in the lens housing when I took it out 2 weeks ago. That and the car hasn't seen rain in months.
__________________
My overweight CTS-V posts on an Obesity Forum and doesn't fall for an African Mango Scam
verbs is offline   Reply With Quote
Old 05-05-2005, 09:01 AM   #4
TECH Junkie
Garage is empty, add now
 
verbs's Avatar
 
Trader Rating: 0
Join Date: Jan 2002
Location: At the office
Posts: 3,017
Send a message via AIM to verbs Send a message via Yahoo to verbs
Default

maybe i need to change my blinker fluid
__________________
My overweight CTS-V posts on an Obesity Forum and doesn't fall for an African Mango Scam
verbs is offline   Reply With Quote
Old 05-05-2005, 01:09 PM   #5
10 Second Club
Garage is empty, add now
 
WAHUSKER's Avatar
 
Trader Rating: 4
Join Date: Feb 2004
Location: Marysville, WA
Posts: 9,448
Default

A buddy of mine had that problem. Turned out to be the wiring in the steering wheel (tilt chafes it).
WAHUSKER is offline   Reply With Quote
Old 05-05-2005, 05:12 PM   #6
TECH Fanatic
2000 Chevrolet Camaro
 
Swang's Avatar
 
Trader Rating: 1
Join Date: Apr 2005
Location: Hometown:Mount Carmel, IL Current: Las Vegas, NV
Posts: 1,121
Send a message via MSN to Swang
Default

also make sure one of the bulbs isnt out, itll stick sometimes if thats the case.
__________________
Arctic White 2000 SS Camaro M6 #6158
Hurst | SLP SS Grille | SLP CME | SLP Lid | LS7 Clutch| SLP Bilsteins | Strano Springs | Strano Hollow Swar Bars
Swang is offline   Reply With Quote
Old 05-05-2005, 05:13 PM   #7
TECH Fanatic
2000 Chevrolet Camaro
 
Swang's Avatar
 
Trader Rating: 1
Join Date: Apr 2005
Location: Hometown:Mount Carmel, IL Current: Las Vegas, NV
Posts: 1,121
Send a message via MSN to Swang
Default

ignore last post, thought you meant the signal would stick. my GT has a fog light that keeps cracking because of subtle vibration. i dunno man, just ignore that last post of mine
__________________
Arctic White 2000 SS Camaro M6 #6158
Hurst | SLP SS Grille | SLP CME | SLP Lid | LS7 Clutch| SLP Bilsteins | Strano Springs | Strano Hollow Swar Bars
Swang is offline   Reply With Quote
Old 05-05-2005, 06:20 PM   #8
Launching!
Garage is empty, add now
 
Trader Rating: 9
Join Date: Jun 2004
Location: Lafayette, IN
Posts: 208
Default

My passenger side front signal does the same thing, bulb totally shatters, seems like it get a lot hotter than the other, all the orange color burns off, then they dont match....bugs the **** out of me!!
jsnone1 is offline   Reply With Quote
Old 05-05-2005, 08:17 PM   #9
11 Second Club
1999 Chevrolet Camaro
 
hugger1975's Avatar
 
Trader Rating: 3
Join Date: Sep 2004
Location: Plainfield, IL
Posts: 735
Send a message via MSN to hugger1975
Default

mine did that till
i drilled a hole in th bottom.

make sure no condensation is building in there either.

drove me nuts for a year
hugger1975 is offline   Reply With Quote
Old 05-05-2005, 08:54 PM   #10
Launching!
Garage is empty, add now
 
Trader Rating: 9
Join Date: Jun 2004
Location: Lafayette, IN
Posts: 208
Default

how big of a hole did you drill in the btm of the housing?
jsnone1 is offline   Reply With Quote
Old 05-05-2005, 10:34 PM   #11
TECH Senior Member
Garage is empty, add now
 
Brandon Boomhauer's Avatar
 
Trader Rating: 10
Join Date: Nov 2001
Location: Gainesville, Denton TX
Posts: 8,768
Send a message via ICQ to Brandon Boomhauer Send a message via AIM to Brandon Boomhauer Send a message via MSN to Brandon Boomhauer Send a message via Yahoo to Brandon Boomhauer
Default

ah damnit, i never thought of drilling a hole

I had to replace mine several times, cleaned it out pretty good, used dyelectric grease to holy hell, and its been fine lately
*knock on wood*
Brandon Boomhauer is offline   Reply With Quote
Old 05-05-2005, 11:10 PM   #12
Launching!
Garage is empty, add now
 
WS6GoFast's Avatar
 
Trader Rating: 0
Join Date: Mar 2005
Location: Columbia MO, Carlyle IL
Posts: 274
Send a message via AIM to WS6GoFast
Default

I have this same problem. Dose the bulb just stay on because tahts what mine does. I found that there is a spefic spot the bulb has to be in pushed all the way in mine will stay solid when i hit the signal but there is one spot when i wiggle the bulb that my signal works. Im prety sure its a bad socket for the light that is doing it but i think the part is $45 so ill just wiggle the bulb when it stops working
hope this helps
__________________
-Matt
02 Black T/A WS.6 M6 #9749 -Sold
http://i2.photobucket.com/albums/y16...k/4-17_2-1.jpg
WS6GoFast is offline   Reply With Quote
Old 05-05-2005, 11:22 PM   #13
TECH Senior Member
Garage is empty, add now
 
Brandon Boomhauer's Avatar
 
Trader Rating: 10
Join Date: Nov 2001
Location: Gainesville, Denton TX
Posts: 8,768
Send a message via ICQ to Brandon Boomhauer Send a message via AIM to Brandon Boomhauer Send a message via MSN to Brandon Boomhauer Send a message via Yahoo to Brandon Boomhauer
Default

i remember reading that you can get the socket from autozone for like 14-15 bucks, compared to the stealership pricing. only difference is the wiring isnt color coded, but should be fairly easy to figure out..
Brandon Boomhauer is offline   Reply With Quote
Old 05-06-2005, 01:22 AM   #14
Staging Lane
Garage is empty, add now
 
LS_WANG's Avatar
 
Trader Rating: 0
Join Date: May 2005
Posts: 82
Default

Same issue/problem here, I notice my right turn signal not flickering today and looked at my clear corners only to find that my $10 hyper white bulb shattered!!! It rained last night and I notice the rubber around my headlight being really far back and that water had filled the turn signal. So I will go buy a new bulb and adjust the rubber when I put on my halo's. Thanks guys
__________________
http://www.diolar.com/images/ss_sized.jpg


JUST AN SS WITH BASIC BOLT ON'S!!!
LS_WANG is offline   Reply With Quote
Old 05-06-2005, 08:23 PM   #15
TECH Enthusiast
Garage is empty, add now
 
nvrstsfd23's Avatar
 
Trader Rating: 0
Join Date: May 2004
Location: hamilton, Ohio
Posts: 549
Default

mine were cracked and the socket messed up but the warranty covered em.
nvrstsfd23 is offline   Reply With Quote
Old 05-06-2005, 09:41 PM   #16
TECH Enthusiast
Garage is empty, add now
 
Trader Rating: 4
Join Date: Dec 2004
Location: Raleigh, nc
Posts: 665
Default

Stupid question , but how DO you change the right turn signal, mines is out also. I cnat seem to find out where the bult goes into the light...
BlackTA98 LS1 is offline   Reply With Quote
Old 05-06-2005, 10:02 PM   #17
RIP April 14, 2008
Garage is empty, add now
 
Diolar Magnum's Avatar
 
Trader Rating: 0
Join Date: Aug 2004
Location: the land where cars repeatedly hit my bumper when I'm in the store...
Posts: 1,618
Send a message via AIM to Diolar Magnum
Default

Quote:
Originally Posted by BlackTA98 LS1
Stupid question , but how DO you change the right turn signal, mines is out also. I cnat seem to find out where the bult goes into the light...
use a 10mm ratchet and open the trapdoor under the front bumper on the right/left side, reach up, above the fog lights, and the turn signal socket is on the TOP of the signal shell. or you could take out your headlight to get to it from the top but thats a PITA. oops you have a T/A so do it the first way.

Brad
__________________
http://i4.photobucket.com/albums/y12...s_08142005.jpg
"Ophelia" - 1998 SSM A4 Z28 - 12 (twelve) rwhp

R.I.P Brad ...You will be missed.

-Your friends at LS1Tech.
Diolar Magnum is offline   Reply With Quote
Old 05-06-2005, 10:02 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
blinker, blowing, blows, bulb, camaro, car, front, halos, light, out, put, signal, signals, turn, turning


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Right Front Turn Signal ZouMechE New LS1 Owners - Newbie Tech 3 01-21-2014 09:11 PM
Keep blowing a fuse, no turn signals/back up lights ACDenali Stereo & Electronics 6 07-03-2013 05:05 PM
Odd Bulb Out DisasterFormula Stereo & Electronics 8 05-04-2013 02:42 AM
Front turn signals oh1ws6 Stereo & Electronics 9 10-17-2012 02:51 AM
Turn Signal Bulb Keeps Blowing Out, Help!! nikeair042 Appearance & Detailing 16 03-06-2006 03:05 AM



All times are GMT -5. The time now is 03:26 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details