Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Automatic Transmission
Sign in using an external account
Register Forgot Password?
Search

Automatic Transmission
4L60E | 4L80E | TH350 | TH400 | TH2004R | Powerglide | Converters | Shift Kits
Sponsored by
PerformaBuilt Transmissions

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 07-02-2009, 09:43 PM   #1
Staging Lane
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jul 2005
Location: usa
Posts: 56
Default 4l80e line pressure

What's the line pressure supposed to be in a 4l80e manual valve body transmission? Better yet a transgo stage 3 kit at idle and load?

My 4l80e died out on me after 600 miles. My line pressure is:

120 idle
205 reverse
1-4 gears cruizing 90-120
typically when downshifting to 2nd and doing wide open throttle it's at 90psi and stays at 90psi and slips.

Obviously my transmission pump is out and or the valve body needs some attention.

If need be i can upload a video of the gauge readings

setup: 4l8i0e, manual valve body, forward pattern pull back to downshift, locking converter, stage 3 transgo.
Rolemodel is offline   Reply With Quote
Old 07-03-2009, 12:53 PM   #2
TECH Enthusiast
Garage is empty, add now
 
Trader Rating: 14
Join Date: Sep 2005
Location: North Texas
Posts: 521
Default

You'll see about 160-180 in forward gears with slight throttle. 275-300+ in reverse.
Somethings not right with your kit.
Are you using the vacuum modulator or a dead EPC?
jakeshoe is offline   Reply With Quote
Old 07-03-2009, 06:32 PM   #3
Staging Lane
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jul 2005
Location: usa
Posts: 56
Default

Quote:
Originally Posted by jakeshoe View Post
Are you using the vacuum modulator or a dead EPC?
I am just using the transgo stage 3 kit. Vacume modulator? I have no electronics going to my transmission i only have a vacume line which is supposed to lower line pressure when the car is in vacume. however when disconnected that line i noted no pressure change on the line pressure.
Rolemodel is offline   Reply With Quote
Old 07-06-2009, 03:42 PM   #4
Launching!
Garage is empty, add now
 
Trader Rating: 2
Join Date: Dec 2008
Location: Cypress, TX
Posts: 294
Default

2nd gear on my 80e with transgo-3 is much higher, as Jakeshoe says above, the line pressure on mine is 150+ in all forward gears at idle, 220+ in reverse. Light load driving it is 175+ in forward gears. WOT I can't say for sure, my car is too hard to drive and watch the gauge at the same time.

I wasn't 100% happy with my transgo kit at first due to slow 2-3 shifts, but it has held up to several dyno pulls in 3rd with the converter locked, plus 2000 miles on the street, so I don't think it is fair to blame the design of the kit. I did a DIY rebuild, my first 4l80e, so it doesn't require a pro, just need to be careful and check everything twice. I bet my slow 2-3 shift is because I set up a clutch pack too loose, not because of a fault in the design of the transgo-3 kit. I will say that the instructions in the kit are not really very clear, especially if you don't build transmissions for a living.

The vacuum modulator is inside the pan, looks just like one from a th400, but the end is machined off shorter. I assume from your post you didn't do the work yourself, if so perhaps you should take it back to the people who did the work.
twinturbo496 is offline   Reply With Quote
Old 07-06-2009, 03:47 PM   #5
Launching!
Garage is empty, add now
 
Trader Rating: 2
Join Date: Dec 2008
Location: Cypress, TX
Posts: 294
Default

What shifter are you using? Are you 100% certain that the detent in the shifter lines up with the detent in the transmission? I had both a Hurst and a B&M that did NOT line up correctly, in the end I cut the bracket that goes on a TH400 and modified it to line up with the 4L80E detents.
twinturbo496 is offline   Reply With Quote
Old 07-06-2009, 09:06 PM   #6
TECH Fanatic
Garage is empty, add now
 
forcd ind's Avatar
 
Trader Rating: 2
Join Date: Sep 2007
Location: woodbine, md
Posts: 1,831
Default

kind of a dump question, but is the fluid level correct-i know when i had my gauge hooked up, it would still build pressure as i poured the last couple quarts of fluid in
i had low pressure with the man. kit, when i switched out to an auto v/b
and compushift controller, i had much better pressure
forcd ind is offline   Reply With Quote
Old 07-07-2009, 04:38 AM   #7
Staging Lane
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jul 2005
Location: usa
Posts: 56
Default

Quote:
Originally Posted by twinturbo496 View Post
What shifter are you using? Are you 100% certain that the detent in the shifter lines up with the detent in the transmission? I had both a Hurst and a B&M that did NOT line up correctly, in the end I cut the bracket that goes on a TH400 and modified it to line up with the 4L80E detents.
b&M shifter i believe it lines up pretty well. I am not able to perform the work as I crashed a motorcycle and still recovering. Yes a transmission builder built the transmission i am pulling it out tomorrow and he said something is wrong iwth it.
Rolemodel is offline   Reply With Quote
Old 07-07-2009, 04:38 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
4l80, 4l80e, body, downshift, idle, jakeshoe, line, low, modulator, pressure, rebuild, shift, transmission, tuning, valve, wot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cost to fix valve body on 4l80e transgo st3 Rolemodel Automatic Transmission 6 06-24-2010 03:18 PM
4l80e manual valve body - downshifted unexpectively Rolemodel Automatic Transmission 11 06-02-2010 02:25 PM
4L80E Shift kit & manual valve body ? Randy WS6 Automatic Transmission 17 11-30-2008 07:05 AM
Self Rebuilt 4L60E Problem Only When Hot redvet99 Automatic Transmission 39 05-16-2007 09:56 AM



All times are GMT -5. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details