2001 Bravada 4L60E Problem - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Automatic Transmission
Log In 
Search


Automatic Transmission
4L60E | 4L80E | TH350 | TH400 | TH2004R | Powerglide | Converters | Shift Kits
Sponsored by
PerformaBuilt Transmissions


2001 Bravada 4L60E Problem

Reply
 
Thread Tools Search this Thread
Old 04-03-2012, 12:51 AM   #1
Registered User
 
Trader Rating: 0
Join Date: Apr 2012
Location: Ohio
Posts: 2
Send a message via Skype™ to AGurky
Post 2001 Bravada 4L60E Problem

Hello everyone! Newbie here!
I just picked up a 2001 4x4 Bravada. My problem
is when you start it transmission works great.
Forward, reverse and so on. After it warms up
(about 5 min) I get nothing. No reverse, no 1,2,
3 or 4. Fluid color is good. No burnt smell. Kinda
has a sweet smell actually. Never had trans fluid
smell sweet before this one. I picked up a new boost
valve and filter kit. I figured I would change the fluid
to dex VI and replace the boost valve with a .49, any
thoughts would be great. I was thinking possibly the
seal for the filter was the problem. Fluid level is correct.
Thanks in advance!

Adam
AGurky is offline   Reply With Quote
Old 04-03-2012, 03:42 AM   #2
TECH Apprentice
 
GMRACER13's Avatar
 
Trader Rating: 1
Join Date: Jul 2006
Location: Tampa, FL
Posts: 308
Send a message via AIM to GMRACER13
Default

Sounds like something has come apart and is clogging the filter. Drop the pan and inspect it for debris.
__________________
-Chris-

'95 Camaro Z28
GMRACER13 is offline   Reply With Quote
Old 04-04-2012, 12:02 AM   #3
Registered User
 
Trader Rating: 0
Join Date: Apr 2012
Location: Ohio
Posts: 2
Send a message via Skype™ to AGurky
Default

Ok after I pulled the pan off. I found needle bearings in the pan. So I am guessing either a torrington bearing or a planetary bearing is bad. So it seems I will not get a quick fix on this one. Just my luck LOL.
AGurky is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Valve springs/timing chain LS BRAVADA Cadillac CTS-V 23 03-03-2014 12:53 PM
WTB: cam for project LS BRAVADA Parts Wanted 2 07-18-2013 04:13 PM
4l80e forward in reverse and neutral mikeselky85 Automatic Transmission 5 06-17-2012 09:03 PM
4l60e problems no reverse andry3000 Automatic Transmission 8 05-07-2012 11:01 PM
ls1 bravada ls1bravada Vehicles Wanted 0 05-23-2011 10:12 AM


Tags
2000, 2001, 4l60e, bad, bearing, bearings, bravada, filter, forward, needle, problems, reverse, signs, torrington, transmission, warms


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details