false knock methinks - LS1TECH

Log In 


Cadillac CTS-V 2004-2007 (Gen I)
The Caddy with an Attitude...

false knock methinks

Reply
 
Thread Tools Search this Thread
Old 05-10-2012, 07:14 AM   #1
On The Tree
Thread Starter
 
Join Date: Jan 2009
Posts: 153
Default false knock methinks

To the guys that dabble with tuning here. I'm having a hard time finishing off my TVS road tune.

I'm running a 2bar SD OS, VVE tables are spot on, IATs are good, MAF is off, AFRs under boost are a nice 11-11.3 at max, so just working on finalizing the high octane tables. I'm doing pulls in 5th gear from 2-5k rpm. At around 4k (apcyl .98-1.00) I'm seeing 6 degrees KR. Pulled 6 degrees in the affected cells, did another run and I see 6 degrees KR again. Boost I'm pegging at 13 psi on the TVS. Running 91 ethanol free gas.

Was running 18 degrees in those cells, pulled it back to 12. Same result.

Car runs strong, don't hear pinging or anything out of the ordinary.

Kind of baffled now and thinking this is false knock. My knock sensors are fresh. From what I read few things to check are torque on knock sensors and if anything may be making contact with the frame/engine. I know my driveline is a bit shot (diff on its way out, DS is not 100% balanced). Only other odd thing is my bank 2 precat o2 is sometimes reading 10% leaner than bank 1 but I see this in many other cars I've logged also so not sure.

Kind of curious if anyone has any outlandish ideas here.

Last edited by ichpen; 05-10-2012 at 07:20 AM.
ichpen is offline   Reply With Quote
Old 05-10-2012, 08:22 AM   #2
DMM
TECH Fanatic
 
DMM's Avatar
 
Join Date: Jul 2010
Location: Maryland
Posts: 1,757
Default

You should be fine at 18* if your fueling is spot on (fuel press, injectors, etc.). While this does not sound like typical "burst knock" conditions, there is a possibility that this could be what is happening.

I would try going into "Spark"--->"Retard" and under "Burst knock" select the "Enable Delta Cylinder Air" and desensitize the sensors a tad bit to see if this helps. I had to do this on the V and the truck, but I have the knock sensors in the valley...and I was having issue's like this at around 2k RPM.

Even though you are pretty safe at 11.0-11.3, I would add a little more fuel JIC you have a single fuel injector that's lagging behind the rest.

This is the PITA stuff that could be caused by any number of things and it gets really frustrating. Good luck!
DMM is offline   Reply With Quote
Old 05-10-2012, 09:06 AM   #3
TECH Apprentice
iTrader: (4)
 
Join Date: Jan 2010
Location: GA
Posts: 331
Default

I'm with DMM. Disable burst knock COMPLETELY and see if it goes away. Mine is off all the time, thats burst knock not regular knock retard. (Before someone tells me I'm crazy).
CancerJCC is offline   Reply With Quote
Old 05-10-2012, 09:12 AM   #4
TECH Fanatic
iTrader: (2)
 
wcryan's Avatar
 
Join Date: Apr 2011
Location: Escondido CA
Posts: 1,681
Default

^ your crazy..... just cause
wcryan is offline   Reply With Quote
Old 05-10-2012, 09:16 AM   #5
TECH Apprentice
iTrader: (4)
 
Join Date: Jan 2010
Location: GA
Posts: 331
Default

Quote:
Originally Posted by wcryan View Post
^ your crazy..... just cause
Damnit. Haha
CancerJCC is offline   Reply With Quote
Old 05-10-2012, 02:39 PM   #6
On The Tree
Thread Starter
 
Join Date: Jan 2009
Posts: 153
Default

Quote:
Originally Posted by DMM View Post
You should be fine at 18* if your fueling is spot on (fuel press, injectors, etc.). While this does not sound like typical "burst knock" conditions, there is a possibility that this could be what is happening.

I would try going into "Spark"--->"Retard" and under "Burst knock" select the "Enable Delta Cylinder Air" and desensitize the sensors a tad bit to see if this helps. I had to do this on the V and the truck, but I have the knock sensors in the valley...and I was having issue's like this at around 2k RPM.

Even though you are pretty safe at 11.0-11.3, I would add a little more fuel JIC you have a single fuel injector that's lagging behind the rest.

This is the PITA stuff that could be caused by any number of things and it gets really frustrating. Good luck!
Good suggestions guys.

Burst spark I've always zeroed out as I know it always used to introduce KR even just blipping the throttle from idle. I'll desensitize the sensors a bit but...

Having said that the KR is now gone. I'm effing confused.

2 things that changed:
1. I refueled
2. I upped my boost a pump level from 20 to 30% just on the off chance that pressure is dropping albeit AFRs are good

Low and behold it seems to have disappeared in those cells so it was/is either a) bad gas b) fuel pressure drop but AFRs were perfect (maybe this is the small delay factor) or maybe I just was running borderline.

Could have been a fluke also but I did 4 solid pulls and 0 KR across the board.

Now not sure what to do. Guess I'll do more pulls and see if this comes back.

Thank you though.
ichpen is offline   Reply With Quote
Old 05-10-2012, 02:47 PM   #7
DMM
TECH Fanatic
 
DMM's Avatar
 
Join Date: Jul 2010
Location: Maryland
Posts: 1,757
Default

Quote:
Originally Posted by ichpen View Post
Now not sure what to do.
Leave it alone! LOL My guess is that you have 1 injector that does not flow the same as the others (unless they were flow matched) and the extra fuel made up for it.
DMM is offline   Reply With Quote
Old 05-10-2012, 03:00 PM   #8
On The Tree
Thread Starter
 
Join Date: Jan 2009
Posts: 153
Default

Quote:
Originally Posted by DMM View Post
Leave it alone! LOL My guess is that you have 1 injector that does not flow the same as the others (unless they were flow matched) and the extra fuel made up for it.
Allegedly flow matched but yeah will let it be.
ichpen is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
knock on first pull only ToxicWS6 Forced Induction 5 07-22-2015 01:58 PM
turbo KR* question crf538 Forced Induction 11 01-10-2009 12:27 AM
Successfully desensitized my knock sensors with HPTuners Another_User PCM Diagnostics & Tuning 7 11-07-2004 07:38 PM
KR, timing retard and knock counts broke7 PCM Diagnostics & Tuning 3 12-26-2002 04:19 AM
Tips from LT1 EDIT for LS1 Edit!! Mike TexaSS PCM Diagnostics & Tuning 14 07-15-2002 09:41 AM


Tags
09, 2009, activate, burst, cadallac, ctsv, delta, false, knock, knocking, ls1, retard, sensor, supercharger, tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:17 AM.