AC/Controls - Light out! Help! - LS1TECH

Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > Chevrolet Camaro 1967-2002
Log In 
Search


Chevrolet Camaro 1967-2002 The forum for diehard Camaro fans


AC/Controls - Light out! Help!

Reply
 
Thread Tools Search this Thread
Old 01-20-2011, 02:56 PM   #1
On The Tree
 
SLPCAMAROSS's Avatar
 
Trader Rating: 0
Join Date: Jan 2004
Location: Miami
Posts: 161
Send a message via AIM to SLPCAMAROSS
Exclamation AC/Controls - Light out! Help!

Hey guys, I have been driving around for over 6 months now without a "lit up" AC unit on my 01 SS. Just realized it's been out lol and I can't see anything at night as far as heat/ac adjustments go etc..

What the hell type of bulb is this? Im pretty sure it's not a fuse cause I already checked twice. Im guessing I just have to pull the entire AC unit out and replace a bulb from behind?

Any experience with this or suggestions will be greatly appreciated! Thanks!
__________________
01' LS3 427, SLP "SS" BEAST


Need A Website?
www.UniversalWebsiteCreations.com
SLPCAMAROSS is offline   Reply With Quote
Old 01-23-2011, 10:46 PM   #2
On The Tree
 
SLPCAMAROSS's Avatar
 
Trader Rating: 0
Join Date: Jan 2004
Location: Miami
Posts: 161
Send a message via AIM to SLPCAMAROSS
Smile

Finally got it! Pulled the a/c unit out and found 2 bulbs that needed to be replAced. Took pix for anyone that comes across the same problem
__________________
01' LS3 427, SLP "SS" BEAST


Need A Website?
www.UniversalWebsiteCreations.com
SLPCAMAROSS is offline   Reply With Quote
Old 01-24-2011, 07:30 AM   #3
TECH Apprentice
 
super_fro_daddy's Avatar
 
Trader Rating: 29
Join Date: Feb 2005
Location: The 906 (Sault Ste. Marie MI)
Posts: 348
Default

Quote:
Originally Posted by SLPCAMAROSS View Post
Took pix for anyone that comes across the same problem
Lets see them, haven't had that problem with any of my f-bodies, but truck has a bunch out.

Thanks.
__________________
Quote:
Originally Posted by Studytime View Post
That means that your car was actually assembled in mexico and it's a thousand wonders that it's still running. They didn't use rod or main bearings at that plant- everything was metal on metal.
super_fro_daddy is offline   Reply With Quote
Old 01-24-2011, 12:09 PM   #4
On The Tree
 
SLPCAMAROSS's Avatar
 
Trader Rating: 0
Join Date: Jan 2004
Location: Miami
Posts: 161
Send a message via AIM to SLPCAMAROSS
Default

Quote:
Originally Posted by super_fro_daddy View Post
Lets see them, haven't had that problem with any of my f-bodies, but truck has a bunch out.

Thanks.
Here ya go... They were little tiny bulbs that were hidden behind the panel when you pull it out. I turned them sideways and they popped right out. They were connected to a harness that I thought was bad, but after taking the bulbs out (had to actually break them and pull them with a plyer) I replaced them and it's working perfect now. Advanced Auto carried the bulbs..


BTW the ***** didn't have to come off.. I realized that after I had the whole thing apart.
Attached Thumbnails
AC/Controls - Light out! Help!-get-attachment-1.jpg   AC/Controls - Light out! Help!-get-attachment-2.jpg  
__________________
01' LS3 427, SLP "SS" BEAST


Need A Website?
www.UniversalWebsiteCreations.com
SLPCAMAROSS is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 07:46 AM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details