Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > Chevrolet Camaro 1967-2002
Sign in using an external account
Register Forgot Password?
Search

Chevrolet Camaro 1967-2002 The forum for diehard Camaro fans

99 Z28 M6 I just picked up. With issues!

Reply
 
Thread Tools Search this Thread
Old 07-31-2012, 02:45 PM   #1
Staging Lane
 
Trader Rating: 2
Join Date: Apr 2010
Posts: 97
Default 99 Z28 M6 I just picked up. With issues!

Ok, like the headline says. I just bought a 99 Z28 M6 car and it is set up really nice. But I have a few concerns with the car.

First of all it has a Dynomax bullet cat back on it and it is way to loud to drive everyday (without getting tickets) and I would like to quiet it down some. Any ideas other than putting a different cat back on it? I am thinking about taking the muffler out of the cat back and replacing it with a spintech low profile sportsman muffler.

Second, the steering column i think might be broken internally. The steering wheel you can pull down in the direction of 7 o'clock an 1 1/2". The dimmer switch doesn't work unless you pull the column down in this direction.

Third, the cruise control doesn't work at all. Might be from the column being broken. Not sure what to check out first. Is there a way to check out the cruise?
__________________
1999 Z28 M6 SOLD
1987 IROC 5.3 M6 with a T-70 Almost Done
2003 Silverado SS, Maggy 112, CIA, Flowmaster
speedfreak391 is offline   Reply With Quote
Old 08-02-2012, 12:29 PM   #2
Staging Lane
 
Trader Rating: 2
Join Date: Apr 2010
Posts: 97
Default

No one can help?
__________________
1999 Z28 M6 SOLD
1987 IROC 5.3 M6 with a T-70 Almost Done
2003 Silverado SS, Maggy 112, CIA, Flowmaster
speedfreak391 is offline   Reply With Quote
Old 08-02-2012, 04:01 PM   #3
Launching!
 
Trader Rating: 6
Join Date: Sep 2011
Location: Florida
Posts: 226
Default

i have a flowmaster catback thats not very loud but gives a very nice tone,
just needs to be cleaned up a bit.
interested in trade?
__________________
1998 t/a- just another 13 second "cam only" ls1 with a stalled th400 and a 8.8
Cooldude5231 is offline   Reply With Quote
Old 08-02-2012, 09:17 PM   #4
Teching In
 
02sunsetorangeZ's Avatar
 
Trader Rating: 0
Join Date: Mar 2012
Posts: 4
Default

the pins break real easy on the column have to get a new column and gm doesnt sell them have to get one at junk yard or just not worry about it. mines been broke for awhile and still works fine
__________________
2002 sunsetorange z28 m6 SS long tubes, 3inch duals x pipe over the axle 2 magnaflow bullets, ngk TR-55 iridium plugs, MSD 8.5mm plugs ported and polished TB, level 2 tick transmission, ls7 clutch, 3.73 gears, pro 5.0 w/lous short stick 160 t-stat, slp lid, amsoil airfilter, smooth air bellow and a frost mail order tune
02sunsetorangeZ is offline   Reply With Quote
Old 08-02-2012, 10:28 PM   #5
On The Tree
 
Trader Rating: 0
Join Date: Jul 2012
Location: DFW, TX
Posts: 121
Default

I recommend trying a pick your own part junk yard, as they charge a flat fee and then weight for the part... it might be your cheapest bet, plus you'll have plenty of practice before trying to take your broken one out and put new one in....
omgitsmikeyc is offline   Reply With Quote
Old 08-06-2012, 12:51 PM   #6
TECH Resident
 
Trader Rating: 4
Join Date: Mar 2011
Location: Lancaster County, PA
Posts: 951
Default

well as far as the cruise not working, check that all your brake lights are working....no im serious......not sure which but if 1 of your brake lights is not workin, your cruise wont work either....
Floorman279 is offline   Reply With Quote
Old 08-06-2012, 01:53 PM   #7
Staging Lane
 
Trader Rating: 2
Join Date: Apr 2010
Posts: 97
Default

Quote:
Originally Posted by Floorman279 View Post
well as far as the cruise not working, check that all your brake lights are working....no im serious......not sure which but if 1 of your brake lights is not workin, your cruise wont work either....
Funny you should say that. The right side bulb in the center light in the wing is acting funny. Doesn't work when it's in the housing, but take it out and it works fine.
Also, I have been doing some reading on the other issues with the cruise and I will need to look at the switches on the brake and clutch pedal.

As far as the steering column goes I will take it apart and make sure all of the bolts are tight in there, since it sounds to be a common problem for them to loosen up.
__________________
1999 Z28 M6 SOLD
1987 IROC 5.3 M6 with a T-70 Almost Done
2003 Silverado SS, Maggy 112, CIA, Flowmaster
speedfreak391 is offline   Reply With Quote
Old 08-08-2012, 01:28 PM   #8
TECH Apprentice
 
Trader Rating: 9
Join Date: Jul 2011
Location: KS
Posts: 336
Default

i run a hooker aerochamber on my car and it sounds great, no interior drone, and when you open it up its loud enough to let people know you're coming. i had a sportsman dual outlet on my el camino and it was still pretty loud for dd. get on youtube and find one you like the sound of....i think pypes has some good quality stuff too.
__________________
1991 Z/28, 6.0L/T56 swap, has a cam in it...i think...
http://ls1tech.com/forums/chevrolet-...-t56-swap.html

1995 GMC Sierra 1500 RCSB
OutlawDrifter is offline   Reply With Quote
Old 08-12-2012, 11:27 PM   #9
TECH Resident
 
Trader Rating: 4
Join Date: Mar 2011
Location: Lancaster County, PA
Posts: 951
Default

Quote:
Originally Posted by speedfreak391 View Post
Funny you should say that. The right side bulb in the center light in the wing is acting funny. Doesn't work when it's in the housing, but take it out and it works fine.
Also, I have been doing some reading on the other issues with the cruise and I will need to look at the switches on the brake and clutch pedal.

As far as the steering column goes I will take it apart and make sure all of the bolts are tight in there, since it sounds to be a common problem for them to loosen up.
Well a few lights my center brake light flicker and ct up but my cruise does work
Floorman279 is offline   Reply With Quote
Old 08-12-2012, 11:27 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
1995, 2002, 410, 410s, 99, camaro, chevrolet, code, default, good, m6, t55, techcom, transmission, z28


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 03:26 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details