Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > Chevrolet Camaro 1967-2002
Sign in using an external account
Register Forgot Password?
Search

Chevrolet Camaro 1967-2002 The forum for diehard Camaro fans

Electrical Trouble..

Reply
 
Thread Tools Search this Thread
Old 06-29-2008, 10:18 AM   #1
Staging Lane
 
Trader Rating: 0
Join Date: Mar 2008
Posts: 77
Default Electrical Trouble..

Last night I noticed that my battery meter jumps around a little. It constantly flickers. Its not low, it stays right in the middle, it just flickers. It does is during the day as well. All the lights on the car do the same, including the dash light. I drove it for 100 miles last night and there were no problems. I thought maybe the altenator, but now i'm not so sure. Anyone have any ideas? fuse, wires, etc.?? Its a 1999 Camaro SS
__________________
2001 Silverado RCSB- 2/4 Drop, 20s, Shaved, 4.8, 212/218 Cam, Ported Polished 241 castings heads, Pacesetter LTs, Dyno Tune, Eaton Posi w/ 4.10s

1999 Camaro SS Convertible- White/white/white, dropped, 17s, A4, 3.73s, tuned by Jeremy in Lutz, FL
aaronk227 is offline   Reply With Quote
Old 06-29-2008, 10:18 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details