2001 S10 5.3 swap - LS1TECH

Log In 


Conversions & Hybrids LSX Engines in Non-LSX Vehicles
Sponsored by:
Sponsored by:

2001 S10 5.3 swap

Reply
 
Thread Tools Search this Thread
Old 08-24-2011, 11:14 PM   #1
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default 2001 S10 5.3 swap

I just though I would share some pics of my truck for you S10 guys.. I just completed the 5.3 swap and still working out the bugs.. feel free to ask any questions.. ill do my best to answer them... It is a 2001 S10 with a 2002 5.3 with TR224 cam, comp pushrods, comp 918 springs, LS2 timing chain, 4L60E trans with a TCI 4000 stall, narrowed 8.8 rear with 3:73 gear...










Last edited by widopn; 09-05-2011 at 02:57 AM.
widopn is offline   Reply With Quote
Old 08-24-2011, 11:16 PM   #2
11 Second Club
iTrader: (11)
 
yelo04goat's Avatar
 
Join Date: Dec 2008
Location: San Diego/ from the 316
Posts: 785
Default

not bad.. i wanted to do that to both my s10s hope to do a swap one day...


nice job man
yelo04goat is offline   Reply With Quote
Old 08-25-2011, 09:59 AM   #3
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

thanks man... ive worked hard on it...
widopn is offline   Reply With Quote
Old 08-25-2011, 10:36 AM   #4
Staging Lane
iTrader: (11)
 
Join Date: Jan 2010
Location: Grayslake, IL
Posts: 79
Default

Very nice. I just finished up my 95 s10 4.8 swap last night. Feels good to drive it again.
fat tony157 is offline   Reply With Quote
Old 08-26-2011, 02:08 AM   #5
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

I wish i could drive mine but unfortunately i had to have my tranny rebuilt after the first time out.. my builder is almost finished with it though so it should be back together by next weekend if no bad luck..
widopn is offline   Reply With Quote
Old 08-26-2011, 09:33 AM   #6
Staging Lane
iTrader: (11)
 
Join Date: Jan 2010
Location: Grayslake, IL
Posts: 79
Default

Yea thats the way it goes though, I had my swap done last week. But when I went out for the first time, i trashed a lifter and destroyed a cam lobe. Got it fixed now though. Put up some videos when you get the new trans installed.
fat tony157 is offline   Reply With Quote
Old 08-26-2011, 02:03 PM   #7
Launching!
iTrader: (7)
 
performinnorman's Avatar
 
Join Date: Apr 2009
Location: Lees Summit, MO (KC Metro)
Posts: 233
Default

That's a great lookin dime. I wish mine was that clean. I just finished an LS6/T56 swap on my 97 dime. Please throw up some vids when you get a chance.
performinnorman is offline   Reply With Quote
Old 08-27-2011, 01:20 PM   #8
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

Ill do my best to get some vids for you guys... I dont have tags on it at the moment but I am gonna take it to the track on Sept. 8th if all goes well... I have a video of the first time out to the track when i lost 3rd gear... I also hadnt got my rear end swap done before that day so i ended up just leaving the stock rear under it to make a couple test runs with it... It was open diff so of course i couldnt launch it and i had to pedal it as you can hear in the vid... with a 2.5 (lol) sixty foot and having no 3rd gear i rolled through at 15.34 lol

http://youtu.be/_9CsbHcj1qE
widopn is offline   Reply With Quote
Old 08-30-2011, 02:18 PM   #9
TECH Fanatic
iTrader: (1)
 
Sandmann120's Avatar
 
Join Date: Dec 2004
Location: SW Iowa
Posts: 1,017
Default

What headers?
Sandmann120 is offline   Reply With Quote
Old 08-31-2011, 05:22 AM   #10
On The Tree
 
Join Date: Aug 2011
Location: dora al
Posts: 152
Default

nice, I look foward to seeing what it runs
Jarred Hodges is offline   Reply With Quote
Old 08-31-2011, 04:48 PM   #11
11 Second Club
iTrader: (86)
 
the_merv's Avatar
 
Join Date: Mar 2006
Location: Arkansucks
Posts: 19,067
Default

Looks sharp.
the_merv is offline   Reply With Quote
Old 09-01-2011, 12:38 AM   #12
TECH Regular
 
Black98s10's Avatar
 
Join Date: Jun 2011
Location: Milwaukee, Wi.
Posts: 413
Default

Very nice, I'm looking to start my 5.3L lm7 swap in my 98 in a month or so. I'm gonna try to get a cam and a Procharger D1SC on the truck before May of next year.
Black98s10 is offline   Reply With Quote
Old 09-04-2011, 11:00 PM   #13
TECH Regular
 
Black98s10's Avatar
 
Join Date: Jun 2011
Location: Milwaukee, Wi.
Posts: 413
Default

Hey Widopn, any plans on going boost in the future?
Black98s10 is offline   Reply With Quote
Old 09-05-2011, 02:17 AM   #14
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

Thanks for all the positive feedback guys...

I am using Sanderson shorties from Current Performance ...

I might possibly look into forced induction some day but right now im just gonna enjoy it for a while... or untill something breaks lol
widopn is offline   Reply With Quote
Old 09-05-2011, 02:25 AM   #15
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

here is a couple pics with the grill back in ...




Last edited by widopn; 09-05-2011 at 03:20 AM.
widopn is offline   Reply With Quote
Old 09-05-2011, 03:25 AM   #16
TECH Junkie
iTrader: (28)
 
Join Date: Feb 2007
Location: Hawaii
Posts: 3,760
Default

My god that thing is clean. Gonna sell it or trade?
whytryz28 is offline   Reply With Quote
Old 09-05-2011, 03:58 AM   #17
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

Thanks... its not going anywhere lol.. that thing is a part of my life .. ive owned it since i was 15...

here is another engine pic that i forgot i had...
widopn is offline   Reply With Quote
Old 09-05-2011, 08:24 PM   #18
Staging Lane
iTrader: (2)
 
jashell1562's Avatar
 
Join Date: Aug 2007
Location: cleveland, tn
Posts: 96
Default

What mounts did you use?
jashell1562 is offline   Reply With Quote
Old 09-06-2011, 06:04 AM   #19
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

I used the poly mounts from Current Performance....
widopn is offline   Reply With Quote
Old 09-08-2011, 11:09 PM   #20
Staging Lane
Thread Starter
 
widopn's Avatar
 
Join Date: Jul 2011
Location: Virginia
Posts: 71
Default

well here is a vid ... first full quarter mile pass ..found that my posi unit was slipping while doing the burnout and i DEFINATELY need some cal tracs on it. The truck wheel hopped so bad I had to completely let off as you can see in the vid.. i would be happy with it if it wasnt for that but at least now i know what needs worked on...

http://youtu.be/OBkzPkhbya8
widopn is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
5.3 s10 ... widopn Conversions & Hybrids 40 03-13-2012 04:53 PM
Thunder Racing TR224 cam widopn Parts Classifieds 3 03-08-2012 02:45 PM
How to Zero a boost gauge. IKnowtheFuture Forced Induction 9 10-02-2010 01:18 AM
My 1st Truck 383lt1impala Western Members 6 10-16-2007 11:52 AM


Tags
10, 2001, 2002, 53, 53l, aftermarket, bolt, cam, forums, installing, ls1, put, quarter, s10, swap, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:58 PM.