Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Conversions & Hybrids
Sign in using an external account
Register Forgot Password?
Search

Conversions & Hybrids
LSX Engines in Non-LSX Vehicles
Sponsored by
Don Hardy Race Cars

LS1 RX7 fuel pump problem

Reply
 
Thread Tools Search this Thread
Old 08-14-2006, 08:18 PM   #1
Teching In
 
Trader Rating: 0
Join Date: Jun 2006
Location: Marietta, Ga.
Posts: 4
Default LS1 RX7 fuel pump problem

Fuel pump(Walbro) went out after about 3,000 miles. Replaced pump last week with same and yesterday it wouldn't start. No pressure at fuel rail. Don't hear the pump when I turn the key. Tomorrow will remove and check power to the pump. Anyone have a similar problem with a conversion?
V8RX7 is offline   Reply With Quote
Old 08-14-2006, 08:18 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
255, fd, fuel, issues, locations, ls1, pump, rx7, stock, troubleshoot, walbro, wiring


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details