Need Help! - LS1TECH

Log In 


Conversions & Hybrids LSX Engines in Non-LSX Vehicles

Need Help!

Reply
 
Thread Tools Search this Thread
Old 05-12-2007, 12:48 PM   #1
TECH Apprentice
Thread Starter
iTrader: (4)
 
sdimess84's Avatar
 
Join Date: Jan 2007
Location: Gallatin/Hville TN
Posts: 344
Default Need Help!

I got my harness from Current Performance yesterday. On the back of the motor I am having oil pressure sending unit problems. Here is what I have.



It is a 2003 5.3L. Does anyone know what that one wire plug goes to? I thought it go to the oil pressure unit, but it does not fit. I need some help please!
sdimess84 is offline   Reply With Quote
Old 05-12-2007, 12:51 PM   #2
TECH Fanatic
iTrader: (4)
 
67rsss's Avatar
 
Join Date: Mar 2007
Location: Twin Cities, MN
Posts: 1,062
Default

That is for oil pressure sender. You may need to change to an F-Body sender. My plug looks just like that one, and pops right on.
67rsss is offline   Reply With Quote
Old 05-12-2007, 12:55 PM   #3
TECH Apprentice
Thread Starter
iTrader: (4)
 
sdimess84's Avatar
 
Join Date: Jan 2007
Location: Gallatin/Hville TN
Posts: 344
Default

any part numbers for the sender
sdimess84 is offline   Reply With Quote
Old 05-12-2007, 05:43 PM   #4
TECH Apprentice
Thread Starter
iTrader: (4)
 
sdimess84's Avatar
 
Join Date: Jan 2007
Location: Gallatin/Hville TN
Posts: 344
Default

Quote:
Originally Posted by 67rsss
That is for oil pressure sender. You may need to change to an F-Body sender. My plug looks just like that one, and pops right on.
What year F body? I noticed that there are two available.
sdimess84 is offline   Reply With Quote
Old 05-12-2007, 07:03 PM   #5
TECH Junkie
iTrader: (18)
 
LS1MCSS's Avatar
 
Join Date: Jan 2006
Location: Dover, Arkansas
Posts: 3,660
Default

I have one for a 2000 f-body if you need it.
LS1MCSS is offline   Reply With Quote
Old 05-13-2007, 09:21 PM   #6
TECH Veteran
iTrader: (37)
 
01WS6/tamu's Avatar
 
Join Date: Oct 2004
Location: somewhere in TX
Posts: 4,838
Default

Any gm sender will work. Just order one for a 2000 fbody or truck. That is the oil pressure sending unit wire. The newer trucks use a different style sensor than they used to use.
01WS6/tamu is offline   Reply With Quote
Old 05-13-2007, 09:39 PM   #7
TECH Enthusiast
iTrader: (3)
 
Join Date: Nov 2004
Location: West Plains, Missouri
Posts: 554
Default

Is the sender in the picture the standard triangle shape like the TPS sensor? if so, just re-wire the plug and save from buying a new sender.
busta9876 is offline   Reply With Quote
Old 05-14-2007, 08:26 AM   #8
TECH Apprentice
Thread Starter
iTrader: (4)
 
sdimess84's Avatar
 
Join Date: Jan 2007
Location: Gallatin/Hville TN
Posts: 344
Default

I was just told from the guy that made my harness, told me used the one off my v6 now, or I have one from a 92 s10 4.3 that I can use.
sdimess84 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 12:29 AM.