Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > Corvette Performance
Sign in using an external account
Register Forgot Password?
Search

Corvette Performance
C5 | Z06 | C6 | ZR1
Sponsored by
Corvette Central
Click Here

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 09-01-2009, 11:48 PM   #1
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default check abs, check trac. control, bank1 sens.2 (o2)code, and gas gauge acting weird

having some trouble with my 2000 corvette.. she is a beauty, runs like a champ, just lighting up my dash like a christmas tree!! traction control light comes on periodically and at the same time so does the abs and one other malfunction code.. then my CEL comes on periodically with a code p01.. something.. i looked it up and is says low voltage bank 1 sensor 2.. i am assuming the o2 sensor is bad? maybe not tho right? and today i noticed about halfway home i had just under 1/2 tank by the time i got within about 1 mile from my house the fuel gauge needle was resting on it's stop, the display said low fuel and the check gauges light was on.. i parked it for about 3 hours and came back and started the car and it went straight back to where it should be! what's the deal? i have a long trip home, do you think it could be draining the main tank and the fuel pump could be lagging behind getting it refilled? not likely i guess, probably just an issue with the sensor?? any help/advice is greatly appreciated!!
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-02-2009, 11:33 AM   #2
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

the gas gauge did it again today.. it was working perfect when i left the house, but about 35 minutes down the road the gas needle just flat dropped and the display said low fuel, but it wasn't saying reserve fuel like it normally does, so that must be a different sensor i guess?
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-02-2009, 08:02 PM   #3
TECH Apprentice
Garage is empty, add now
 
ALL UC2's Avatar
 
Trader Rating: 4
Join Date: Jan 2005
Posts: 347
Default

mine started to do the service traction,service abs and sevice active handling crap a couple of days ago......i know vettes have alot of electrical issues, and i have heard that alot of it could be solved by cleaning the gounding points...im gonna look into mine on friday and i will let you know......i just lowered my car quite a bit, dont know if that had anything to do with it or not.....and i am throwing two codes for the cats being bad..
__________________
1999 white frc corvette

2001 white ecsb 6 inch rc lift and 35/12.50 nitto mud grappplers with 20in black kmc rock stars
ALL UC2 is offline   Reply With Quote
Old 09-02-2009, 08:10 PM   #4
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

thanks all uc2
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-04-2009, 08:15 AM   #5
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

well yesterday i got under the car and found a box about 4"x4"x1" with a hard rubber shield over what i assume to be wires.. it was draped over the exhaust just ahead of the rear end on the driver's side.. any ideas what that box may be and how i can go about checking to see if it is the issue? mainly what are the functions of that box? if the traction control and active handling and the gas gauge sensor all run through that box i would have to say it is the culprit, but i need to know what it's functions are.
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-06-2009, 12:08 AM   #6
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

uc2, saw where you said your body grounds were all crusted over, that sucks! did you get them cleaned off? did it fix your abs/trac. control/active handling lights? i don't think that is my problem, i only found 1 body ground, but i was in a not very well lit shop with the car on a crummy jack.. i need to check it again in my shop, but i found a box that was draped by its connection over the exhaust.. i'm hoping that someone can tell me what that box is!
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-06-2009, 09:17 AM   #7
TECH Apprentice
Garage is empty, add now
 
ALL UC2's Avatar
 
Trader Rating: 4
Join Date: Jan 2005
Posts: 347
Default

i think there is like 7 or 9 grounding points on the car.....if you do a search i found a diagram that list where they are all at.......im havent ever looked at that box but i am going to work on mine tonight so i will check it out...
__________________
1999 white frc corvette

2001 white ecsb 6 inch rc lift and 35/12.50 nitto mud grappplers with 20in black kmc rock stars
ALL UC2 is offline   Reply With Quote
Old 09-06-2009, 11:54 AM   #8
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

i will see if i can find that diagram.. let me know if you have any ideas! thanks!!
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-06-2009, 12:33 PM   #9
10 Second Club
Garage is empty, add now
 
sultan(ZR-1)KSA's Avatar
 
Trader Rating: 0
Join Date: Jun 2004
Posts: 384
Default

i think this may help

http://forums.corvetteforum.com/c5-t...tion-long.html
__________________
JRW DRAG STRIP 10.78 at 138MPH at 621WHP http://http://www.youtube.com/watch?v=64VKVeX8L0I

new dyno number 798WHP/805WTQ uncorected
http://www.youtube.com/watch?v=ED99x...lA&feature=sub
sultan(ZR-1)KSA is offline   Reply With Quote
Old 09-06-2009, 10:43 PM   #10
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

ohhhh man, what a super link there sultan!! thanks! i will clean all of those and i would bet big money that will fix it!!
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-08-2009, 04:09 PM   #11
Launching!
Garage is empty, add now
 
fozziejared's Avatar
 
Trader Rating: 1
Join Date: Jun 2004
Location: longview, tx
Posts: 297
Send a message via AIM to fozziejared
Default

i cleaned a couple of my ground connections and it seems to have possibly fixed a couple of the issues.. the collector had corrosion in it.. i am still throwing codes p0137 p1431 c1217(thrown instantly after clearing code and starting car back up) and c1243

C1217 BPMV Pump Motor Relay Contact CKT Open

thats the one that throws immediately..

here are the other 3

C1243 BPMV Pump Motor Stalled
P0137 Heated Oxygen Sensor (HO2S) Circuit Low Voltage Bank 1 Sensor 2
P1431 Fuel Level Sensor 2 Circuit Performance

so all of my issues are narrowed down by the computer, but how do i go about addressing them? i guess the 02 is probably bad, what about the fuel level sensor? what about the bpmv pump, i can't even reason out what that is or where to look for it!?
__________________
sold:99 z28 m6, modified 5.3 heads, 383 kit, eagle crank and rods je pistons, g5x3 112 cam, lid, electric cutout, & hp tuners.
appearance= RS body kit, angel eyes, cf tails, billet grill.

2000 corvette coupe, ready for some mods!
fozziejared is offline   Reply With Quote
Old 09-08-2009, 04:09 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
1999, 2001, abs, bank, check, corvette, electrical, fuel, grounds, hp, light, oxygen, sensor, trac, tuners, utube


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weirdest o2 sensor problem! rcr05261 Generation III External Engine 4 10-05-2014 04:06 PM
Code P0332 Knock sensor low input bank 2 jaycenk LT1-LT4 Modifications 3 11-22-2010 05:07 PM
o2 sensor bank1 sensor2 low voltage, gas gauge acting weird, tcs light and abs light fozziejared General Maintenance & Repairs 14 09-09-2009 03:48 PM
Need help with po452 code on ls1 conversion wildmanaaron PCM Diagnostics & Tuning 0 09-05-2009 06:53 PM
O2 Sensors and Lean Banks SES MJE95GAGT General Maintenance & Repairs 4 09-07-2007 07:29 PM



All times are GMT -5. The time now is 06:02 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details