mcloed rxt - LS1TECH



Corvette Performance
C5 | Z06 | C6 | ZR1

mcloed rxt

Reply
 
Thread Tools Search this Thread
Old 05-20-2012, 08:49 AM   #1
Teching In
Thread Starter
 
Join Date: Jan 2010
Location: CT
Posts: 23
Default mcloed rxt

i just installed a mcleod rxt clutch with hinson motor and trans mounts in my c6 corvette. I'm getting a lot of neutral noise... when i push in the clutch it goes away. is this normal? does anyone else have this problem?
slowc6 is offline   Reply With Quote
Old 05-20-2012, 07:04 PM   #2
TECH Addict
iTrader: (24)
 
Join Date: Jun 2003
Location: St Joe, MO
Posts: 2,647
Default

Mine does the same, een after 7k miles. F'king thing grips like no other, I love this clutch
JoeyGC5 is offline   Reply With Quote
Old 05-21-2012, 10:16 AM   #3
Teching In
Thread Starter
 
Join Date: Jan 2010
Location: CT
Posts: 23
Default

Quote:
Originally Posted by JoeyGC5 View Post
Mine does the same, een after 7k miles. F'king thing grips like no other, I love this clutch
Thanks seems like a lot of peoples twins are doing it so its normal. I was stressing because some people told me I had a bad throwout bearing or the clutch was out of balance. Im very happy with it to.
slowc6 is offline   Reply With Quote
Reply


Tags
ls1tech, rxt

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:49 AM.