Go Back   LS1TECH > RACING DEPARTMENT > Drag Racing Results
Sign in using an external account
Register Forgot Password?
Search

Drag Racing Results Track Times | Records | Testing Info
Timeslip Database CLICK HERE

Why is my trap speed so low??

Reply
 
Thread Tools Search this Thread
Old 04-08-2010, 11:07 AM   #1
Staging Lane
 
Ryan00SS's Avatar
 
Trader Rating: 3
Join Date: Jul 2009
Location: Orlando
Posts: 67
Default Why is my trap speed so low??

So i went to the track last night after replacing my master cylinder to see if my sticking clutch problems would stop. My clutch definately has a better feel to it, but it still stuck to the ground after i pushed my clutch in after my run. I have a cammed camaro and i cant even break into the 12's. I had a 2.2 60 foot on my shitty sumitomos but my highest trap speed to date is 108.5. The car dynoed 376 rwhp 364 rwtq just a couple weeks ago when i had it tuned so i dont think its a power problem. Does this sound like a problem with my clutch?? I also have a CEL on for bad 02 sensors but i heard that doesnt affect anything at WOT.
__________________


2000 LPM SS Tuned by Geoff at Next Level Performance 376 rwhp/364 rwtq
Mod List: Moser 12 bolt Rear with 3.90 gears|TR224/227 114 LSA Cam | Monster Stage 3 | Borla 3" exhaust | SLP Long tube headers with hi flow cats | QTP 3" Electric Cutout | LS6 intake manifold | Whipser Lid | Pro 5.0 short throw shifter | BMR chromoly LCA's | Panhard rod | Torque arm | SLP subframe connectors | 10" JL Audio W3v2 sub | Power Stop Slotted and Dimpled rotors | Driveshaft Loop
Ryan00SS is offline   Reply With Quote
Old 04-08-2010, 12:38 PM   #2
On The Tree
 
jgarza54's Avatar
 
Trader Rating: 4
Join Date: Feb 2009
Location: DFW area
Posts: 114
Default

Quote:
Originally Posted by Ryan00SS View Post
So i went to the track last night after replacing my master cylinder to see if my sticking clutch problems would stop. My clutch definately has a better feel to it, but it still stuck to the ground after i pushed my clutch in after my run. I have a cammed camaro and i cant even break into the 12's. I had a 2.2 60 foot on my shitty sumitomos but my highest trap speed to date is 108.5. The car dynoed 376 rwhp 364 rwtq just a couple weeks ago when i had it tuned so i dont think its a power problem. Does this sound like a problem with my clutch?? I also have a CEL on for bad 02 sensors but i heard that doesnt affect anything at WOT.
Sounds like you are having clutch problems. Have you replaced it? And you might want to put some stickys on to help you out more.

Last edited by jgarza54; 04-08-2010 at 12:53 PM..
jgarza54 is offline   Reply With Quote
Old 04-08-2010, 12:56 PM   #3
Staging Lane
 
Ryan00SS's Avatar
 
Trader Rating: 3
Join Date: Jul 2009
Location: Orlando
Posts: 67
Default

Quote:
Originally Posted by jgarza54 View Post
Sounds like you are having clutch problems. Have you replaced it?
i bought the car with a LUK clutch and flywheel. I havent noticed any real bad slipping though.. im not sure what the problem could be
__________________


2000 LPM SS Tuned by Geoff at Next Level Performance 376 rwhp/364 rwtq
Mod List: Moser 12 bolt Rear with 3.90 gears|TR224/227 114 LSA Cam | Monster Stage 3 | Borla 3" exhaust | SLP Long tube headers with hi flow cats | QTP 3" Electric Cutout | LS6 intake manifold | Whipser Lid | Pro 5.0 short throw shifter | BMR chromoly LCA's | Panhard rod | Torque arm | SLP subframe connectors | 10" JL Audio W3v2 sub | Power Stop Slotted and Dimpled rotors | Driveshaft Loop
Ryan00SS is offline   Reply With Quote
Old 04-08-2010, 03:35 PM   #4
On The Tree
 
jgarza54's Avatar
 
Trader Rating: 4
Join Date: Feb 2009
Location: DFW area
Posts: 114
Default

Quote:
Originally Posted by Ryan00SS View Post
i bought the car with a LUK clutch and flywheel. I havent noticed any real bad slipping though.. im not sure what the problem could be
have you changed your slave cylinder? Does it stick when you are driving normal also or only when you are racing?
jgarza54 is offline   Reply With Quote
Old 04-08-2010, 03:37 PM   #5
On The Tree
 
GT-OH's Avatar
 
Trader Rating: 7
Join Date: Jun 2006
Location: Warminster PA
Posts: 149
Default

What clutch fluid are you using? You need to get those 60's down if you want some good numbers
GT-OH is offline   Reply With Quote
Old 04-08-2010, 03:45 PM   #6
10 Second Club
 
jmm98LS1's Avatar
 
Trader Rating: 27
Join Date: Feb 2005
Location: KS
Posts: 3,837
Default

How much does the car weigh with you in it? What was the DA like during your runs? Are your dyno #s sae corrected?
__________________

-98 NBM Z/28: 370ci | T56 | twin 6165
-85 Chevy Silverado SWB: 383ci sbc | T56 | 4.11

Last edited by jmm98LS1; 04-08-2010 at 03:51 PM..
jmm98LS1 is offline   Reply With Quote
Old 04-08-2010, 05:23 PM   #7
11 Second Club
 
69LT1Bird's Avatar
 
Trader Rating: 1
Join Date: Sep 2007
Location: Lapeer, MI
Posts: 2,317
Default

What kind of dyno?

How much does it weigh with you in it?
__________________
HP Tuners Beginners Tuning Guide

Michigan Snowmobiler
1969 Firebird: 7.55@92.93 1/8 1.70 60 ft. 11.7@116[/COLOR] EPS cam 234/246 .602.606 114+3, 6.0 LQ4, L92 heads milled 10.5:1, Ported L76 intake, ported 90mm Holley TB, 100mm MAF, FIC Custom injectors, Hooker LT, PYPES dual exhaust with an X pipe, 4L65e with all of the good parts inside, FTI 4000 RPM Stall, 12 bolt with 3.73 gears. HP Tuner tuned by me
69LT1Bird is offline   Reply With Quote
Old 04-08-2010, 05:29 PM   #8
Staging Lane
 
Ryan00SS's Avatar
 
Trader Rating: 3
Join Date: Jul 2009
Location: Orlando
Posts: 67
Default

DOT 4 clutch fluid, it doesnt stick under normal driving, but it will occasionaly if i slam through 2-4. I have not replaced the slave, thats what im thinking i need to do and i was just gonna get a new clutch while i was at it. Today i got on it in 1st gear and after the little pull, i smelt burnt clutch. So i guess it is my clutch going. I havent weighed my car yet, and dyno numbers are SAE corrected.

oh and the DA was pretty good that night
__________________


2000 LPM SS Tuned by Geoff at Next Level Performance 376 rwhp/364 rwtq
Mod List: Moser 12 bolt Rear with 3.90 gears|TR224/227 114 LSA Cam | Monster Stage 3 | Borla 3" exhaust | SLP Long tube headers with hi flow cats | QTP 3" Electric Cutout | LS6 intake manifold | Whipser Lid | Pro 5.0 short throw shifter | BMR chromoly LCA's | Panhard rod | Torque arm | SLP subframe connectors | 10" JL Audio W3v2 sub | Power Stop Slotted and Dimpled rotors | Driveshaft Loop

Last edited by Ryan00SS; 04-08-2010 at 05:30 PM.. Reason: added something
Ryan00SS is offline   Reply With Quote
Old 04-08-2010, 05:32 PM   #9
11 Second Club
 
69LT1Bird's Avatar
 
Trader Rating: 1
Join Date: Sep 2007
Location: Lapeer, MI
Posts: 2,317
Default

I mean load bearing (Mustang style) or non-load bearing like a Dynojet
__________________
HP Tuners Beginners Tuning Guide

Michigan Snowmobiler
1969 Firebird: 7.55@92.93 1/8 1.70 60 ft. 11.7@116[/COLOR] EPS cam 234/246 .602.606 114+3, 6.0 LQ4, L92 heads milled 10.5:1, Ported L76 intake, ported 90mm Holley TB, 100mm MAF, FIC Custom injectors, Hooker LT, PYPES dual exhaust with an X pipe, 4L65e with all of the good parts inside, FTI 4000 RPM Stall, 12 bolt with 3.73 gears. HP Tuner tuned by me
69LT1Bird is offline   Reply With Quote
Old 04-08-2010, 07:03 PM   #10
On The Tree
 
jgarza54's Avatar
 
Trader Rating: 4
Join Date: Feb 2009
Location: DFW area
Posts: 114
Default

Quote:
Originally Posted by Ryan00SS View Post
DOT 4 clutch fluid, it doesnt stick under normal driving, but it will occasionaly if i slam through 2-4. I have not replaced the slave, thats what im thinking i need to do and i was just gonna get a new clutch while i was at it. Today i got on it in 1st gear and after the little pull, i smelt burnt clutch. So i guess it is my clutch going. I havent weighed my car yet, and dyno numbers are SAE corrected.

oh and the DA was pretty good that night
IMO sounds like the clutch is going out, well actually the springs on the pressure plate are weak and not allowing the clutch to disengage under higher pressure meaning, speedshifting or powershifting. You can check for this by engaging your clutch 1/2 ways and reving your engine. When you do this, if your pressure plate/springs are weak it will actually suck the pedal down away from your foot. If this is the case just go with a better clutch(not spec) that has a stonger pressure plate and while you are at it, do your slave cylinder.. Oh and you might want to go with a non-synthetic fluid too. Synthetic could cause blow-by in the slave cylinder and also cause it to leak.

Last edited by jgarza54; 04-08-2010 at 07:15 PM..
jgarza54 is offline   Reply With Quote
Old 04-08-2010, 07:55 PM   #11
Staging Lane
 
Ryan00SS's Avatar
 
Trader Rating: 3
Join Date: Jul 2009
Location: Orlando
Posts: 67
Default

it wasnt a mustang dyno. and ill try that halfway clutch engaging thing and let you know what happens.
__________________


2000 LPM SS Tuned by Geoff at Next Level Performance 376 rwhp/364 rwtq
Mod List: Moser 12 bolt Rear with 3.90 gears|TR224/227 114 LSA Cam | Monster Stage 3 | Borla 3" exhaust | SLP Long tube headers with hi flow cats | QTP 3" Electric Cutout | LS6 intake manifold | Whipser Lid | Pro 5.0 short throw shifter | BMR chromoly LCA's | Panhard rod | Torque arm | SLP subframe connectors | 10" JL Audio W3v2 sub | Power Stop Slotted and Dimpled rotors | Driveshaft Loop
Ryan00SS is offline   Reply With Quote
Old 04-10-2010, 01:45 PM   #12
Staging Lane
 
Ryan00SS's Avatar
 
Trader Rating: 3
Join Date: Jul 2009
Location: Orlando
Posts: 67
Default

i have a feeling it has something to do with the pressure plate. While im driving and its in gear, i can pop it out of gear real easily without pushing on the clutch.. Does this sound like a pressure plate problem?
__________________


2000 LPM SS Tuned by Geoff at Next Level Performance 376 rwhp/364 rwtq
Mod List: Moser 12 bolt Rear with 3.90 gears|TR224/227 114 LSA Cam | Monster Stage 3 | Borla 3" exhaust | SLP Long tube headers with hi flow cats | QTP 3" Electric Cutout | LS6 intake manifold | Whipser Lid | Pro 5.0 short throw shifter | BMR chromoly LCA's | Panhard rod | Torque arm | SLP subframe connectors | 10" JL Audio W3v2 sub | Power Stop Slotted and Dimpled rotors | Driveshaft Loop
Ryan00SS is offline   Reply With Quote
Old 04-10-2010, 02:31 PM   #13
Teching In
 
93LS1Ws6's Avatar
 
Trader Rating: 12
Join Date: Sep 2009
Posts: 44
Default

Quote:
Originally Posted by Ryan00SS View Post
i have a feeling it has something to do with the pressure plate. While im driving and its in gear, i can pop it out of gear real easily without pushing on the clutch.. Does this sound like a pressure plate problem?
I would say more clutch than a pressure plate problem. But i would also replace your slave cylinder.
93LS1Ws6 is offline   Reply With Quote
Old 04-10-2010, 03:35 PM   #14
Teching In
 
87LX5.SLOW's Avatar
 
Trader Rating: 0
Join Date: Nov 2004
Location: BR LA
Posts: 24
Default

Quote:
Originally Posted by Ryan00SS View Post
i have a feeling it has something to do with the pressure plate. While im driving and its in gear, i can pop it out of gear real easily without pushing on the clutch.. Does this sound like a pressure plate problem?
If your trying to take it out of gear without a load on the drivetrain it will come out easily, Basicly if your cruising and if you try to take it out of gear with a little pressure and your not on the throttle hard or slowing down it will go into N easy. I'd say replace the slave with an upgraded one thats adjustable and get it adjusted properly and see where you stand.
__________________
1992 LS1 Iroc-Z
02 LS1 W/F13
TH350 4500stall
87LX5.SLOW is offline   Reply With Quote
Old 04-15-2010, 01:41 PM   #15
Staging Lane
 
Ryan00SS's Avatar
 
Trader Rating: 3
Join Date: Jul 2009
Location: Orlando
Posts: 67
Default

the clutch doesnt slip when im cruising at 35 in 5th gear, so i dont think my clutch is that bad right now. could a bad slave really be causing my low trap speed?
__________________


2000 LPM SS Tuned by Geoff at Next Level Performance 376 rwhp/364 rwtq
Mod List: Moser 12 bolt Rear with 3.90 gears|TR224/227 114 LSA Cam | Monster Stage 3 | Borla 3" exhaust | SLP Long tube headers with hi flow cats | QTP 3" Electric Cutout | LS6 intake manifold | Whipser Lid | Pro 5.0 short throw shifter | BMR chromoly LCA's | Panhard rod | Torque arm | SLP subframe connectors | 10" JL Audio W3v2 sub | Power Stop Slotted and Dimpled rotors | Driveshaft Loop
Ryan00SS is offline   Reply With Quote
Old 04-15-2010, 01:41 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
12, 60, cammed, changing, connectors, foot, gears, low, ls1, mustang, rear, speed, subframe, trap, ur


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 12:38 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details