Finally at the strip, only 11.57@124, opinions please? - LS1TECH

Go Back   LS1TECH > RACING DEPARTMENT > Drag Racing Results
Sign in using an external account
Register Forgot Password?
Search


Drag Racing Results Track Times | Records | Testing Info
Timeslip Database CLICK HERE

Finally at the strip, only 11.57@124, opinions please?

Reply
 
Thread Tools Search this Thread
Old 07-02-2012, 06:51 PM   #1
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default Finally at the strip, only 11.57@124, opinions please?

First of all thanks to all members of this forum who helped me with the info, advises, pics of their projects and inspiration!
After 4 years of building (turbocharging and getting 4L80E in there) my TransAm is in good running state Go 200miles to the strip, race, and go back.
Best result, at 13psi, footbraking the car, was:
11.57@124mph
60': 1.88
1/8: 7.51@96mph
This was just old airfield, no glue. I run 12-bolt 3.73, relocating LCA brackets, Billstein shocks, WS6 springs. MT ET Drags 28x11.5 in the rear. 383ci with my own built turbo kit, with TC78. 3500 Circle-D converter.

Since this was basically my first time at the track with new setup I'm asking for opinions. How does it look? Is chassis "working"? I honestly expected better 60ft - I was racing my other car (Nissan 200SX 1.8L) and it got 60ft' of 1.72-1.75 on smaller tire. My best in TransAm was 1.83.
Unfortunately these were only 2 clips of my runs...
What can you tell from them?
Thanks! I know this was just first track day and I'll work out "bugs" with time, I think car should run at least 10.9x with TC78 turbo?
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-02-2012, 07:11 PM   #2
TECH Fanatic
 
B18B1LS1's Avatar
 
Trader Rating: 12
Join Date: Nov 2001
Location: Lawrenceville, Ga
Posts: 1,514
Default

You have the mph of a 10-second car, but it's way to lazy out of the hole. How much boost is it making off the line? A transbrake and 2-step would work wonders for you.
__________________
'98 Z28 A3--slow
'97 Dodge 2500 CTD--600hp tow rig
'02 Chevy 2500 Duramax--work truck
'95 Civic--40+ mpg
'92 Wrangler--offroad fun
B18B1LS1 is offline   Reply With Quote
Old 07-02-2012, 07:19 PM   #3
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Hmm... Just checked. I had 6-7psi on the footbrake. Do you think I need more boost off the line? I was spinning like crazy already...
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-02-2012, 08:18 PM   #4
TECH Fanatic
 
B18B1LS1's Avatar
 
Trader Rating: 12
Join Date: Nov 2001
Location: Lawrenceville, Ga
Posts: 1,514
Default

Ahh ok, didn't think it was spinning, I thought it was bogging. I should have payed closer attention to that first video. Time for some more suspension!
__________________
'98 Z28 A3--slow
'97 Dodge 2500 CTD--600hp tow rig
'02 Chevy 2500 Duramax--work truck
'95 Civic--40+ mpg
'92 Wrangler--offroad fun
B18B1LS1 is offline   Reply With Quote
Old 07-02-2012, 08:27 PM   #5
TECH Fanatic
 
Trader Rating: 67
Join Date: Jan 2004
Location: Indiana
Posts: 1,495
Default

first video,sounds like you were hitting the rev limiter.?.?
__________________
heymoej is offline   Reply With Quote
Old 07-02-2012, 08:38 PM   #6
TECH Fanatic
 
Trader Rating: 0
Join Date: Jan 2010
Location: South of Augusta,GA
Posts: 1,334
Default

Quote:
Originally Posted by heymoej View Post
first video,sounds like you were hitting the rev limiter.?.?
I agree, you over rev, and your gear is most likely to short. You need a 3.55, hell maybe even a 3.08 thats what I run, but leaving at idle 2.20 60ft, my car mph 127. So my vote is suspention, and gear. Nice car!! Oh I run a cheap ebay turbo GT45.
MillsMotorvation is offline   Reply With Quote
Old 07-03-2012, 01:17 AM   #7
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Yepp the car was banging off the limiter in 1st and probably 2nd too. Gearchange set at 5500, rev limiter at 6200.
Still, do you think 3.73 gear is soooooo way too much? Hell I'm not leaving at 20 psi ) I would like to think gear is at least OK, but my 60ft suffer because of smth. else - either suspension or overall slowness when I start off the footbrake.
It looks to me like front end is not rising up much, and on the other hand rear raises a lot when I bring the revs up, is it how it should be?
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-03-2012, 09:24 AM   #8
11 Second Club
 
Trader Rating: 5
Join Date: Apr 2007
Location: Alma, MI
Posts: 463
Default

No transfer - so it's not planting the tires.
__________________
-Jeremy
Y2K Pontiac Firebird Formula
H/C/I, MWC 9", Faceplated T56, McLeod RXT, Nitrous
New Times coming soon
nocooler is offline   Reply With Quote
Old 07-03-2012, 10:23 AM   #9
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

I also left stock tranny tables so it shifted early into 2nd then back to 1st then 2nd then in a moment in 3rd already, also applied TC lock, crazy
Attached Files
File Type: hpl _Tartu_qualrun3ilms.hpl (24.6 KB, 58 views)
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-03-2012, 10:41 AM   #10
12 Second Club
 
coolmanvette75's Avatar
 
Trader Rating: 2
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

A bit off topic but how much clearancing did you have to do to fit those tires? I have the same exact ones I will be installing on friday. Any pics?
__________________
1994 Medium Patriot Red Z28 6spd
Forged 370ci iron block, LSA Heads, T6 S480 ET-R HO, Viper T56, QP 9in
Numbers Coming Soon
coolmanvette75 is offline   Reply With Quote
Old 07-03-2012, 10:49 AM   #11
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Quote:
Originally Posted by coolmanvette75 View Post
A bit off topic but how much clearancing did you have to do to fit those tires? I have the same exact ones I will be installing on friday. Any pics?
had to bang the inner fenders quite a bit. Also bend front lips of the rear bumper. And to get wheels perfectly centered in the wells I got my LCA's shortened few millimeters (cut and rewelded back near front bushing housing).
But back to topic What's wrong, what to try and what to test?
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-03-2012, 12:58 PM   #12
TECH Apprentice
 
Trader Rating: 0
Join Date: Aug 2003
Posts: 314
Default

Quote:
Originally Posted by Vetal View Post
I also left stock tranny tables so it shifted early into 2nd then back to 1st then 2nd then in a moment in 3rd already, also applied TC lock, crazy
Looks like you figured out some of the issue. If you have a 6200 rev limit, dont cut it off at 5500, let it eat!

I also agree with suspension work and 3.08 or other tall gears. That 4L80E has a low first gear.

Al
__________________
94 Supra TT Auto
9.57@142.42
T6Rocket is offline   Reply With Quote
Old 07-03-2012, 01:18 PM   #13
TECH Fanatic
 
Trader Rating: 0
Join Date: Jan 2010
Location: South of Augusta,GA
Posts: 1,334
Default

Ok well you seem to know what you need, Good luck!
MillsMotorvation is offline   Reply With Quote
Old 07-03-2012, 02:18 PM   #14
9 Second Club
 
chasgiv3's Avatar
 
Trader Rating: 1
Join Date: Nov 2001
Location: Chicago
Posts: 783
Default

In watching the video I don't see much weight transfer at all to the rear tires. The rear end doesn't hunker down hardly at all and I don't see much lift from the front.

What shocks are you running? What are the settings on them? Are you still running a front sway bar?
__________________
Street/Strip Car: Black 1999 WS6 Patriot Heads, Cam, LQ4 block with forged rotating assembly, Speed Inc. Custom Twin Turbo kit with Precision PT67 P-trim. Burkhart Chassis Chrome Moly Cage, Strange Engineering 12-bolt with 3.42 gears. 907RWHP, TH400 racing tranny with 4000 stall. Best 1/4 mile ET 9.19 @ 156.25 MPH on 15" Slicks ET 9.22 @144 MPH on 17" drag radials. New High Imp 160lb injectors 965RWHP getting ready for next season.
chasgiv3 is offline   Reply With Quote
Old 07-04-2012, 02:46 AM   #15
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Quote:
Originally Posted by T6Rocket View Post
Looks like you figured out some of the issue. If you have a 6200 rev limit, dont cut it off at 5500, let it eat!

I also agree with suspension work and 3.08 or other tall gears. That 4L80E has a low first gear.

Al
Well 5500 is still too high because it still bangs into rev limiter!
Yes, suspension, but what exactly?
Hmm I don't know, I saw people put 4.xx gears in theirs and hook...
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-04-2012, 02:49 AM   #16
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Quote:
Originally Posted by chasgiv3 View Post
In watching the video I don't see much weight transfer at all to the rear tires. The rear end doesn't hunker down hardly at all and I don't see much lift from the front.

What shocks are you running? What are the settings on them? Are you still running a front sway bar?
yepp, neither do I
I'm running Bilstein HD shocks and WS6 springs. Yes for front sway bar.
However I remember when I was N/A and had manual tranny (in 2008 I think), it lifted the nose pretty noticeable on launch, on 26" slicks
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-04-2012, 02:59 AM   #17
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Few pics of 2008-2009 when it was non-turbo and M6 tranny. The nose was probably a bit lighter then, when it had no turbo or intercooler hanging there in front
Attached Thumbnails
Finally at the strip, only 11.57@124, opinions please?-me-jk-06.07.08sm.jpg   Finally at the strip, only 11.57@124, opinions please?-000023204039_-23_3_-23_bes.jpg   Finally at the strip, only 11.57@124, opinions please?-dsc01914sm.jpg  
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-04-2012, 07:33 AM   #18
9 Second Club
 
chasgiv3's Avatar
 
Trader Rating: 1
Join Date: Nov 2001
Location: Chicago
Posts: 783
Default

I get much better travel with the front sway bar unlinked and to lesson the front end weight even removed. My front end is really heavy also so every little bit helps.
Click the image to open in full size.
__________________
Street/Strip Car: Black 1999 WS6 Patriot Heads, Cam, LQ4 block with forged rotating assembly, Speed Inc. Custom Twin Turbo kit with Precision PT67 P-trim. Burkhart Chassis Chrome Moly Cage, Strange Engineering 12-bolt with 3.42 gears. 907RWHP, TH400 racing tranny with 4000 stall. Best 1/4 mile ET 9.19 @ 156.25 MPH on 15" Slicks ET 9.22 @144 MPH on 17" drag radials. New High Imp 160lb injectors 965RWHP getting ready for next season.
chasgiv3 is offline   Reply With Quote
Old 07-04-2012, 07:50 AM   #19
TECH Fanatic
 
Trader Rating: 3
Join Date: Aug 2006
Location: Latvia
Posts: 1,931
Send a message via Skype™ to Vetal
Default

Looks like yours hooks "a little" better
__________________
98' TransAm 383ci + TC78
LS1, 00' PCM swap, 4L80E, Circle-D converter 10.71@128mph, 1.59 60'
Nissan 200SX (110ci, 410hp, 26psi)
Vetal is offline   Reply With Quote
Old 07-04-2012, 12:01 PM   #20
TECH Fanatic
 
Trader Rating: 67
Join Date: Jan 2004
Location: Indiana
Posts: 1,495
Default

i cant tell in the vids,do you have lighter rims & skinnies on the front?

how much air do you have in the ET Drags 28x11.5 on those runs?

pull the front sway bar off........
__________________
heymoej is offline   Reply With Quote
Old 07-04-2012, 12:01 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
5th gen new PB...11.26!!! 62nalide 11 Second Club 8 07-29-2014 03:13 AM
Aussie drag combo, e85 carb/dizzy/mech fuel pump 10.1@132 dogsballs Carbureted LSX Forum 43 02-25-2014 10:51 AM
Bonestock 2000 A4 SS Camaro 1/8th Passes Vid Inside RBD_305 Drag Racing Results 4 02-06-2014 10:51 PM
11.OH so close to that 10 sec motor pass! floman Drag Racing Results 18 01-10-2014 06:43 PM
9.0h at 150 tc78 6.0mustang Forced Induction 27 11-24-2013 12:37 PM


Tags
02, back, backup, circle, converter, end, footbrake, front, gear, idle, leave, ls1, racing, raising, trans, whats


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 01:34 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details