Launch vid included, could use constructive critisism - LS1TECH

Log In 


Launch vid included, could use constructive critisism

Reply
 
Thread Tools Search this Thread
Old 07-01-2010, 08:38 PM   #1
11 Second Club
Thread Starter
iTrader: (22)
 
V-10 Killer's Avatar
 
Join Date: Feb 2003
Location: Midland MI
Posts: 1,281
Default Launch vid included, could use constructive critisism

http://www.v10killer.com/TrackDayJune30.wmv

I had 4 runs just like this, about 1.60 60'. Then I lost my PCM...
But in retrospect, what adjustments should I have made?
Sorry the vid's shaky, my 14 year old son was toying with the digital camera when I got it.
Launch is just over 1/2 way through.
V-10 Killer is offline   Reply With Quote
Old 07-01-2010, 08:41 PM   #2
TECH Fanatic
iTrader: (12)
 
fuel's Avatar
 
Join Date: Apr 2007
Location: seminole,fl
Posts: 1,042
Default

looked like you got a tire.......
fuel is offline   Reply With Quote
Old 07-02-2010, 08:58 AM   #3
TECH Veteran
iTrader: (2)
 
Old Geezer's Avatar
 
Join Date: Jun 2004
Location: GA, USA
Posts: 4,908
Default

if the engine sound on the vid is yours, it sounds to me that U R driving thru the converter, or as mentioned tires are going away.
Suggest a better video, for more detail.
Old Geezer is offline   Reply With Quote
Old 07-02-2010, 09:01 AM   #4
9 Second Club
iTrader: (23)
 
tektrans's Avatar
 
Join Date: Nov 2003
Posts: 3,378
Default

It's not bad. Looks like she rolls a bit then settles back in the rear. What sway bar you have back there? Front settings look good, no bounce and she settles nice when the fronts touch back down.
What suspension mods do you have?
tektrans is offline   Reply With Quote
Old 07-02-2010, 09:55 AM   #5
11 Second Club
Thread Starter
iTrader: (22)
 
V-10 Killer's Avatar
 
Join Date: Feb 2003
Location: Midland MI
Posts: 1,281
Default

I have a 1" Spohn rear swaybar in it right now. I know a drag bar would be best, but I wanna see how far I can push this one. Since the fitment sux around the shocks, it's resale value is in the toilet. ~13# in the tires, Shocks were 1's in front, 5,6 in the back. PHR, Adjustable LCA's, Spohn tunnel mount torque arm, K-member and A-arms,...
Car was shifting at 5k regardless of how I tried programming it, and was going into 4th and locking the TCC for some reason at 1/2 track.... The motor makes peak hp at 6300 rpms, and peak torque from 4600-6k rpms. Converter's a TCI Comp 3800 I picked up for spraying, but I haven't got the trans cooperating yet to use it. I couldn't even get into my peak power area...

I squeezed a 1.51 out of it back when everything was shifting right, but I had the rears WAY softer and it was end of season so the air and track were really good.

I'm just trying to learn to read the video's now.

Last edited by V-10 Killer; 07-02-2010 at 10:06 AM.
V-10 Killer is offline   Reply With Quote
Old 07-02-2010, 11:14 AM   #6
On The Tree
 
Join Date: Aug 2007
Location: Mid Michigan
Posts: 130
Default

You really ought to have someone behind the car and off to the side recording the launch. That usually gives the best results for critiquing.

Take care,
Jim
96onele is offline   Reply With Quote
Old 07-02-2010, 01:13 PM   #7
TECH Fanatic
iTrader: (24)
 
BES Stroked Nova's Avatar
 
Join Date: Oct 2004
Location: Lawrenceburg Indiana
Posts: 1,441
Default

need to get that trans tuned... launch looks good then the trans shifts and ruins it.

your tuning the car? it takes some work to get a 4l60e to shift with a big converter... guy who tunes my car has it down pat...
BES Stroked Nova is offline   Reply With Quote
Old 07-02-2010, 01:58 PM   #8
11 Second Club
Thread Starter
iTrader: (22)
 
V-10 Killer's Avatar
 
Join Date: Feb 2003
Location: Midland MI
Posts: 1,281
Default

I got everything wrapped up with the cars build back in 2006 and took it to get tuned down in Detroit. When it came back it had more power, but wouldn't always downshift when you hammer it, and WOT shifts were totally screwed up. Took it back and had them work on it again, and didn't really get any better. Tuner claimed it was the tranny.
This is a FLT Level 5 tranny, and should not even have an issue at 500hp with no spray yet. I don't believe they did anything wrong with it, I'm almost 100% sure it's the tune. It was so frustrating, I didn't race the car for 3 years after. Now I'm trying to get it all ironed out and re-learn how to make adjustments.
I finally got it out again this year, and was trying to adjust the WOT mph/rpm shift tables myself when I filmed this. After 5 adjustments, the PCM fried.
After I get a new PCM in, I'm I'm gonna start looking at building a 4L80E
V-10 Killer is offline   Reply With Quote
Old 07-03-2010, 08:01 AM   #9
9 Second Club
iTrader: (23)
 
tektrans's Avatar
 
Join Date: Nov 2003
Posts: 3,378
Default

Well I will say you're doing a nice job with the car. Sounds like you have some tuning issues and yes a dragbar would let it leave a little better but very nice job so far. Nitrous converter too.
I'd leave everything alone until u get the tuning issues straightened out and take it from there.
tektrans is offline   Reply With Quote
Old 07-03-2010, 11:37 AM   #10
11 Second Club
Thread Starter
iTrader: (22)
 
V-10 Killer's Avatar
 
Join Date: Feb 2003
Location: Midland MI
Posts: 1,281
Default

Thanks man
Hopefully within a week or 2 I'll have the new PCM.
I'm looking at switching to a TCI trans controller for the 4L65 until I get the 4L80 built and ready. Maybe it'll help me figure out if it's the control or the trans.
Hopefully I'll be back up and racing in 2 weeks.
V-10 Killer is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:11 AM.