What in the world do I need to do to hook? (long) - LS1TECH



What in the world do I need to do to hook? (long)

Reply
 
Thread Tools Search this Thread
Old 07-09-2006, 05:23 PM   #1
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Question What in the world do I need to do to hook? (long)

I've recently done quite a bit to gain traction w/ pretty disapointing results. I'm looking for advice as to what I should do?
Some details on the car:
Car is a 01 SS, full weight (3700 #'s w/ me in it)
Cam only TSP 233/239, & regular bolt ons, and TNT 150 wet shot.
Custom TCI 4000 stall for nitrous.
Rear Suspension:
BMR LCA's, BMR subrames, BMR PHR, Jegster T/A set at -3 deg.
Moser 12 bolt, full spool, 3.73 gears.
Front: Stock minus swaybar

I'm running 3.5" prostars up front, and 15 x 10 out back w/ 325 - 50 M/T Drag radials.

I've cut a best 60' of 1.67 on motor spinning slightly, and I only attempted to spray out of the hole once and it took me for quite a ride spinning like crazy.

Questions:
Will shocks help me much?
Is there a problem w/ 28" tires in back and 26" in front. The car has quite a rake to it and I'm wondering if that's why I'm not getting good weight transfer. Will dropping the back of the car 1" and adding some relo brackets do me any good?

Sorry for the long thread. I'm looking for any help you can offer.
TIA,
Craig
calongo_SS is offline   Reply With Quote
Old 07-09-2006, 09:28 PM   #2
TECH Senior Member
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Quote:
Originally Posted by calongo_SS
I've recently done quite a bit to gain traction w/ pretty disapointing results. I'm looking for advice as to what I should do?
Some details on the car:
Car is a 01 SS, full weight (3700 #'s w/ me in it)
Cam only TSP 233/239, & regular bolt ons, and TNT 150 wet shot.
Custom TCI 4000 stall for nitrous.
Rear Suspension:
BMR LCA's, BMR subrames, BMR PHR, Jegster T/A set at -3 deg.
Moser 12 bolt, full spool, 3.73 gears.
Front: Stock minus swaybar

I'm running 3.5" prostars up front, and 15 x 10 out back w/ 325 - 50 M/T Drag radials.

I've cut a best 60' of 1.67 on motor spinning slightly, and I only attempted to spray out of the hole once and it took me for quite a ride spinning like crazy.

Questions:
Will shocks help me much?
Is there a problem w/ 28" tires in back and 26" in front. The car has quite a rake to it and I'm wondering if that's why I'm not getting good weight transfer. Will dropping the back of the car 1" and adding some relo brackets do me any good?

Sorry for the long thread. I'm looking for any help you can offer.
TIA,
Craig
Is the car wieght transfering at all Craig??
You fott braking the car up or flashing the converter??
id say do the LCA Relo Brackets and some adj. shocks...... I say doubles front and rear but others wont.

TTT for ya man.
Kyle
NA$TY-TA is offline   Reply With Quote
Old 07-09-2006, 09:35 PM   #3
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

Doesn't really feel like it's transfering weight very well. I'll take a look at the video soon.
I was foot braking, not flashing. I've tried anywhere from 1500-3000.
calongo_SS is offline   Reply With Quote
Old 07-09-2006, 10:25 PM   #4
TECH Senior Member
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Quote:
Originally Posted by calongo_SS
Doesn't really feel like it's transfering weight very well. I'll take a look at the video soon.
I was foot braking, not flashing. I've tried anywhere from 1500-3000.

PM me what it did run if ya dont want to post it up.

Kyle
NA$TY-TA is offline   Reply With Quote
Old 07-09-2006, 10:46 PM   #5
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

Same as last time, 11.2 @ 126 spraying about 30-40' out.

What shocks do you like Kyle? Keep in mind, I primarily drive it on the street.
calongo_SS is offline   Reply With Quote
Old 07-09-2006, 10:51 PM   #6
TECH Senior Member
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Quote:
Originally Posted by calongo_SS
Same as last time, 11.2 @ 126 spraying about 30-40' out.

What shocks do you like Kyle? Keep in mind, I primarily drive it on the street.

We went with the Strange Doubles on all for Corners..... they are a little spendy..... plus there front springs.

You can run there single springs wicj Strange says is the same as the Type ""R"" QA1's. They are about $150 a shock. Id at least try the fronts to get the weight up and transfering to the back.....
I know Stenod carries them... Give him a ring and tell him i sent ya....
I wanna see 10's for ya man.... your so close.....


Kyle
NA$TY-TA is offline   Reply With Quote
Old 07-09-2006, 10:56 PM   #7
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

If I could get down to 1.50 60' I'd be pretty damn happy. That should get me the ET I'd be happy with for a while.
I was about to pull the trigger on some heads/intake, but what's the point if I can't hook?
calongo_SS is offline   Reply With Quote
Old 07-09-2006, 11:22 PM   #8
12 Second Club
iTrader: (13)
 
HD1911's Avatar
 
Join Date: May 2006
Location: Henderson, KY
Posts: 380
Default

what springs do you have on the car??
HD1911 is offline   Reply With Quote
Old 07-09-2006, 11:24 PM   #9
TECH Senior Member
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Quote:
Originally Posted by calongo_SS
If I could get down to 1.50 60' I'd be pretty damn happy. That should get me the ET I'd be happy with for a while.
I was about to pull the trigger on some heads/intake, but what's the point if I can't hook?
Yeah thats so true... use the power u have now... ah ha dont add more.. prob get worse ya know.
NA$TY-TA is offline   Reply With Quote
Old 07-09-2006, 11:55 PM   #10
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

Quote:
Originally Posted by HD1911
what springs do you have on the car??
Stock

I also have a BMR sway bar in back. Not the drag one, but it is a solid peice.

Last edited by calongo_SS; 07-10-2006 at 12:13 AM.
calongo_SS is offline   Reply With Quote
Old 07-10-2006, 02:02 PM   #11
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

What do you guys think about the rake? Would there be any point in lowering the back of the car to level it out?
calongo_SS is offline   Reply With Quote
Old 07-10-2006, 03:52 PM   #12
n2o
TECH Enthusiast
iTrader: (1)
 
n2o's Avatar
 
Join Date: Jan 2003
Location: Saban Country
Posts: 702
Default

You could take the spring rubbers off and put some hose on it. I did that and it lowered mine 1/2in. or so. What about lca relocation brackets? You need them if you don't have them. Also You should consider moving your battery to the rear.
n2o is offline   Reply With Quote
Old 07-10-2006, 05:26 PM   #13
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

So if I got shocks, maybe springs, relo brackets, and moved the battery to the trunk should I be able to dead hook on the 150 shot?

I'm gonna call Stenod pretty soon Kyle and see what they suggest.
calongo_SS is offline   Reply With Quote
Old 07-10-2006, 08:27 PM   #14
n2o
TECH Enthusiast
iTrader: (1)
 
n2o's Avatar
 
Join Date: Jan 2003
Location: Saban Country
Posts: 702
Default

1.50 60's should be no problem. That race weight is alot to get moving. Track prep will have alot to do with whether or not you "dead hook" on drag radials of any sort. I know from experience I am currently running 325's on tracks that have poor to average prep. I cut a 1.64 on motor the other night with a busted tranny. The battery and the relo brackets definitely help.
n2o is offline   Reply With Quote
Old 07-10-2006, 11:21 PM   #15
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

Yeah, I know the car is a pig. But I live 100 + miles from a drag strip so I'm gonna keep A/C, heat, power steering, radio, power stuff, etc... for a while.
Some day I'll get a k-member & a arms, but for now the car is going to stay a pig.

Maybe down the road I'll get another set of prostars w/ some slicks for track days.

Will a 28" slick fit w/o mini tubbing? The 28" radials fit, but they don't grow like a slick does.
calongo_SS is offline   Reply With Quote
Old 07-11-2006, 08:11 AM   #16
n2o
TECH Enthusiast
iTrader: (1)
 
n2o's Avatar
 
Join Date: Jan 2003
Location: Saban Country
Posts: 702
Default

If you got the 325's to fit a regular 10.5 will fit no problem. I believe a 10.5w will fit as well. The K-member is something that I am kicking myself around for not doing. I will be losing that 40 lb at some point in the near future.
n2o is offline   Reply With Quote
Old 07-12-2006, 08:18 PM   #17
9 Second Club
iTrader: (4)
 
Join Date: Dec 2004
Location: Cali
Posts: 2,608
Default

A 10.5W will fit no problem... That's what I run and with just a tad bit of rolling the inner fenders they clear no prob.... running V6 camaro springs and CE 3 way adjustable crap shocks.....
OutlawZ is offline   Reply With Quote
Old 07-12-2006, 10:47 PM   #18
10 Second Club
Thread Starter
iTrader: (7)
 
calongo_SS's Avatar
 
Join Date: Feb 2004
Location: Victoria, TX
Posts: 2,070
Default

That's good to know.
I think I might have been spinning the wheel on the rim, which might have been part of my problem. I am running tubes, b/c the wheels had holes for screws when I got them, but I never put screws in. Anyway, one of the tires went flat, and is leaking bady from around the valvestem (not actually through it). I still haven't got the video yet though to see for sure.
calongo_SS is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:17 PM.