Go Back   LS1TECH > RACING DEPARTMENT > Drag Racing Tech
Sign in using an external account
Register Forgot Password?
Search

Drag Racing Tech
Rules | Safety | Setups | Hardware | Methods
Sponsored by
Scoggin-Dickey Parts Center
Click Here

Steering Issue on Long End of Track?

Reply
 
Thread Tools Search this Thread
Old 04-28-2008, 03:24 PM   #1
TECH Fanatic
 
tee-boy's Avatar
 
Trader Rating: 8
Join Date: Apr 2007
Posts: 1,168
Default Steering Issue on Long End of Track?

Does anyone notice that their front tires pull hard after about the 1/8 mile at the track. It seems I have to fight the car to keep it going straight. I assume it's from the 275/17 directional treads on the front.

The track I go to was re-surfaced last year, so it can't be too uneven.
tee-boy is offline   Reply With Quote
Old 04-28-2008, 04:22 PM   #2
Race your car!
 
Trader Rating: 49
Join Date: Mar 2004
Posts: 14,353
Default

Probably the rear tires at differnt sizes. That will cause what you're talking about, if you're having a problem with the car pulling in one direction at speed.

If it's bad enough it will cause the car to launch screwy as well.

Measure the rear tires, sounds like you have a set that's not matched up very well.
JL ws-6 is offline   Reply With Quote
Old 04-28-2008, 04:28 PM   #3
TECH Fanatic
 
tee-boy's Avatar
 
Trader Rating: 8
Join Date: Apr 2007
Posts: 1,168
Default

forgot to mention that rears are 275/17 true street tires
tee-boy is offline   Reply With Quote
Old 04-28-2008, 05:12 PM   #4
Race your car!
 
Trader Rating: 49
Join Date: Mar 2004
Posts: 14,353
Default

I bet the rear isn't lined up right, or your alignment in the front end is off
JL ws-6 is offline   Reply With Quote
Old 04-28-2008, 05:43 PM   #5
TECH Fanatic
 
tee-boy's Avatar
 
Trader Rating: 8
Join Date: Apr 2007
Posts: 1,168
Default

might be time for a 4 wheel computer alignment. have adj panhard and control arms.
tee-boy is offline   Reply With Quote
Old 04-28-2008, 07:23 PM   #6
Race your car!
 
Trader Rating: 49
Join Date: Mar 2004
Posts: 14,353
Default

control arms are probably off. If you had relocateion brackets put on, I bet one isn't welded exactly the same as the other, that will do it too.
JL ws-6 is offline   Reply With Quote
Old 04-28-2008, 08:49 PM   #7
TECH Fanatic
 
tee-boy's Avatar
 
Trader Rating: 8
Join Date: Apr 2007
Posts: 1,168
Default

yeahp, I put the relocation brackets on myself. measured the control arms to stock length. 4 wheel computer alignment should take care of that as well.
tee-boy is offline   Reply With Quote
Old 04-28-2008, 08:49 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 12:32 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details