Help - LS1TECH



Florida Members Fun, sun and LS1's

Help

Reply
 
Thread Tools Search this Thread
Old 12-25-2008, 10:31 AM   #1
Teching In
Thread Starter
 
Join Date: Apr 2008
Location: Orlando
Posts: 4
Default Help

I just changed my spark plugs last night and I was out driving. Now everytime I give it gas there is a knocking noise comming from the driver side. Any suggestions on what I should do?
HoTrOd HaRrY is offline   Reply With Quote
Old 12-25-2008, 10:42 AM   #2
TECH Addict
iTrader: (21)
 
blk/slvr02ss's Avatar
 
Join Date: Dec 2006
Location: Port Saint Lucie,Florida
Posts: 2,773
Default

It sound's like you may have not tightened a plug enough.Recheck them to make sure.
blk/slvr02ss is offline   Reply With Quote
Old 12-25-2008, 11:11 AM   #3
TECH Apprentice
iTrader: (7)
 
Join Date: Jun 2006
Location: Deltona, FL
Posts: 369
Default

Pulled a wire apart or not got one hooked back up completely....
kwiksilverz28 is offline   Reply With Quote
Old 12-25-2008, 06:22 PM   #4
Teching In
Thread Starter
 
Join Date: Apr 2008
Location: Orlando
Posts: 4
Default

I still cant figure out where the knocking is comming from its not the plugs or the wires. Does anybody know of a shop thats good and i can take it to to have it looked at?
HoTrOd HaRrY is offline   Reply With Quote
Old 12-26-2008, 01:35 AM   #5
TECH Apprentice
iTrader: (7)
 
Join Date: Jun 2006
Location: Deltona, FL
Posts: 369
Default

My garage but I hate to charge you normal my shop rate.....

If it was fine before you touched it, and it is not afterwards, it is something you touched....
kwiksilverz28 is offline   Reply With Quote
Old 12-26-2008, 01:59 AM   #6
11 Second Club
iTrader: (10)
 
torquejunky's Avatar
 
Join Date: Jan 2008
Location: Orlando, fL
Posts: 343
Default

Cracked plug maybe???
torquejunky is offline   Reply With Quote
Old 12-26-2008, 11:03 PM   #7
Launching!
iTrader: (5)
 
OnA Fan's Avatar
 
Join Date: Feb 2006
Location: Tampa Bay Area
Posts: 249
Default

Quote:
Originally Posted by blk/slvr02ss View Post
It sound's like you may have not tightened a plug enough.Recheck them to make sure.
x2. I had that happen before.
OnA Fan is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Is my 350 Block any good?? strokerpilot Small Block & Big Block Chevy Specific 8 10-06-2010 07:30 PM
i wish I was blind streetassasin Racer's Lounge 27 09-13-2007 12:53 PM
i mean now!!!!!!!!!! billyb Florida Members 18 07-07-2006 09:44 PM
123 Mike24 Signature Testing & Design 1 03-21-2006 08:41 PM
Can I add it ASR jimboss Chevrolet Camaro 1967-2002 23 01-16-2006 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:33 AM.