Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Fueling & Injection
Sign in using an external account
Register Forgot Password?
Search

Fueling & Injection
Fuel Pumps | Injectors | Rails | Regulators | Tanks

FIC reworked stock injectors

Reply
 
Thread Tools Search this Thread
Old 04-26-2012, 08:57 PM   #1
TECH Apprentice
 
marthastewart's Avatar
 
Trader Rating: 1
Join Date: Apr 2006
Posts: 301
Default FIC reworked stock injectors

Guys with these reworked to 42#'s, did you need to change anything in the tune other than the flow rate? having a surge still at 1500-2000 rpm's and everything else is tuned nice. Wondering if there is something here i might be missing.
__________________
99Z A4 w/ SS LT's, h/f cats, magnaflow catback, port/polish t/b, egr deleted, ls6 intake, lid, 3.73's, hpt, performabuilt level 1 tranny, 3600 stall, Stage 2.5 (5.3 heads), Torquer 2 cam, FIC 42# reworked injectors, TR6 plugs
marthastewart is offline   Reply With Quote
Old 04-26-2012, 09:54 PM   #2
LS1Tech Sponsor
 
FICINJECTORS's Avatar
 
Trader Rating: 30
Join Date: Sep 2008
Location: Cumming, Ga
Posts: 1,254
Default

Quote:
Originally Posted by marthastewart View Post
Guys with these reworked to 42#'s, did you need to change anything in the tune other than the flow rate? having a surge still at 1500-2000 rpm's and everything else is tuned nice. Wondering if there is something here i might be missing.
Send me your tune, let us see what you did.
FICINJECTORS is online now   Reply With Quote
Old 04-27-2012, 10:15 AM   #3
TECH Apprentice
 
marthastewart's Avatar
 
Trader Rating: 1
Join Date: Apr 2006
Posts: 301
Default

Quote:
Originally Posted by FICINJECTORS View Post
Send me your tune, let us see what you did.
Sent these to your email with the config.
Attached Files
File Type: hpt 4-4-12 GOOD RUNNING 1 added to injector timing.hpt (462.9 KB, 65 views)
File Type: hpl 3-11-2012 AROUND TOWN.hpl (199.1 KB, 50 views)
__________________
99Z A4 w/ SS LT's, h/f cats, magnaflow catback, port/polish t/b, egr deleted, ls6 intake, lid, 3.73's, hpt, performabuilt level 1 tranny, 3600 stall, Stage 2.5 (5.3 heads), Torquer 2 cam, FIC 42# reworked injectors, TR6 plugs
marthastewart is offline   Reply With Quote
Old 04-27-2012, 06:22 PM   #4
TECH Resident
 
ZL1Killa's Avatar
 
Trader Rating: 17
Join Date: Sep 2004
Location: NC - Charlotte area
Posts: 3,748
Send a message via AIM to ZL1Killa
Default

what version of hptuners are you using? I get an error why trying to open saying that:

Unable to open file.
Index was outside the bounds of the array.


are you running hptuners beta?
__________________
01 T/A WS6 #4984 PM for info...funny rear mount...father/son build.
My Rear Mount build
655RWHP & 688RWTQ
NEW: TC76, 69.65# FIC 725s , FPR, External Bosch 044, 12-Bolt 3.42,
Manifolds, Forged Rods+Pistons,

Leaky Moser or issues?
ZL1Killa is offline   Reply With Quote
Old 04-27-2012, 06:29 PM   #5
LS1Tech Sponsor
 
FICINJECTORS's Avatar
 
Trader Rating: 30
Join Date: Sep 2008
Location: Cumming, Ga
Posts: 1,254
Default

Quote:
Originally Posted by marthastewart View Post
Sent these to your email with the config.
I can't open it either
FICINJECTORS is online now   Reply With Quote
Old 04-27-2012, 07:28 PM   #6
TECH Apprentice
 
marthastewart's Avatar
 
Trader Rating: 1
Join Date: Apr 2006
Posts: 301
Default

Yes it's BETA.
__________________
99Z A4 w/ SS LT's, h/f cats, magnaflow catback, port/polish t/b, egr deleted, ls6 intake, lid, 3.73's, hpt, performabuilt level 1 tranny, 3600 stall, Stage 2.5 (5.3 heads), Torquer 2 cam, FIC 42# reworked injectors, TR6 plugs
marthastewart is offline   Reply With Quote
Old 04-27-2012, 08:01 PM   #7
TECH Resident
 
ZL1Killa's Avatar
 
Trader Rating: 17
Join Date: Sep 2004
Location: NC - Charlotte area
Posts: 3,748
Send a message via AIM to ZL1Killa
Default

let me log my car tomorrow morning, and check everything. I will install the beta tomorrow evening and let you know, I don't want to mess anything up with what I have spent the past hour setting up, so I'll check it once I'm done
__________________
01 T/A WS6 #4984 PM for info...funny rear mount...father/son build.
My Rear Mount build
655RWHP & 688RWTQ
NEW: TC76, 69.65# FIC 725s , FPR, External Bosch 044, 12-Bolt 3.42,
Manifolds, Forged Rods+Pistons,

Leaky Moser or issues?
ZL1Killa is offline   Reply With Quote
Old 04-30-2012, 09:27 PM   #8
TECH Resident
 
ZL1Killa's Avatar
 
Trader Rating: 17
Join Date: Sep 2004
Location: NC - Charlotte area
Posts: 3,748
Send a message via AIM to ZL1Killa
Default

your data for the fuel injectors.. you say they are reworked 42#ers...
is all of your injector data set correctly for those injectors? are you certain? can you email me the data file for the injectors ? sm1218@aol.com


why do you have your rev limiter set to 7k?
you have turned off DFCO, doesn't really matter but why?

at what point in the data log did you get the surge?
your spark table(s) in the range of idle...really 400 rpm up to 1600 rpm vary too much. Set your 400 to 1000 all to 24 or 26 up to 0.16
This is my table from 400 rpm to 1800 rpm up to 0.36 vertical
30.0 28.0 26.0 29.5 33.0 35.0 36.0 39.0
30.0 28.0 26.0 29.5 33.0 35.0 36.0 39.0
30.0 28.0 26.0 29.5 33.0 35.0 36.0 39.0
30.0 28.0 26.0 29.5 33.0 35.0 36.0 38.0
30.0 28.0 26.0 29.5 33.0 35.4 35.9 37.0
27.1 25.9 26.0 28.9 33.0 34.8 35.5 37.0
24.1 23.8 26.4 28.9 32.1 33.6 35.0 36.0
22.0 21.8 24.7 28.0 31.0 33.0 34.0 35.0
__________________
01 T/A WS6 #4984 PM for info...funny rear mount...father/son build.
My Rear Mount build
655RWHP & 688RWTQ
NEW: TC76, 69.65# FIC 725s , FPR, External Bosch 044, 12-Bolt 3.42,
Manifolds, Forged Rods+Pistons,

Leaky Moser or issues?

Last edited by ZL1Killa; 04-30-2012 at 09:43 PM..
ZL1Killa is offline   Reply With Quote
Old 04-30-2012, 10:14 PM   #9
TECH Apprentice
 
marthastewart's Avatar
 
Trader Rating: 1
Join Date: Apr 2006
Posts: 301
Default

Quote:
Originally Posted by ZL1Killa View Post
your data for the fuel injectors.. you say they are reworked 42#ers...
is all of your injector data set correctly for those injectors? are you certain? can you email me the data file for the injectors ? sm1218@aol.com


why do you have your rev limiter set to 7k?
you have turned off DFCO, doesn't really matter but why?

at what point in the data log did you get the surge?
your spark table(s) in the range of idle...really 400 rpm up to 1600 rpm vary too much. Set your 400 to 1000 all to 24 or 26 up to 0.16
This is my table from 400 rpm to 1800 rpm up to 0.36 vertical
30.0 28.0 26.0 29.5 33.0 35.0 36.0 39.0
30.0 28.0 26.0 29.5 33.0 35.0 36.0 39.0
30.0 28.0 26.0 29.5 33.0 35.0 36.0 39.0
30.0 28.0 26.0 29.5 33.0 35.0 36.0 38.0
30.0 28.0 26.0 29.5 33.0 35.4 35.9 37.0
27.1 25.9 26.0 28.9 33.0 34.8 35.5 37.0
24.1 23.8 26.4 28.9 32.1 33.6 35.0 36.0
22.0 21.8 24.7 28.0 31.0 33.0 34.0 35.0

I didnt get a file with them They came from FIC with a little card that said 42lbs (and thats what the guy I spoke to on the phone said they were) I totally believe him and think the injectors are great. My stock ones were showing 100% DC where as these are only in the 70% range. I am not saying the injectors are wrong, just asking the guys that have put them in, if they needed to change anything else than what I did.

I have no clue whats up with the RPM. I had a few other guys attempting to help and though I look over the changes I guess I missed that one. I will knock that down a little even though I hope the A4 shifts well before it gets to that!

DFCO was turned off to do tuning before. I read to disable that as well as COT. I though I had those back on though.

As far as timing goes, I have tried a higher timing, smooth, and just about everything else. For some reason this cam does not like any timing at all. I see where most put their idle timing at mid to upper 20's but this cam runs like crap there.

I have been looking for answers to this surge at the HP Tuners site too. I couple of the guys there think it has to does with the NB02's cant react quick enough to the overlap (9*). This giving me the surge. I disabled closed loop and problem solved. Put about 100 miles on it with the 02's disabled and no surge what so ever. Ready to just say screw it and leave it in open loop for good and not have to worry about this at all. (Sucks that I just bought 2 new O2 sensors though.
__________________
99Z A4 w/ SS LT's, h/f cats, magnaflow catback, port/polish t/b, egr deleted, ls6 intake, lid, 3.73's, hpt, performabuilt level 1 tranny, 3600 stall, Stage 2.5 (5.3 heads), Torquer 2 cam, FIC 42# reworked injectors, TR6 plugs
marthastewart is offline   Reply With Quote
Old 05-01-2012, 10:00 AM   #10
TECH Resident
 
ZL1Killa's Avatar
 
Trader Rating: 17
Join Date: Sep 2004
Location: NC - Charlotte area
Posts: 3,748
Send a message via AIM to ZL1Killa
Default

Quote:
Originally Posted by marthastewart View Post
I didnt get a file with them They came from FIC with a little card that said 42lbs (and thats what the guy I spoke to on the phone said they were) I totally believe him and think the injectors are great. My stock ones were showing 100% DC where as these are only in the 70% range. I am not saying the injectors are wrong, just asking the guys that have put them in, if they needed to change anything else than what I did.

I have no clue whats up with the RPM. I had a few other guys attempting to help and though I look over the changes I guess I missed that one. I will knock that down a little even though I hope the A4 shifts well before it gets to that!

DFCO was turned off to do tuning before. I read to disable that as well as COT. I though I had those back on though.

As far as timing goes, I have tried a higher timing, smooth, and just about everything else. For some reason this cam does not like any timing at all. I see where most put their idle timing at mid to upper 20's but this cam runs like crap there.

I have been looking for answers to this surge at the HP Tuners site too. I couple of the guys there think it has to does with the NB02's cant react quick enough to the overlap (9*). This giving me the surge. I disabled closed loop and problem solved. Put about 100 miles on it with the 02's disabled and no surge what so ever. Ready to just say screw it and leave it in open loop for good and not have to worry about this at all. (Sucks that I just bought 2 new O2 sensors though.
do you have a copy of hptuners that you can look at your tune with? or do you just go to the shop(s)?
I'm running open loop with fuel trim feedback...and love it.

If the car is tuned correctly under OL you will be fine.
The only reason to turn DFCO off is so that it doesn't come on.... the only thing it comes on for is Deceleration fueling cut off... so when you let off the throttle fuel is cut and you get a lean condition in your data logger.... the thing is if you stay out of DFCO it doesn't need to be turned off....just depends on the tuner I guess.

I would definitely get that 7krpm rev limiter put back to 6400 or 6800 if you wish, but I would bet on the dyno you don't make power above 6400 so whats the point? really shitty its up at 7k
__________________
01 T/A WS6 #4984 PM for info...funny rear mount...father/son build.
My Rear Mount build
655RWHP & 688RWTQ
NEW: TC76, 69.65# FIC 725s , FPR, External Bosch 044, 12-Bolt 3.42,
Manifolds, Forged Rods+Pistons,

Leaky Moser or issues?
ZL1Killa is offline   Reply With Quote
Old 05-01-2012, 08:48 PM   #11
TECH Resident
 
ZL1Killa's Avatar
 
Trader Rating: 17
Join Date: Sep 2004
Location: NC - Charlotte area
Posts: 3,748
Send a message via AIM to ZL1Killa
Default

and your IFR table doesn't look right, and your VE table looks like its too high...likely due to IFR being off.

Lets get a few things straight first. These injectors are 42# at what PSI? 43.5 or 58?
If they are rated at 43.5psi then you should have an IFR table that looks like this:
48.49827788 48.80053386 49.10092925 49.39949798 49.69627298 49.9912862 50.28456864 50.57615042 50.86606077 51.15432813 51.4409801 51.72604355 52.00954459 52.29150865 52.57196044 52.85092404 53.12842289


if they are rated at 58 it should look like this:
42.00074069 42.34939629 42.69520481 43.03823487 43.3785524 43.71622075 44.05130082 44.38385125 44.71392847 45.04158686 45.36687882 45.68985491 46.01056389 46.32905284 46.64536724 46.95955102 47.27164668

so your IFR numbers to me look OFF as you start with 40.01 ... odd.
__________________
01 T/A WS6 #4984 PM for info...funny rear mount...father/son build.
My Rear Mount build
655RWHP & 688RWTQ
NEW: TC76, 69.65# FIC 725s , FPR, External Bosch 044, 12-Bolt 3.42,
Manifolds, Forged Rods+Pistons,

Leaky Moser or issues?
ZL1Killa is offline   Reply With Quote
Old 05-03-2012, 10:18 PM   #12
TECH Apprentice
 
marthastewart's Avatar
 
Trader Rating: 1
Join Date: Apr 2006
Posts: 301
Default

Well here is the latest update. I put TR6 plugs in and all the low end knock I had is now gone. Guess this set up needs those plugs. As for the injectors I called FIC and spoke to John. He hooked me up with this data sheet for these reworked 42lb injectors. Guess my IFR was ~5% off. Thanks to all those that helped and thanks FIC for providing a good product and great CS!!
__________________
99Z A4 w/ SS LT's, h/f cats, magnaflow catback, port/polish t/b, egr deleted, ls6 intake, lid, 3.73's, hpt, performabuilt level 1 tranny, 3600 stall, Stage 2.5 (5.3 heads), Torquer 2 cam, FIC 42# reworked injectors, TR6 plugs
marthastewart is offline   Reply With Quote
Old 05-03-2012, 10:18 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
bad, email, fic, flow, fuel, hpuners, idle, injectors, ls1tech, ls6, replaced, reworked, stock, surge, table, tune


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 08:06 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details