Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Fueling & Injection
Sign in using an external account
Register Forgot Password?
Search

Fueling & Injection
Fuel Pumps | Injectors | Rails | Regulators | Tanks
Sponsored by
Aeromotive Inc

Boost-A-Pump Question

Reply
 
Thread Tools Search this Thread
Old 07-22-2007, 05:43 PM   #1
11 Second Club
Garage is empty, add now
 
BBM98C5's Avatar
 
Trader Rating: 2
Join Date: Dec 2004
Location: Oswego Il
Posts: 77
Default Boost-A-Pump Question

I have a question about my boost-a-pump. On Tuesday, my car had no fuel pressure as my fuel pump would not kick on. I got to the wiring and checked itgoing and coming from the boost-a-pump, checked all fuses, and checked the relay for the pump and there was no problem. After the boost-a-pump where it connects to the fuel pump wiring, I have my aftercooler pump wired, so I know the problem is before there, because the aftercooler wasnt working either. After I checked all of the wiring, I turned the key on and the pumps kicked on. Today, the same thing happened, except for I just tapped on the BAP and tried the key and the pumps kicked on again. My question is, can the BAP go bad and be causing there to be no power sent out of it? The car has had the BAP for 2 1/2 years and this has never happened before, and the BAP was used when I got it. Do you guys think it is time for a new BAP?
__________________
Just a slow Vette with a noisy intake.
Best E.T. 11.34@122 w/a 1.86 60FT
BBM98C5 is offline   Reply With Quote
Old 07-23-2007, 03:03 PM   #2
LS1Tech Sponsor
Garage is empty, add now
 
Nasty N8's Avatar
 
Trader Rating: 33
Join Date: Feb 2002
Location: Lake in the Hills, IL
Posts: 5,047
Default

Never seen a bad one but it is possible as it is just a fancy relay. It is either that or a bad connection somewhere.

Nate
__________________
Nate 847-458-4858 www.NastyPerformance.com
Nate@nastyperformance.comAlso see us on Facebook http://www.facebook.com/home.php?#!/...632733?ref=sgm
Nasty Performance Billet Valve Covers Starting at $430
Nasty Performance fuel rails to fit all LS1,LS2,LS3,LS7,L76,L92, FAST 90,92,102LSXR intakes and more In stock ON SALE NOW
Nasty N8 is online now   Reply With Quote
Old 07-23-2007, 03:55 PM   #3
11 Second Club
Garage is empty, add now
 
BBM98C5's Avatar
 
Trader Rating: 2
Join Date: Dec 2004
Location: Oswego Il
Posts: 77
Default

Yea, I was thinking a it could be a connection, but it has never happened before in almost 3 years, so I didnt think that was what it was.
__________________
Just a slow Vette with a noisy intake.
Best E.T. 11.34@122 w/a 1.86 60FT
BBM98C5 is offline   Reply With Quote
Old 07-23-2007, 06:59 PM   #4
LS1Tech Sponsor
Garage is empty, add now
 
Nasty N8's Avatar
 
Trader Rating: 33
Join Date: Feb 2002
Location: Lake in the Hills, IL
Posts: 5,047
Default

Could be corrosion over time. Just something not touching 100%.

Nate
__________________
Nate 847-458-4858 www.NastyPerformance.com
Nate@nastyperformance.comAlso see us on Facebook http://www.facebook.com/home.php?#!/...632733?ref=sgm
Nasty Performance Billet Valve Covers Starting at $430
Nasty Performance fuel rails to fit all LS1,LS2,LS3,LS7,L76,L92, FAST 90,92,102LSXR intakes and more In stock ON SALE NOW
Nasty N8 is online now   Reply With Quote
Old 07-23-2007, 06:59 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details