MWC driveshaft loop won't fit - LS1TECH

Log In 


Gears & Axles Driveshafts | Rearends | Differentials | Gears | 12 Bolt | 9 Inch | Dana

MWC driveshaft loop won't fit

Reply
 
Thread Tools Search this Thread
Old 01-16-2010, 05:34 PM   #1
10 Second Club
Thread Starter
iTrader: (27)
 
RsSean's Avatar
 
Join Date: Feb 2008
Location: Pensacola, FL
Posts: 2,183
Default MWC driveshaft loop won't fit

I have tried different ways of installing this thing and it either hits the body or it hits the exhaust anyone have any pics that may help me out.

Thanks
RsSean is offline   Reply With Quote
Old 01-17-2010, 01:47 PM   #2
10 Second Club
Thread Starter
iTrader: (27)
 
RsSean's Avatar
 
Join Date: Feb 2008
Location: Pensacola, FL
Posts: 2,183
Default

Bump someone has to have some insight on this.
RsSean is offline   Reply With Quote
Old 01-17-2010, 02:27 PM   #3
TECH Apprentice
iTrader: (1)
 
Join Date: Dec 2007
Posts: 354
Default

I had the same problem due to my stock y pipe. I took and shaved a half moon shape into the vertical brace on the loop.
boss79z is offline   Reply With Quote
Old 01-17-2010, 02:28 PM   #4
TECH Apprentice
iTrader: (1)
 
Join Date: Dec 2007
Posts: 354
Default

This is the best picture I got man.
Attached Thumbnails
MWC driveshaft loop won't fit-dsc01925.jpg  
boss79z is offline   Reply With Quote
Old 01-17-2010, 04:37 PM   #5
Banned
iTrader: (26)
 
Join Date: Dec 2006
Location: Central Illinois
Posts: 3,476
Default

do you have just the d/s lop or is it a torque arm/crossmember assy?

the d/s loop by itself is designed to lay right on the sheetmetal of the tunnel. start(don't tighten) one side of the bolts, push it up into the tunnel, and then start the other bolts. this is the way it is designed, allow for the most exhaust and torque arm clearance, and not hang low/under the exhaust like all the other designs out there that drag the ground or your trailer.
ssvert99 is offline   Reply With Quote
Old 01-17-2010, 07:11 PM   #6
10 Second Club
Thread Starter
iTrader: (27)
 
RsSean's Avatar
 
Join Date: Feb 2008
Location: Pensacola, FL
Posts: 2,183
Default

Yes I got the DS loop brace only. I figured that is the way it was supposed to go but was not willing to have it resting on the body of the car. Thanks

It the brake lines supposed to be on the inside pinned agasint the body or on the outside.
RsSean is offline   Reply With Quote
Old 01-19-2010, 11:35 PM   #7
Banned
iTrader: (10)
 
cookba's Avatar
 
Join Date: May 2006
Location: Tampa
Posts: 2,844
Default

mine didnt fit either with my GMMG exhaust and Kooks headers. gonna have to put it back on a rack and see what i can do.
cookba is offline   Reply With Quote
Old 01-20-2010, 09:16 AM   #8
Launching!
iTrader: (4)
 
hokie00 TA's Avatar
 
Join Date: Sep 2006
Location: Culpeper Va
Posts: 287
Default

i had to grind a notch in mine so it would fit around the exhaust
hokie00 TA is offline   Reply With Quote
Old 01-20-2010, 01:10 PM   #9
12 Second Club
 
WARP211's Avatar
 
Join Date: Feb 2007
Location: Fairfield, Cali
Posts: 150
Default

Most likely it won't fit unless you modify the exhaust to get it up higher in the tunnel area.. I had the same problem wit UMI DSL setup and just sent it back and got something else. My setup was ARH headers with their catted Y-pipe.
WARP211 is offline   Reply With Quote
Old 01-20-2010, 03:33 PM   #10
TECH Enthusiast
iTrader: (13)
 
Giddswat's Avatar
 
Join Date: Jan 2006
Location: Parkton, Md.
Posts: 658
Default

I have the MW d/s loop and at first it rubbed the exhaust a little bit, I have Kooks L/T and a Borla exhaust. We just had to loosen all of the exhaust clamps and mounts and used a ratchet strap to pull the exhaust away and re tighten everything back up . I have not had a problem since. I mounted the fuel line on the outside, I was concerned about rubbing a line thru. You have to remove a fuel line clamp or two and just re secure the lines on the outside.
Giddswat is offline   Reply With Quote
Old 01-21-2010, 08:42 PM   #11
10 Second Club
Thread Starter
iTrader: (27)
 
RsSean's Avatar
 
Join Date: Feb 2008
Location: Pensacola, FL
Posts: 2,183
Default

I just said the hell with it and set it aside for now, till I go to the track and I will find a way to mount it for the track
RsSean is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WTB: used ls7 motor Carlos01SS Parts Wanted 3 06-16-2016 09:39 PM
holley issues help usmc53 Carbureted LSX Forum 0 12-27-2014 06:36 PM
Cam with great drivability abates LT1-LT4 Modifications 31 12-15-2010 09:34 PM
TVS 2300 Install issue twinturbo496 Forced Induction 8 11-29-2010 10:00 AM
Ported LS2 Intake MonmouthCtyLS7 Parts Wanted 7 08-27-2009 10:37 PM


Tags
arm, bmr, chassis, drive, driveline, driveshaft, fit, loop, midwest, mwc, shaft, silverado, torque, wont, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 12:31 AM.