s60 with strac.. Diff seems ratchety?? new install - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Gears & Axles
Sign in using an external account
Register Forgot Password?
Search


Gears & Axles
Driveshafts | Rearends | Differentials | Gears | 12 Bolt | 9 Inch | Dana
Sponsored by
JawsGear

s60 with strac.. Diff seems ratchety?? new install

Reply
 
Thread Tools Search this Thread
Old 04-18-2012, 08:46 PM   #1
TECH Fanatic
 
Trader Rating: 12
Join Date: Jun 2007
Location: earth
Posts: 1,433
Default s60 with strac.. Diff seems ratchety?? new install

so when i spin the axles you can feel the differential catching and sounds like a ratchet. not smooth as i would expect a torsen dif. anyone else with a s60 experience this? when i went for a drive the first turn i took felt a little like it was a detroit locker... seems to be getting better as im driving but just freaking me out... have a friend with a new one not yet driven and it doesnt do it, though you can hear a hint of it barely... but mine would actually catch turning by hand.
__________________

2000 ws6 - was stock 5.3 pt7675 making 700+rwhp. currently building turbo kit again.... haha
2001 camaro 408, afr 225s, pt88, 4l80e. 880rwhp on 19-20psi 91 pump gas.
got-a-ls1 is offline   Reply With Quote
Old 04-18-2012, 11:03 PM   #2
TECH Resident
 
Trader Rating: 34
Join Date: Jun 2007
Location: Iowa
Posts: 901
Default

Does the posi you're using require friction modifier? Maybe the diff fluid you put in doesn't have any mixed in and you have to add some separately.
__________________
'02 Z28 - NBM - LS1 / M6 - PRC LS6 Heads - CamMotion LLSR 236/240-.640/.615 - SLP 25% UD Pulley - Speed Pro pistons - Fast 92 / Nick Williams 92 TB - EFILive Tune - SE 1-7/8" LTs - True Dual/Duals & CME - 19x12 & 18x9.5 Spyders - Viking DA Shocks - Diamond Clutch - Spohn TA - 8.8 Rear with Hiltsy TA Mount, FRP 4.10s, 31 spline Strange axles, minitubs - Custom 14"/13" brakes w/ Wilwood 4-piston calipers - UMI Panhard Bar - Custom adjustable rear LCAs
hiltsy855 is offline   Reply With Quote
Old 04-18-2012, 11:11 PM   #3
TECH Fanatic
 
Trader Rating: 12
Join Date: Jun 2007
Location: earth
Posts: 1,433
Default

Quote:
Originally Posted by hiltsy855 View Post
Does the posi you're using require friction modifier? Maybe the diff fluid you put in doesn't have any mixed in and you have to add some separately.
its a torsen. no clutch packs
__________________

2000 ws6 - was stock 5.3 pt7675 making 700+rwhp. currently building turbo kit again.... haha
2001 camaro 408, afr 225s, pt88, 4l80e. 880rwhp on 19-20psi 91 pump gas.
got-a-ls1 is offline   Reply With Quote
Old 04-18-2012, 11:11 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Camaro SS Ssteering has a "catch" in it when turning the wheel 97_ek Suspension & Brakes 4 11-19-2014 05:20 AM
ZL1 won’t start issue - NEED HELP nxttruck2002 New LS1 Owners - Newbie Tech 3 07-29-2014 05:33 AM
Wheels hard to spin. drives but whines and pops CS2 Sasuke XD Gears & Axles 5 08-27-2012 12:18 PM
random radio shut off during driving. HossinatorSS Stereo & Electronics 9 09-27-2008 12:30 AM
PCV System ? BoneSS Generation III External Engine 7 05-31-2005 03:49 AM


Tags
9, diff, differential, fluid, install, locker, ls1tech, oil, part, s60, strac, strange, torsen, trac


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details