Loud Noises when I accelerate and turn??? - LS1TECH



Gears & Axles Driveshafts | Rearends | Differentials | Gears | 12 Bolt | 9 Inch | Dana

Loud Noises when I accelerate and turn???

Reply
 
Thread Tools Search this Thread
Old 03-24-2008, 06:26 PM   #1
Launching!
Thread Starter
 
Benny Blanco's Avatar
 
Join Date: Aug 2007
Location: San Jose CA
Posts: 260
Default Loud Noises when I accelerate and turn???

So i noticed this last week and its finally outta control. It started off with a mild clunk and now its really loud I was racing last nite and I did a burn out and it got much worse so when I launched it made a huge clunk but I was able to still drive it home it makes the noise when I speed up from a deadstop and when I make left or right turns I have a BMR torque so I know its not that can anybody trouble shoot this problem for me Thanks fellas......BB
Benny Blanco is offline   Reply With Quote
Old 03-24-2008, 06:38 PM   #2
On The Tree
iTrader: (2)
 
Join Date: Jul 2007
Posts: 185
Default

Sounds like you broke the spider gears in the differential.....
sevenstarsfall is offline   Reply With Quote
Old 03-24-2008, 06:41 PM   #3
TECH Fanatic
iTrader: (6)
 
DarkJuggalo's Avatar
 
Join Date: Sep 2007
Location: Charlotte, NC / Ansonia,CT
Posts: 1,275
Default

does it sound like a loud banging? mine was makin noises like this but banging from a dead stop. was a bad tranny mount
DarkJuggalo is offline   Reply With Quote
Old 03-24-2008, 06:45 PM   #4
On The Tree
iTrader: (2)
 
Join Date: Jul 2007
Posts: 185
Default

He said that it makes it under hard acceleration and turns so it could be a combo of the mount and the gears.

Id check the mount which could cause the banging under acceleration and pull the rear cover to check the gears.
sevenstarsfall is offline   Reply With Quote
Old 03-24-2008, 06:57 PM   #5
Launching!
Thread Starter
 
Benny Blanco's Avatar
 
Join Date: Aug 2007
Location: San Jose CA
Posts: 260
Default

damn and I just did the gasket and fluid change last week...this sucks ..BB
Benny Blanco is offline   Reply With Quote
Old 03-24-2008, 07:10 PM   #6
On The Tree
iTrader: (2)
 
Join Date: Jul 2007
Posts: 185
Default

Yeah, that would suck....let us know what you find
sevenstarsfall is offline   Reply With Quote
Old 03-24-2008, 07:13 PM   #7
Launching!
Thread Starter
 
Benny Blanco's Avatar
 
Join Date: Aug 2007
Location: San Jose CA
Posts: 260
Default

I will!!! good lookn out bro.....be koo....BB
Benny Blanco is offline   Reply With Quote
Old 03-25-2008, 08:59 PM   #8
On The Tree
 
goinfast's Avatar
 
Join Date: Jan 2007
Location: Stokes Bay,Ontario Canada
Posts: 195
Default

i have the same prob no idea whats goin on i just changed my fluid too and it seem to get worse
goinfast is offline   Reply With Quote
Old 03-26-2008, 01:26 AM   #9
Launching!
Thread Starter
 
Benny Blanco's Avatar
 
Join Date: Aug 2007
Location: San Jose CA
Posts: 260
Default

welcome to the club hahahaha This is the second time I changed the gasket and fluid out and its gona happen again this **** isnt cheap man its time to recycle my fluid again....Iam gona get a moser 12 bolt with 373 for 1000 bucks and it only has 200 miles on it **** this 10 bolt bs its time to HOOK UP.
Benny Blanco is offline   Reply With Quote
Old 03-27-2008, 07:27 PM   #10
Launching!
Thread Starter
 
Benny Blanco's Avatar
 
Join Date: Aug 2007
Location: San Jose CA
Posts: 260
Default

totally blown oh well My Moser is coming in a few days woo hoo can you say HOOKED UP.....BB
Benny Blanco is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:36 AM.