Clutch Issue - LS1TECH

Go Back   LS1TECH > Gen 5 Camaro 2010+ Forum > Gen 5 Camaro External Bolt-On Tech
Log In 

Gen 5 Camaro External Bolt-On Tech
Intake, exhaust, appearance mods, general discussion
Sponsored by
Texas Speed & Performance

Clutch Issue

Thread Tools Search this Thread
Old 03-21-2012, 10:36 PM   #1
TECH Fanatic
Midnight00SS's Avatar
Trader Rating: 0
Join Date: Jul 2008
Posts: 1,483
Question Clutch Issue

I have 500 miles on my clutch brand new 2012 SS, just notice after driving for awhile when i press the clutch down and let up, the pedal kinda pulsates or shakes a bit?? is this normal?? evertyhing runs and shifts fine
2012 IBM 1SS/RS M6 Halltech Yellow Jacket CAI, Corsa Sport Catback 4" Tips
Midnight00SS is offline   Reply With Quote
Old 01-26-2013, 08:47 AM   #2
Teching In
Trader Rating: 0
Join Date: Jan 2013
Posts: 0

Take in the shop
98sickspeedblkta is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch problems 02sslvr Manual Transmission 0 06-30-2013 10:16 PM
Clutch Stiffness MeMz Manual Transmission 2 12-18-2012 12:55 AM
Track only clutch break in ss2000 Drag Racing Tech 5 01-22-2011 03:34 PM
LS6 Clutch VS LS1 Clutch Midnight00SS Manual Transmission 9 08-11-2010 11:42 AM
bleeding clutch problem 911ss Manual Transmission 13 04-11-2007 08:40 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -5. The time now is 03:06 PM.