clutch squeaking??? HELP! - LS1TECH



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

clutch squeaking??? HELP!

Reply
 
Thread Tools Search this Thread
Old 05-09-2009, 01:57 PM   #1
On The Tree
Thread Starter
iTrader: (2)
 
jcws6-25's Avatar
 
Join Date: Sep 2008
Location: Hickville LA
Posts: 109
Default clutch squeaking??? HELP!

my clutch is squeaking. when im releasing the clutch in first and i give it like to much throttle i get this squeaking noise/feeling in the clutch. I feel it more than i hear it though.

Any body have same issue or know wats up??
jcws6-25 is offline   Reply With Quote
Old 05-09-2009, 04:33 PM   #2
Teching In
 
Ws6DieseL's Avatar
 
Join Date: Feb 2009
Posts: 23
Default

I have the same problem when I go to pull out for the first time my clutch will squeak/squeal. But it will only do it the first time from a cold start.
Ws6DieseL is offline   Reply With Quote
Old 05-14-2009, 07:24 PM   #3
On The Tree
Thread Starter
iTrader: (2)
 
jcws6-25's Avatar
 
Join Date: Sep 2008
Location: Hickville LA
Posts: 109
Default

ttt.....
jcws6-25 is offline   Reply With Quote
Old 05-14-2009, 10:18 PM   #4
TECH Fanatic
iTrader: (12)
 
slayerized6's Avatar
 
Join Date: Oct 2006
Posts: 1,593
Default

can be the throw out bearing or pilot bearing
slayerized6 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:31 PM.