turn signals & reverse lights dont work - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Log In 
Search


General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions


turn signals & reverse lights dont work

Reply
 
Thread Tools Search this Thread
Old 07-07-2011, 10:46 AM   #1
TECH Enthusiast
 
Mightymike2000ss's Avatar
 
Trader Rating: 3
Join Date: Apr 2008
Location: Home town Clive,IA current town FORT BENNING GEORGIA
Posts: 525
Default turn signals & reverse lights dont work

I'm in need of some help guys im not sure what happened but my turn signal's or reverse lights wont come on at all the markers light up but not turn signal. the hazards work still. if anyone can give me some input i would appreciate it alot.
__________________
2000 CAMARO SS Little turbo street car.....
Mightymike2000ss is offline   Reply With Quote
Old 07-07-2011, 11:44 AM   #2
On The Tree
 
98 White T/A's Avatar
 
Trader Rating: 5
Join Date: Jun 2011
Location: Macomb, Michigan
Posts: 160
Default

Check your fuses before anything.
98 White T/A is offline   Reply With Quote
Old 07-07-2011, 12:40 PM   #3
TECH Enthusiast
 
Mightymike2000ss's Avatar
 
Trader Rating: 3
Join Date: Apr 2008
Location: Home town Clive,IA current town FORT BENNING GEORGIA
Posts: 525
Default

i thought it was a relay if so which one!!!
__________________
2000 CAMARO SS Little turbo street car.....
Mightymike2000ss is offline   Reply With Quote
Old 07-07-2011, 09:34 PM   #4
On The Tree
 
98 White T/A's Avatar
 
Trader Rating: 5
Join Date: Jun 2011
Location: Macomb, Michigan
Posts: 160
Default

Your manual will tell you which fuses are which exactly, im not near my car so i dont have the book next to me to tell you
98 White T/A is offline   Reply With Quote
Old 07-07-2011, 09:54 PM   #5
TECH Fanatic
 
FiredUpZ28's Avatar
 
Trader Rating: 0
Join Date: Jun 2006
Location: Elgin, Il
Posts: 1,289
Default

Bet you have a ground issue somewhere if both reverse and turn signals dont work. Rear turn signals im assuming? Best bet is to find a wiring diagram to see what those circuits share.
__________________
~Ryan~
'01 SS - m6, lid, factory SLP exhaust
'99 T/A - a4, 222/226 cam, 243 heads, working tune
Quote:
Originally Posted by I8UR4RD View Post
You shut your ***** mouth!
FiredUpZ28 is offline   Reply With Quote
Old 07-08-2011, 11:02 AM   #6
Save the manuals!
 
wssix99's Avatar
 
Trader Rating: 5
Join Date: Dec 2007
Location: Chicago, IL
Posts: 7,924
Default

Is this only in the back or all around?
__________________
Black 1999 Firebird Formula WS6; M6

Please DO NOT send PMs for questions that can be answered in the forums!
wssix99 is offline   Reply With Quote
Old 07-08-2011, 11:15 AM   #7
TECH Enthusiast
 
Mightymike2000ss's Avatar
 
Trader Rating: 3
Join Date: Apr 2008
Location: Home town Clive,IA current town FORT BENNING GEORGIA
Posts: 525
Default

its all around the car, i got off the interstate one day and i forgot to flip it off and it just stayed on ever since then its never worked.
__________________
2000 CAMARO SS Little turbo street car.....
Mightymike2000ss is offline   Reply With Quote
Old 07-09-2011, 08:49 AM   #8
Save the manuals!
 
wssix99's Avatar
 
Trader Rating: 5
Join Date: Dec 2007
Location: Chicago, IL
Posts: 7,924
Default

Quote:
Originally Posted by Mightymike2000ss View Post
its all around the car, i got off the interstate one day and i forgot to flip it off and it just stayed on ever since then its never worked.
Best case scenario, you have two separate problems.

If your fuses are good, I'd start by tracing the turn signals. See if you have power at the flasher. If so, it may be a bad flasher. (Your hazards working proves that the DRL module and bulbs/sockets are good.) If no power at the flasher, then you should check the power going in to the turn signal switch and keep going back from there.
__________________
Black 1999 Firebird Formula WS6; M6

Please DO NOT send PMs for questions that can be answered in the forums!
wssix99 is offline   Reply With Quote
Old 07-09-2011, 08:49 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Right turn signal doesn't work gabelsx New LS1 Owners - Newbie Tech 5 05-22-2015 05:10 PM
Weird Turn Signal Issue loyolacub68 Stereo & Electronics 9 06-04-2012 01:23 PM
Left side turn signals not flashing... 1994 TA Jeep_junkie Stereo & Electronics 16 07-27-2010 08:22 PM
1998 Trans AM: Turn Signals, Reverse Lights and TCS are all not working GoodOlBoy0404 Pontiac Firebird 1967-2002 1 03-27-2010 06:32 AM
Condensation in reverse lights and turn signal Hotrodflpd2 General Maintenance & Repairs 21 03-08-2004 10:41 AM


Tags
2000, dont, firebird, fuse, g6, hazards, lights, pontiac, rear, reverse, signal, signals, turn, wont, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 09:24 PM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details