speedometer doesn't keep up with car - LS1TECH

Log In 


General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

speedometer doesn't keep up with car

Reply
 
Thread Tools Search this Thread
Old 05-29-2012, 05:42 PM   #1
TECH Resident
Thread Starter
iTrader: (21)
 
xRelapse13's Avatar
 
Join Date: May 2008
Location: East Brunswick, NJ
Posts: 770
Default speedometer doesn't keep up with car

So I've been having an issue for the last few months where under rapid acceleration or uphill accel (more load) the speedometer wont keep up with the car.

If i do a WOT run, I'll stop near end of 3rd or mid 4th and the speedo will be showing around 35mph or so pending when i actually rolled into it, and then when I press the brakes it will rocket up to a more accurate speed.

Under moderate accel it will lag a bit until I let off the gas a bit and then it will catch up.

I put in a new VSS sensor and that didn't really help anything at all.

Started when I put in a new Built T56. Any ideas?
xRelapse13 is offline   Reply With Quote
Old 05-31-2012, 01:18 PM   #2
TECH Resident
iTrader: (4)
 
White 96LT1's Avatar
 
Join Date: Jun 2006
Location: WYLIE, TEXAS
Posts: 918
Default

instrament cluster, or maybe your wheel speed sensor.
White 96LT1 is offline   Reply With Quote
Old 05-31-2012, 08:33 PM   #3
TECH Resident
Thread Starter
iTrader: (21)
 
xRelapse13's Avatar
 
Join Date: May 2008
Location: East Brunswick, NJ
Posts: 770
Default

anyway to actually check the wheelspeed sensors short of throwing new ones in there?

Also, my gas gauge is messed up a bit also sometimes it will read nothing when the tank is full and then move up as you drive the car. I assumed that was just the fuel sending unit but now it's just starting to sound like overall something wrong with the cluster
xRelapse13 is offline   Reply With Quote
Reply


Tags
car, doesnt, lags, ls1, move, repair, speedometer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:10 AM.