Car bogs when WOT - LS1TECH



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

Car bogs when WOT

Reply
 
Thread Tools Search this Thread
Old 06-21-2012, 12:36 PM   #1
Staging Lane
Thread Starter
 
Join Date: Sep 2011
Location: Rapids City, Illinois
Posts: 69
Default Car bogs when WOT

When driving my car in every gear besides first at around 2500-3000 rpms my its bogs for a second then takes off like a bat out of hell. i have a little bit of a thought of what it is but i want your guys take on whats it could be.

Thanks!
thegerberbaby is offline   Reply With Quote
Old 06-25-2012, 12:15 AM   #2
Staging Lane
 
nealws6's Avatar
 
Join Date: Jan 2006
Location: Anaheim, CA
Posts: 50
Default

check fuel pressure should be about 58psi, Might want to change your fuel filter.
nealws6 is offline   Reply With Quote
Old 06-25-2012, 01:13 PM   #3
Registered User
 
Join Date: Jun 2012
Location: Louisiana
Posts: 2
Default

I had a ford ranger that had those symtoms and it was the MAF
sp3edr4cer is offline   Reply With Quote
Old 06-25-2012, 01:46 PM   #4
On The Tree
 
Z28RS's Avatar
 
Join Date: Apr 2012
Posts: 185
Default

I'm sorry to hear that your car's having this problem.

What size gears do you have?

And did you notice this symptom become manifest after making any modifications?
Z28RS is offline   Reply With Quote
Old 06-25-2012, 06:54 PM   #5
Launching!
 
BadBirdie's Avatar
 
Join Date: Feb 2012
Location: IL
Posts: 281
Default

replace fuel filter if you havent in awhile and never hurts to clean maf unless you use anything other than maf cleaner.
BadBirdie is offline   Reply With Quote
Old 06-25-2012, 07:08 PM   #6
TECH Enthusiast
iTrader: (1)
 
Join Date: Apr 2012
Location: West TN
Posts: 632
Default

Fuel pressure at WOT should be 37 psi, NOT! 58.
DisasterFormula is offline   Reply With Quote
Old 06-25-2012, 07:48 PM   #7
On The Tree
iTrader: (3)
 
puddingmmmmmmmm's Avatar
 
Join Date: Jul 2011
Location: Bel Air, MD
Posts: 182
Default

Quote:
Originally Posted by DisasterFormula View Post
Fuel pressure at WOT should be 37 psi, NOT! 58.
Yeah on a lt1...a ls1 should be around 58psi at all times.
puddingmmmmmmmm is offline   Reply With Quote
Old 06-26-2012, 12:04 PM   #8
TECH Enthusiast
iTrader: (1)
 
Join Date: Apr 2012
Location: West TN
Posts: 632
Default

Quote:
Originally Posted by puddingmmmmmmmm View Post
Yeah on a lt1...a ls1 should be around 58psi at all times.
Y'don't say? Learn something new everyday.
DisasterFormula is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Plugged EVAP Choking Engine Down blackws620 Generation III External Engine 4 10-05-2014 07:35 AM
My Car Bogs At Takeoff camarolt195 LT1-LT4 Modifications 10 09-10-2007 11:45 AM
Bogging MeatL0af LT1-LT4 Modifications 9 09-28-2006 02:26 PM
bogging issue hawk232 LT1-LT4 Modifications 5 07-18-2006 03:59 AM
bogs at the begining of second gear 98TwoToneSS New LS1 Owners - Newbie Tech 18 02-18-2006 08:15 PM


Tags
1995, 2500, 3000, 351w, bad, bog, boggs, bogs, car, durig, firebird, formula, ls, ls1tech, maf, motor, rpm, shift, wot

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:40 AM.