Help me out, replaced steering wheel, now the horn buttons don't work. - LS1TECH



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

Help me out, replaced steering wheel, now the horn buttons don't work.

Reply
 
Thread Tools Search this Thread
Old 02-27-2017, 10:15 AM   #1
UNDER PRESSURE MOD
Thread Starter
iTrader: (19)
 
The Alchemist's Avatar
 
Join Date: Nov 2001
Location: Doylestown PA
Posts: 10,710
Default Help me out, replaced steering wheel, now the horn buttons don't work.

Ok, so over the weekend, I replaced my steering wheel with another factory wheel. Now the horn buttons don't work.

When I lock/unlock the car the horn works, so it's not a horn problem. It has to be the steering wheel buttons.

So my next step is to remove the airbag, and change over the contacts from the original wheel to see if that fixes it.

Are there any diagrams of how the the horn buttons work? I'm not the greatest when it comes to electrical.
The Alchemist is offline   Reply With Quote
Old 02-27-2017, 10:45 AM   #2
TECH Apprentice
 
Join Date: Apr 2011
Posts: 329
Default

http://www.corvetteforum.com/forums/...stion-wire.jpg

That thing goes in this thing (cam cancel)

http://www.steeringcolumnservices.co...ges/horn02.jpg

and when you press your horn button down, it makes contact thus producing a horn sound.


I'll upload the service manual page in a bit.

Oops, can't upload. Sorry. Try page 2-62 in the 2000 service manual.

Last edited by ShovelMan; 02-27-2017 at 11:00 AM. Reason: exceeds 5MB
ShovelMan is offline   Reply With Quote
Old 02-27-2017, 01:35 PM   #3
UNDER PRESSURE MOD
Thread Starter
iTrader: (19)
 
The Alchemist's Avatar
 
Join Date: Nov 2001
Location: Doylestown PA
Posts: 10,710
Default

Ok. Let me try to replace the contacts and see if that fixes it.
The Alchemist is offline   Reply With Quote
Old 02-27-2017, 03:19 PM   #4
UNDER PRESSURE MOD
Thread Starter
iTrader: (19)
 
The Alchemist's Avatar
 
Join Date: Nov 2001
Location: Doylestown PA
Posts: 10,710
Default

I figured it out. It was a combination of issues. When they finished the wheel, they had sprayed it with a clear, and it coated the contacts, and then the spring retainer thing wasn't being held in contact either.

Thanks for the help guys.
The Alchemist is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Two new electrical problems CTSvOH Cadillac CTS-V 2004-2007 (Gen I) 16 03-10-2017 07:10 PM
Is my clock spring or contact ring bad? Rabid Dog General Maintenance & Repairs 6 06-02-2009 04:05 PM
LT1 Horn Issue BushyTea LT1-LT4 Modifications 3 12-23-2007 04:27 PM
Where the hell is my horn relay? 1Last69 Stereo & Electronics 6 08-16-2006 07:57 AM
Trans Am Horn doesn't work Xtnct00WS6 General Maintenance & Repairs 12 10-28-2005 06:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:51 AM.