z28 camaro - LS1TECH



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

z28 camaro

Reply
 
Thread Tools Search this Thread
Old 03-15-2017, 05:05 PM   #1
Registered User
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default z28 camaro

I have a 95 z28 camaro and when the motor is cold and i go to start the car the cooling fans come on at the same time service engine comes on after like 5 minutes it will go away and i am able to drive the car with out it sputtering out
Andrea Rivera is offline   Reply With Quote
Old 03-15-2017, 05:46 PM   #2
Teching In
 
Join Date: Sep 2016
Location: Drexel Hill
Posts: 40
Default

what does your gauge read on your dash for coolant temp when you start it? would a bad coolant temp sensor do this?
Boosted53F is offline   Reply With Quote
Old 03-16-2017, 08:52 AM   #3
Registered User
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default

The sensor on the dash for the coolant comes and goes but i dont know if that will make the service engine light come on and last night installed two electric cutouts and the car just wants to o er heat someone help
Andrea Rivera is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:48 AM.