Exhaust leak cause bad gas mileage? - LS1TECH

Log In 


General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

Exhaust leak cause bad gas mileage?

Reply
 
Thread Tools Search this Thread
Old 02-20-2006, 04:07 AM   #1
TECH Fanatic
Thread Starter
iTrader: (5)
 
Justin00SS's Avatar
 
Join Date: Feb 2006
Location: Mobile, AL
Posts: 1,675
Default Exhaust leak cause bad gas mileage? *Update 2*

My car is stock enternally. Its hypertech tuned, magnaflow exhaust, 160* stat, granatelli maf, and whisper lid.

I'm not really a lead foot but my gas mileage sucks. Almost to the point that I'm gonna look for a leak.

I went over a speedbump to hard and I have a minor exhaust leak. I can barely hear it but its there and I think thats causing the check engine light. Wouldn't it cause a CEL if it was infront of the o2 sensor? Would that cause uncharacteristically bad gas mileage?

I normally shift around 1900 to 2500rpms because the speedlimit on base isn't over 30mph anywhere.

I only got like 50miles to a half tank.

Last edited by Justin00SS; 02-24-2006 at 03:56 AM.
Justin00SS is offline   Reply With Quote
Old 02-20-2006, 11:10 AM   #2
11 Second Club
iTrader: (1)
 
rule 7 ss's Avatar
 
Join Date: Oct 2005
Location: Honolulu, Hawaii
Posts: 96
Default

check for fuel leak, hit up dansredz28 on phfba........ he's usually willing to lend a hand when his wife is working.

I get 11-14 mpg with an a4, If i'm playing with a heavy foot, goes down to 9mpg
rule 7 ss is offline   Reply With Quote
Old 02-20-2006, 09:28 PM   #3
TECH Fanatic
Thread Starter
iTrader: (5)
 
Justin00SS's Avatar
 
Join Date: Feb 2006
Location: Mobile, AL
Posts: 1,675
Default

fuel leak for real? I guess that would make sense.
Justin00SS is offline   Reply With Quote
Old 02-20-2006, 10:18 PM   #4
TECH Resident
 
flyin red TA's Avatar
 
Join Date: Nov 2001
Location: Barbaria
Posts: 943
Default

50 to a half tank is insane if you don't have a fuel leak. I usually hit 50 miles before I even go through the first 1/4 tank.

An exhaust leak can screw up gas mileage, but it has to be close enough for the O2s to be catching outside air. The O2s then see the mixture as too lean, and the computer compensates by adding fuel. The granatelli MAF probably isn't helping either.
flyin red TA is offline   Reply With Quote
Old 02-21-2006, 11:49 AM   #5
TECH Fanatic
Thread Starter
iTrader: (5)
 
Justin00SS's Avatar
 
Join Date: Feb 2006
Location: Mobile, AL
Posts: 1,675
Default

Lose the granatelli maf? Do those even do anything? I have the stock one. The original owner put the aftermarket maf on it.
Justin00SS is offline   Reply With Quote
Old 02-21-2006, 02:47 PM   #6
Launching!
iTrader: (4)
 
01black's Avatar
 
Join Date: Mar 2005
Location: orange*county, ca.
Posts: 289
Default

I have numerous exh leaks and my car still gets like 50 outta a 1/4 tank......
01black is offline   Reply With Quote
Old 02-21-2006, 02:56 PM   #7
TECH Resident
 
flyin red TA's Avatar
 
Join Date: Nov 2001
Location: Barbaria
Posts: 943
Default

Quote:
Originally Posted by Justin00SS
Lose the granatelli maf? Do those even do anything? I have the stock one. The original owner put the aftermarket maf on it.
Go back to the stock one. Aftermarket MAFs are hit or miss, and the stocker has been proven to do fine until 500hp.

Still, 50 miles out of a half tank is ridiculous. That fuel has to be going somewhere and it isn't exactly safe to drive the car if it's leaking.
flyin red TA is offline   Reply With Quote
Old 02-21-2006, 03:33 PM   #8
TECH Fanatic
Thread Starter
iTrader: (5)
 
Justin00SS's Avatar
 
Join Date: Feb 2006
Location: Mobile, AL
Posts: 1,675
Default

I think I may have a clogged injector. I took the car to an exhaust shop today and the only leaks they could find are near the muffler where the magnaflow slides onto the pipe. Not anywhere near and o2 sensor.

I scheduled an appointment for tommorow with an auto repair place to get the codes the computer is throwing out.

I can hear a slight miss in the exhaust and when I'm buy the engine. Its not causing the engine to vibrate to bad but it is a little shaky.

If I get the codes then can someone on here tell me what they mean? I'd like to save myself some money and fix it myself. If its just an injector then I know I can do that.
Justin00SS is offline   Reply With Quote
Old 02-23-2006, 04:32 AM   #9
TECH Fanatic
Thread Starter
iTrader: (5)
 
Justin00SS's Avatar
 
Join Date: Feb 2006
Location: Mobile, AL
Posts: 1,675
Default

I went to checkers and rant he diagnostic myself and this is what I got.

The trouble code is it throwing for the SES light is : P0420

Which means, "Catalyst system Efficiency Below Threshold (Bank 1)

What does this mean? I have to buy new cats? New o2 sensor?

What if I seafoamed my car could that burn some of the stuff out of the cats?

Lemme know what you guys think please.

I replaced the granatelli maf with the stock one and got back ALOT of gas mileage. I mean ALOT!
Justin00SS is offline   Reply With Quote
Old 02-24-2006, 03:56 AM   #10
TECH Fanatic
Thread Starter
iTrader: (5)
 
Justin00SS's Avatar
 
Join Date: Feb 2006
Location: Mobile, AL
Posts: 1,675
Default

Well. Here is what happened today. I've gotten my gas mileage back since replacing the gran maf with the stock maf. SES light still on. I start my car up today after it sitting at work for a couple of hours and I had to give it some gas to keep it above 250rpms. I was like WTF! THIS PIECE OF ****!

It started sputtering, popping, shimmying I am the whole time like OMG MY ******* CAR IS FUCKED! WTF!

Then she roared back to life. I'm just sitting there like uhhhhh.

Purring like a ******* lion. The SES light went off. Its not on anymore. She idles so much more smoothly. And the light misfire that I could hear in the exhaust. Not there anymore. Just a nice rumble of the LS1.

Runs soo much smoother and better now. I dunno wtf but it seems to be fixed.
Justin00SS is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Poor MPG's? Bullitt117 LT1-LT4 Modifications 3 12-03-2012 09:10 AM
what would cause o2 sensors to foul out? jt_2002_ta General Maintenance & Repairs 13 04-25-2012 04:47 PM
HORRIBLE gas mileage. 10-15 highway, 5-8 in town. D: KyleW707 LT1-LT4 Modifications 34 10-06-2011 09:01 PM
No muffler... gas mileage? sandsk8erz400 New LS1 Owners - Newbie Tech 16 02-11-2009 12:22 AM
Can an exhaust leak cause pinging? Hemi Killer Generation III Internal Engine 7 01-18-2008 03:14 AM


Tags
40, affect, alot, bad, burn, car, exhaust, gas, leak, leaks, lower, magnaflow, mileage, muffler, xterra

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:28 AM.