Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

Weird A/C question....HELP! its 98* outside!

Reply
 
Thread Tools Search this Thread
Old 10-05-2006, 12:40 PM   #1
Launching!
 
s10blaza's Avatar
 
Trader Rating: 2
Join Date: Jul 2006
Location: El Paso, TX
Posts: 265
Default Weird A/C question....HELP! its 98* outside!

OK, when I bought my T/A the air conditioning would blow slightly colder than ambient temps and at night it would be very cold. Recently the past few days it just wouldn't blow cold at all. I check the pressure with the a/c on and compressor kicked on and it was about 80psi. YIKES! I know with the pressure that high the refrigerant won't condense so it can get cold

If I leave the car running in hopes of it cooling the compressor will not cycle on and off

So I let some of the pressure out and the compressor just shuts off before it gets to the safe level. WTF so I put my dad's machine on and evacuate it completely. I go to pull a vacuum on it and notice the schrader valve on the accumulator is leaking. So I replace that and it kept 24 inches of vacuum for over half an hour. That rules a leak out of the question.

I forgot to mention I also took out the orifice tube to see if it was clogged and it was clean with very very little debris

I go to put a can of refrigerant in and about 3/4 of the bottle it stops taking it in. I remove the bottle and check pressure and its up to like 80 psi AGAIN

The belt isn't broken because I see the clutch engaging and I know its not the compressor because I can feel the car bog down slightly and increase idle again when i turn the button to max a/c.

Isn't a the secondary fan supposed to come on when I turn on the a/c? because I notice that one of them is only slightly spinning (which I guess is from the turbulence the other one is causing) then when I jump the two of the three terminals on the pressure switch it kicks on but the compressor shuts off and the SES light comes on.

I'm ALL out of ideas here

Last edited by s10blaza; 10-05-2006 at 12:50 PM..
s10blaza is offline   Reply With Quote
Old 10-05-2006, 12:45 PM   #2
TECH Addict
 
Trader Rating: 0
Join Date: Sep 2006
Location: Massachusetts
Posts: 2,599
Default

Quote:
Originally Posted by s10blaza
I know its not the compressor because I can feel the car bog down slightly and increase idle again when i turn the button to max a/c.
I am no AC expert, but that doesn't seem like a very thorough conclusion to me.


Good luck
__________________
2009 Pontiac G8 GT
dragonrage is offline   Reply With Quote
Old 10-05-2006, 12:49 PM   #3
Launching!
 
s10blaza's Avatar
 
Trader Rating: 2
Join Date: Jul 2006
Location: El Paso, TX
Posts: 265
Default

What I meant is that it doesn't seem like there is anything wrong with the compressor internally. But then again I'm no ASE certified mechanic. Thanks for pointing that out
s10blaza is offline   Reply With Quote
Old 10-05-2006, 01:12 PM   #4
TECH Resident
 
A-Dub's Avatar
 
Trader Rating: 6
Join Date: Nov 2004
Location: Houston, TX
Posts: 833
Default

When the compressor was still working, did you measure the high side pressure?

When I refilled my car, i did it with the engine running and the compressor set to max. I filled through the manifold gauge and the pressure would definitely get up to 80 or higher as I filled it, but then would come back down as the system accepted the refrigerant.
__________________
2009 G8 GT
1970 Chevelle SS 396
1969 C10 SWB LY6/T56
A-Dub is offline   Reply With Quote
Old 10-06-2006, 03:10 AM   #5
Launching!
 
s10blaza's Avatar
 
Trader Rating: 2
Join Date: Jul 2006
Location: El Paso, TX
Posts: 265
Default

Yeah the high side is also high, the compressor still works it just doesn't kick off like it should and i believe the fan isnt turning on. Could it be the switch on the high pressure line next to the dryer?
s10blaza is offline   Reply With Quote
Old 10-06-2006, 03:10 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
ac, compressor, g8, pontiac, psi, supposed


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 06:41 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details