Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 11-05-2002, 04:01 AM   #1
TECH Apprentice
Garage is empty, add now
 
Trader Rating: 0
Join Date: Dec 2001
Location: CA
Posts: 352
Default What are symptoms of a broken oil pressure sender?

I've been noticing that my oil pressure is reading lower and lower. It's gradual, like over a couple months. Now it's at 15psi with hot oil at idle. And goes to about 33psi at 2000rpms and 36psi or so at 4000rpms. I don't see any metal shavings or flakes in the oil, so I don't think it's the bearings. I don't hear any knocking either. Last things I can think of are bad lifters or bad oil pressure sender. I pulled my oil pressure sender out and looked at it, it looked nice and clean. I was hoping that something was clogged in there that was messing up the readings, but no dice.

Is it still possible that it will just read low or would a broken oil pressure sender read 0? I've been thinking back to all the times I pulled the intake manifold, trying to remember if the oil pressure going down is related, but not sure.
akw408 is offline   Reply With Quote
Old 11-05-2002, 07:04 AM   #2
11 Second Club
Garage is empty, add now
 
StevieZ's Avatar
 
Trader Rating: 3
Join Date: Mar 2002
Location: Montreal
Posts: 1,794
Default Re: What are symptoms of a broken oil pressure sender?

Sender usually works or doesn't work. My old sender, even though inacurate, and reading about 10psi lower , still registered 38 psi at hot idle. Sorry to tell you this but progressively less pressure sounds like bearings and you wouldn't necessarily see anything in the oil or in the filter such as "shavings or flakes"
__________________
1998 Z28 M6/LS6 383 CID Lunati stroker/PP Stage II+heads/ Comp Cams 242/242 .610/.610 113+4* lsa/ARP mains and head studs/ Yella Terra rockers/ LS6 intake/Kooks stainless1 7/8" headers/ 3"X3"ORP/ QTEC cutout/ LS6 PCV/Rollmaster double roller T-chain/Katech oil pump/Spec 3+ /3.73-12 bolt Strange/ASP pulley/ Magnaflow cat back/315 Nittos/K&N + MTI lid/160 Tstat/SLP rad .Other stuff.....
Old heads and cam: 11:47@123.5mph (4400rpm launch)
StevieZ is offline   Reply With Quote
Old 11-05-2002, 04:18 PM   #3
TECH Apprentice
Garage is empty, add now
 
Trader Rating: 0
Join Date: Dec 2001
Location: CA
Posts: 352
Default Re: What are symptoms of a broken oil pressure sender?

</font><blockquote><font size="1" face="Verdana, Helvetica, sans-serif">quote:</font><hr /><font size="2" face="Verdana, Helvetica, sans-serif">Originally posted by StevieZ:
<strong>Sender usually works or doesn't work. My old sender, even though inacurate, and reading about 10psi lower , still registered 38 psi at hot idle. Sorry to tell you this but progressively less pressure sounds like bearings and you wouldn't necessarily see anything in the oil or in the filter such as "shavings or flakes"</strong></font><hr /></blockquote><font size="2" face="Verdana, Helvetica, sans-serif">That doesn't sound good. But usually you will see bearing material in the oil, shows up as golden speckles, do you not? And wouldn't bad bearings have even more symptoms than just low oil pressure? I think I will check out the lifters and then hook up a mechanical oil pressure gauge.
akw408 is offline   Reply With Quote
Old 11-06-2002, 02:52 PM   #4
LS1Tech Co-Founder
Garage is empty, add now
 
Pro Stock John's Avatar
 
Trader Rating: 34
Join Date: Nov 2001
Location: Chicago, IL
Posts: 41,610
Default Re: What are symptoms of a broken oil pressure sender?

Email Patman and get the oil tested.

The oil sender is cheap if the oil test comes back okay I would change the sender ($25).
__________________
2010 Camaro | 11.90@112 1.60 | Stock Internal H/C soon
2000 Camaro | 10.00@134 1.38 | 348, 150 shot sold
1998 Formula | 9.40@145 1.35 | 348, 88mm sold
1998 Camaro | 12.1@118 | 150, stock internal sold

LSX RECORD LIST
Pro Stock John is offline   Reply With Quote
Old 11-06-2002, 06:12 PM   #5
TECH Apprentice
Garage is empty, add now
 
Trader Rating: 0
Join Date: Dec 2001
Location: CA
Posts: 352
Default Re: What are symptoms of a broken oil pressure sender?

</font><blockquote><font size="1" face="Verdana, Helvetica, sans-serif">quote:</font><hr /><font size="2" face="Verdana, Helvetica, sans-serif">Originally posted by Pro Stock John:
<strong>Email Patman and get the oil tested.

The oil sender is cheap if the oil test comes back okay I would change the sender ($25).</strong></font><hr /></blockquote><font size="2" face="Verdana, Helvetica, sans-serif">How do I get in contact with Patman? How much is the oil test?
akw408 is offline   Reply With Quote
Old 11-06-2002, 06:45 PM   #6
11 Second Club
Garage is empty, add now
 
StevieZ's Avatar
 
Trader Rating: 3
Join Date: Mar 2002
Location: Montreal
Posts: 1,794
Default Re: What are symptoms of a broken oil pressure sender?

Send a Check for $25 US funds to Terry Dyson at the address below. Include $2.06 for Texas sales tax if you reside in Texas. He will send you a kit that includes,sample bottle,data sheet,and US postage paid mailer. You send the used sample directly to the contract lab in Dallas. He will email the results after he interprets them for you. He will answer your questions so you know what it all means.
Terry Dyson
Dyson Analysis
3679 CR 2184
Greenville, TX 75402
903 883 4661
__________________
1998 Z28 M6/LS6 383 CID Lunati stroker/PP Stage II+heads/ Comp Cams 242/242 .610/.610 113+4* lsa/ARP mains and head studs/ Yella Terra rockers/ LS6 intake/Kooks stainless1 7/8" headers/ 3"X3"ORP/ QTEC cutout/ LS6 PCV/Rollmaster double roller T-chain/Katech oil pump/Spec 3+ /3.73-12 bolt Strange/ASP pulley/ Magnaflow cat back/315 Nittos/K&N + MTI lid/160 Tstat/SLP rad .Other stuff.....
Old heads and cam: 11:47@123.5mph (4400rpm launch)
StevieZ is offline   Reply With Quote
Old 11-06-2002, 06:45 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
bad, broken, filter, gauge, low, oil, pressure, pump, sender, sensor, signs, switch, symptoms, test, testing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil priming question ws6ed Generation III Internal Engine 13 09-16-2013 11:09 AM
Oil pressure lower than normal after some hard runs.. Suggestions? 2000SS1979 Generation III Internal Engine 2 07-30-2013 12:48 PM
Shop Recommendation Near Folsom CA Aerobatix Generation III Internal Engine 5 11-11-2012 12:32 PM
Melling Oil Pump ... Low Pressure GTO1_OHIO Generation IV Internal Engine 19 09-06-2012 01:08 AM
Need help : low oil pressure but no symptoms! Give me things to check akw408 Generation III Internal Engine 5 11-17-2002 08:37 PM



All times are GMT -5. The time now is 10:48 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details