engine died - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search


General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions


engine died

Reply
 
Thread Tools Search this Thread
Old 04-11-2007, 02:08 PM   #1
Teching In
 
Trader Rating: 0
Join Date: Sep 2006
Posts: 8
Default engine died

Hi all,

I have a 1998 Silverado which I replaced the fuel pump on about 12000 miles ago. I recently filled up with gas and 10 minutes later it shuddered slightly and died, engine will not fire. Fuel filter seemed fine but was replaced. Pump pushed fuel through the line when the filter was disconnected. The priming noise the pump makes sounds a little odd, hard to explain but not quite right. Not quite as consistant as normal. I was wondering if anyone had any ideas?

Thanks

Joe-
jlsjoe is offline   Reply With Quote
Old 04-11-2007, 02:08 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 09:04 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details