Need question answered ASAP PLEASE!!!!! - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search


General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions


Need question answered ASAP PLEASE!!!!!

Reply
 
Thread Tools Search this Thread
Old 07-29-2007, 08:12 PM   #1
12 Second Club
 
Josh Nickelsen's Avatar
 
Trader Rating: 9
Join Date: Dec 2006
Posts: 193
Default Need question answered ASAP PLEASE!!!!!

I have been chasing what I thought was a pulley squeak. I have taken off all pulley's and regreased them and I also have put on a new alternator as it was squeaking a little bit. The belt on the car is about 2-3 months old. Tonight I tried spraying a very little bit of liqiud wrench on the grove side of the belt and the squeak stopped immediatelu but came back about five seconds later. Is there any type of trick to get the belt squeal to stop or should I buy a new belt?
Josh Nickelsen is offline   Reply With Quote
Old 07-29-2007, 08:29 PM   #2
TECH Fanatic
 
Trader Rating: 6
Join Date: Nov 2001
Location: NV
Posts: 1,224
Default

You're not suppose to grease the pulley's. They have sealed bearings. When they go bad you have to replace the whole unit, or have new bearings put in. It's easier to just change the whole thing. Spraying Liquid wrench or anything on the belts or pullies is not a good idea. You shouldn't "lube" anythng that has to do with the belts or pullies. I always hose my engine bay down with water, with the engine running. Depending on the grease you used, it's probably going to be a pain to clean up.

I'd try and wash down all the pullies real good with dish soap/water and replace the belt. Usually the idler pullies go bad. I've used them from Autozone, but never would again.
WhiteRhino is offline   Reply With Quote
Old 07-29-2007, 09:46 PM   #3
12 Second Club
 
Josh Nickelsen's Avatar
 
Trader Rating: 9
Join Date: Dec 2006
Posts: 193
Default

I have seen many people on here that have greased bearings and have had no problem. There isn't any grease at all on any of the pulley. This sound was here before I ever greased anything. Like I said in my first post, I put a very little bit of spray on the belt as I know it is not good for it. I only did it once and the squeal stopped right away. Also the squeal seems to be coming from the alternator pulley and the alternator is new. It has to be the belt if it stops squealing when I spray it. I am going to go and get a new belt from the dealer tomorrow and see what that does. If that doesn't cure it I am going to get a new alternator bracket.
Josh Nickelsen is offline   Reply With Quote
Old 07-29-2007, 09:46 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details