LS1 to LS6 Valley cover swap question - LS1TECH



Generation III External Engine LS1 | LS6 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories
Sponsored by:
Sponsored by:

LS1 to LS6 Valley cover swap question

Reply
 
Thread Tools Search this Thread
Old 03-12-2017, 04:59 PM   #1
Staging Lane
Thread Starter
 
RedTA02's Avatar
 
Join Date: Dec 2006
Location: Destin, FL
Posts: 69
Default LS1 to LS6 Valley cover swap question

I just did the swap. The instructions on LS1Howto.com say to reuse the stock pcv valve but from what I can find on the web, it seems like no one or the stock ls6 don't use one. Is it necessary?
RedTA02 is offline   Reply With Quote
Old 03-12-2017, 10:44 PM   #2
Teching In
 
Join Date: Feb 2017
Location: Leola PA
Posts: 34
Default

There have been two ls6 valley covers. The early one used an external PCV valve and the later ones don't because they have a built in orifice. If you bought yours new recently you probably have the later style. To tell, blow into the hose connected to the tube on the front of the cover. If you feel a restriction to flow, you have the new one and no valve is needed.
JimsNovaLS is offline   Reply With Quote
Old 03-13-2017, 09:39 AM   #3
Staging Lane
Thread Starter
 
RedTA02's Avatar
 
Join Date: Dec 2006
Location: Destin, FL
Posts: 69
Default

Awesome, thanks man! I ordered the kit last week from Improvedracing.com and im pretty sure its the new style.
RedTA02 is offline   Reply With Quote
Old 03-13-2017, 12:48 PM   #4
On The Tree
iTrader: (8)
 
Join Date: Sep 2006
Location: Bay Minette, AL
Posts: 134
Default

I did this swap on my '01 Z28 a few years back with the new style cover. It didn't take care of the oil in the intake problem for me. Recently bought a Mighty Mouse catch can and will see if that stops it.
TimE is offline   Reply With Quote
Old 03-13-2017, 01:34 PM   #5
TECH Enthusiast
iTrader: (6)
 
BREWS02WS6's Avatar
 
Join Date: Mar 2005
Location: Kansas City, MO
Posts: 694
Default

Same boat as Tim. Got my MM can last week but haven't installed. And I did not use the factory valve like it says to on ls1howto. I don't think that would have solved it, either.
BREWS02WS6 is online now   Reply With Quote
Old 03-13-2017, 08:34 PM   #6
Teching In
 
Join Date: Feb 2017
Location: Leola PA
Posts: 34
Default

I put an oil separator on from the initial build with the ls6 cover and have no oil control problems. Installing one should help you guys out.
JimsNovaLS is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cam advise for stock lq4 LS1 pwrd NOVA Generation III Internal Engine 14 01-05-2017 12:12 AM
first gen stock radiator with ls1 swap? 68topls Conversions & Hybrids 6 05-08-2010 06:42 PM
Head swap, cleaning block surface? 98-LS1 Generation III Internal Engine 18 10-23-2008 02:26 PM
LS1 Stock flywheel.. WS6TransAm Manual Transmission 10 02-14-2005 07:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:22 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send