High oil pressure??? - LS1TECH

Log In 


Generation III Internal Engine 1997-2006 LS1 | LS6
Sponsored by:
Sponsored by:

High oil pressure???

Reply
 
Thread Tools Search this Thread
Old 05-05-2012, 12:16 AM   #1
TECH Resident
Thread Starter
iTrader: (20)
 
Join Date: Dec 2006
Location: New Port Richey, FL
Posts: 879
Default High oil pressure???

Garage Queen started making what sounds like a stuck lifter noise... but on cold starts oil pressure is like 65-80 psi, then warms up and might go down to like 50ish but on WOT goes back up to 70+psi. Anyone have this issue? Do I have a bad sensor and a stuck lifter or something more/less?

Thanks in advance
FU_I_AM_UltraZ is offline   Reply With Quote
Old 05-05-2012, 01:02 AM   #2
TECH Addict
 
mark21742's Avatar
 
Join Date: Sep 2009
Location: PA/MD
Posts: 2,482
Default

Are you going by the stock gauge, or FI you have a mechanical gauge hooked to it? If just the stock one I'd hookup a mechanical one and see what it is reading. What oil, weight, and filter are you running, and how oil are they?
mark21742 is offline   Reply With Quote
Old 05-05-2012, 12:25 PM   #3
Staging Lane
iTrader: (1)
 
Tubba's Avatar
 
Join Date: Dec 2011
Location: The Cuttz, Ca
Posts: 63
Default

I have the same problem, prob just a bad stock gauge, like mark said Imma hook up a mechanical gauge and then go from there
Tubba is offline   Reply With Quote
Old 05-05-2012, 03:07 PM   #4
TECH Resident
Thread Starter
iTrader: (20)
 
Join Date: Dec 2006
Location: New Port Richey, FL
Posts: 879
Default

Quote:
Originally Posted by mark21742 View Post
Are you going by the stock gauge, or FI you have a mechanical gauge hooked to it? If just the stock one I'd hookup a mechanical one and see what it is reading. What oil, weight, and filter are you running, and how oil are they?
Car has just about always had royal purple 5w30, b4 that since car was new had mobile 1 5w30 but car sat due to being active duty Marine and setting for months without start so... didn't know if anyone else has have the same problems from sitting... always use a delco oil filter since it's the only design that fits my filter cup wrench with my long tubes...
FU_I_AM_UltraZ is offline   Reply With Quote
Reply


Tags
129, 80, high, higher, lifter, ls1ech, noise, oil, pressire, pressure, presure, psi, purple, royal, warmed

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:13 AM.