Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Generation III Internal Engine
Sign in using an external account
Register Forgot Password?
Search

Generation III Internal Engine
1997-2006 LS1 | LS6
Sponsored by
Texas Speed & Performance

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 05-23-2012, 01:38 PM   #1
Launching!
Garage is empty, add now
 
Trader Rating: 6
Join Date: Sep 2011
Location: Florida
Posts: 224
Default 98 z28 low oil pressure?

what is the normal oil pressure for a 98 z28 with about 130k miles?
im looking at buying one.
the car runs great, but the gauge never touches 40 after it warms up.
even at 4k rpms.
on cold start it sits right at 42, driving in 6th gear at 1500 rpms its sitting around 30psi
is this normal?
i got a good deal on a 6 speed z28.
runs good, full exhaust, will need a clutch soon but shifts fine, for 2200
the interior is long passed gone.
the leather seats arnt bad, but the headliner is falling down, and the dash is missing pieces.
i havent got it yet but thinking seriously about it.
think its worth it?
the oil pressure thing is kinda bothering me.
the paint has clear coat cancer like a ****
whoever put the factory lip kit on it screwed it in with sheetrock screws
basically the car looks like crap.
but when i stomped it, and hit second gear it totally broke loose.
i had to let off it or i woulda been all over the highway.
all feedback is appreciated.
thanks.
__________________
1998 t/a- just another "cam only" iron block with a stalled th400 and a 8.8
Cooldude5231 is offline   Reply With Quote
Old 05-23-2012, 02:25 PM   #2
TECH Addict
Garage is empty, add now
 
mark21742's Avatar
 
Trader Rating: 0
Join Date: Sep 2009
Location: PA/MD
Posts: 2,473
Default

Oil pressure sounds a little on the low side, so if you get it you might want to think about putting an oil pump in.....and while at it, you might as well slide a cam in too
mark21742 is offline   Reply With Quote
Old 05-23-2012, 02:27 PM   #3
Launching!
Garage is empty, add now
 
Trader Rating: 6
Join Date: Sep 2011
Location: Florida
Posts: 224
Default

would a oil pump off a lq4 work on it?
i have an extra one lying around that held good oil pressure....
__________________
1998 t/a- just another "cam only" iron block with a stalled th400 and a 8.8
Cooldude5231 is offline   Reply With Quote
Old 05-23-2012, 03:00 PM   #4
TECH Addict
Garage is empty, add now
 
mark21742's Avatar
 
Trader Rating: 0
Join Date: Sep 2009
Location: PA/MD
Posts: 2,473
Default

Should bolt right up....the 98 pumps were known to be a little weaker and not last as long as the newer year pumps, but if you'd like, you can verify your oil pressure with a mechanical gauge first to be sure it isn't just a last gauge
mark21742 is offline   Reply With Quote
Old 05-23-2012, 07:50 PM   #5
TECH Addict
Garage is empty, add now
 
mjs1012's Avatar
 
Trader Rating: 31
Join Date: Mar 2011
Location: Milford, CT
Posts: 2,052
Default

i just put a new pump in an engine, i believe its a melling m295, which is a stock replacement. holds good psi and was only like $65 bucks. i personally wouldnt use a used oil pump but its not my car...
__________________
98 z28 A4.
mjs1012 is offline   Reply With Quote
Old 05-24-2012, 11:30 AM   #6
TECH Enthusiast
Garage is empty, add now
 
karpetcm's Avatar
 
Trader Rating: 2
Join Date: Mar 2010
Location: Glendale
Posts: 534
Default

seems kinda low to me as well on a hot day drivnig in stop and go traffic mine wont drop below 35psi and when its cold its past 60psi at initial start up. Crusing speeds it maintains around 40 or a bit higher. I would go ahead and replace the pump and as mentioned put in a cam. If you got those concerns with paint and other stuff what i ended up doing since i had no patience like i did before with my other Z i paid a bit extra and bought something thats a bit cleaner and less work doing cosmetics and maintenance and can immediatly start modding it.
__________________
96 Z28 M6: K&N, Smooth Elbow, 52mm TB, Air Foil, Throttle Body Bypass, No Cats, Flowcrapster, Exhaust Cut Out, 160 Thermo and Tune, B&M Short Shifter.
06 300 SRT-8 Mopar Cold Air Intake, Predator/Johan Tune, 180 Thermo, Catch Can, Maganflow Exhaust.(Sold)
03 C5 Z06(Gone)
01 Z28 Full Bolt Ons/Nitrous(Sold)
01 M3 Vert Full Bolt ons(Sold)
karpetcm is offline   Reply With Quote
Old 05-24-2012, 12:13 PM   #7
Launching!
2002 Chevrolet Camaro
 
spicebird98's Avatar
 
Trader Rating: 10
Join Date: Oct 2008
Location: Wilmington, DE
Posts: 228
Default

what oil are you using? might be a bit light, try changing the oil with something heavier/thicker and it should bump you up 10lbs or so.
__________________
2002 Pewter M6 Z28 Corsa/Lid 13.00@109 Sold
2000 NBM M6 SS PRC 5.3 heads/Torquer V2 425/412 Sold
2001 Pewter A4 Z28 Stock Stall, 2.73's 12.42@113
spicebird98 is offline   Reply With Quote
Old 05-24-2012, 12:13 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
1998, 98, bolt, camaro, hot, low, ls1, ls1tech, normal, oil, ons, pressure, presure, tech, traffic, z28


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -5. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details