My cam sensor harness is not mating with the engine harness help!! - LS1TECH

Log In 


Generation IV External Engine LS2 | LS3 | LS7 | L92 | Bolt-Ons | Intakes | Exhaust | Ignition | Accessories

My cam sensor harness is not mating with the engine harness help!!

Reply
 
Thread Tools Search this Thread
Old 01-31-2012, 07:41 PM   #1
TECH Enthusiast
Thread Starter
iTrader: (2)
 
firehawk68mcleod's Avatar
 
Join Date: Jul 2010
Location: missouri
Posts: 508
Default My cam sensor harness is not mating with the engine harness help!!

Im doing a ls2 engine swap into 68 camaro. I purchased an 05-06 gm gto m6 engine harness. The engine core i bought did not come with any sensors including the cam sensor and cam sensor harness. So i went on to purchase all the sensor from the gm dealership.. all 05-06 gto sensors. But one problem, the cam sensor harness (part number 12627501) will not mate with the engine harness. Its looks like there two different style clips. Any ideas guy? Maybe some one has some pics of the two harnesses, or im missing something? helppp please guys...

cam sensor harness




Engine harness



Now the cam side only has three wires and the engine side has five wires i believe. which doesnt make much sense to me but there the only ones that even look close to clipping together.
Attached Thumbnails
My cam sensor harness is not mating with the engine harness help!!-cam-sensor.jpg   My cam sensor harness is not mating with the engine harness help!!-engine-harness.jpg  
firehawk68mcleod is offline   Reply With Quote
Old 01-31-2012, 09:02 PM   #2
TECH Enthusiast
Thread Starter
iTrader: (2)
 
firehawk68mcleod's Avatar
 
Join Date: Jul 2010
Location: missouri
Posts: 508
Default

12591720 is the part number of the cam sensor they sold me. Did gm discontinue the gto cam sensor?
firehawk68mcleod is offline   Reply With Quote
Old 01-31-2012, 09:20 PM   #3
TECH Enthusiast
Thread Starter
iTrader: (2)
 
firehawk68mcleod's Avatar
 
Join Date: Jul 2010
Location: missouri
Posts: 508
Default

Fixed it boys and girls ... gm sold me a cam harness to which a gto never had... I never would of guessed considering my ls2 timing chain cover had a spot for it to mount lol oh well at least its fixed
firehawk68mcleod is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Tore down some optispark sensors today ipaq3115 LT1-LT4 Modifications 48 08-01-2015 10:17 AM
WTB - GTO Splined Hub RacerBill Parts Wanted 4 11-20-2014 10:42 AM
ProEFI 128 Engine Management + extras digitalsolo Parts Classifieds 3 07-29-2014 11:38 AM
FS: Dynatech Mustang LSX Swap Headers $400 BNIB 89L98T56 Parts Classifieds 9 12-02-2013 10:37 AM
1999 Red FRC Corvette needs motor SEB Vehicle Classifieds 7 05-16-2012 09:18 PM


Tags
06, 12627501, 99, cam, camaro, camshaft, engine, gto, harness, ls1, number, part, sensor, wire, ws6

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:01 PM.