WTF? 0-rings - LS1TECH

Log In 


Generation IV Internal Engine 2005-2014 LS2 | LS3 | LS7 | L92 | LS9
Sponsored by:
Sponsored by:

WTF? 0-rings

Reply
 
Thread Tools Search this Thread
Old 04-07-2007, 06:42 PM   #1
TECH Apprentice
Thread Starter
 
bigturboz28's Avatar
 
Join Date: Nov 2005
Location: Newmarket, Ontario
Posts: 304
Default WTF? 0-rings

I am doing a ls1 to ls2 swap, when I installed the oil pickup tube (from 98 ls1) there was a black o-ring and I reused it, however now that the engine is assembled and in the car with pretty much everything hooked up, a saw another o-ring in the 98 block, a blue one??? Does this pick up tube need two o-rings, whats the deal?
bigturboz28 is offline   Reply With Quote
Old 04-07-2007, 07:53 PM   #2
TECH Addict
iTrader: (6)
 
P Mack's Avatar
 
Join Date: Jan 2003
Location: Phoenix
Posts: 2,384
Default

You mean one was stuck on the tube and one was stuck in the oil pump? It only takes one o-ring. I've only seen blue ones. Did someone do a cam swap on your engine before you got it? For a while people who did cam swaps where double o-ringing the pickup tubes just in case one got pinched but I think then it went away when people realized it wasn't necessary.
P Mack is offline   Reply With Quote
Old 04-07-2007, 08:05 PM   #3
TECH Apprentice
Thread Starter
 
bigturboz28's Avatar
 
Join Date: Nov 2005
Location: Newmarket, Ontario
Posts: 304
Default

Yes, someone did a cam swap before I got the LS1 motor, so is the black one the correct one - let me guess put a new one in. Anyway to check if it is needed before I tear it down again?
bigturboz28 is offline   Reply With Quote
Old 04-07-2007, 10:09 PM   #4
TECH Senior Member
iTrader: (14)
 
ArcticZ28's Avatar
 
Join Date: Jun 2004
Location: Alexandria, VA
Posts: 5,113
Default

Is it the stock pump? Different pumps come with different color rings.
ArcticZ28 is offline   Reply With Quote
Old 04-08-2007, 09:17 AM   #5
TECH Apprentice
Thread Starter
 
bigturboz28's Avatar
 
Join Date: Nov 2005
Location: Newmarket, Ontario
Posts: 304
Default

I thought the o-ring only changed with the pick-up tube not the pump, are you sure the pump also has different sizes?
bigturboz28 is offline   Reply With Quote
Old 04-08-2007, 10:54 AM   #6
TECH Senior Member
iTrader: (14)
 
ArcticZ28's Avatar
 
Join Date: Jun 2004
Location: Alexandria, VA
Posts: 5,113
Default

PM'ed you back. The different colored o-rings are for different sized pickup tubes. You are correct.
ArcticZ28 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:37 PM.