Howz it yall!! - LS1TECH

Log In 


Introductions & Greetings New to the site? Say hello!

Howz it yall!!

Reply
 
Thread Tools Search this Thread
Old 06-27-2012, 03:56 AM   #1
Registered User
Thread Starter
 
Join Date: Jun 2012
Posts: 2
Default Howz it yall!!

Hi there I'm J.D. From Auckland NZ... I own a 2005 Holden Commodore SV8 with a LS1 Generation III engine
Hobbies??? Ummm Fast cars, Fast women and general MAN stuff, I'm also a crane operator... I've been searching endlessly over the web for answers but with no results and I hope that someone here might be able to help me???
I have a power steering flow problem where the fluid is getting irritated and going pink instead of being a cheery red. I'm wondering if the power steering pump has a filter in it and maybe blocked and if there is a filter, where is it located?? Can anyone Help me??? I'm desperate and can't afford and don't want to take it to my Holden dealer for repair and get ripped off if I'm able to fix it myself...
Thanks J

Last edited by TripleGee; 06-27-2012 at 04:13 AM.
TripleGee is offline   Reply With Quote
Old 06-29-2012, 10:33 AM   #2
Brought out of retirement Super Moderator
iTrader: (7)
 
Reckless's Avatar
 
Join Date: Nov 2001
Location: Alpharetta, GA
Posts: 9,852
Default

Welcome J!
Reckless is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 12:27 AM.