Go Back   LS1TECH > WELCOME TO LS1TECH > Introductions & Greetings
Sign in using an external account
Register Forgot Password?
Search

Introductions & Greetings
New to the site? Say hello!

Suspension Problems/Question

Reply
 
Thread Tools Search this Thread
Old 08-19-2012, 02:43 PM   #1
Teching In
 
Trader Rating: 0
Join Date: Oct 2011
Location: Orange County, CA
Posts: 11
Default Suspension Problems/Question

I have QA1 double adjustable coil overs on my 02 SS and I have had a problem with the bolts staying put. The bolt used to connect the bracket on the bottom of the shock to the rear axel has failed me twice now. I noticed a noise and checked it out and turns out the bold had sheared off. The second time I was driving at about 55mph and the bolt either broke or came out (never found it in the road) and the suspension dropped. Any ideas as to why this is happening? I used a grade 8 bolt and a lock washer the last time I replaced it.
mean02ss is offline   Reply With Quote
Old 08-19-2012, 02:43 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 10:12 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details