View Full Version : Squeaking brakes- help!!


murrayfan97m
03-14-2009, 10:56 PM
Hi i have a 2000 trans am ws6. has 53k on it. i bought it about a year ago and not long after i bought it the brakes started squeaking all the time. had a few places look at it and said maybe just need new pads, so i tried that, didn't work. I just had a new place look at it and said it's the rear rotors and they need replaced. SO i got brand new rear rotors ..brand new pads for the rear rotors andd front, and the brakes STILLL squeak. i've only had the new rotors on 2 days. DO the new rotors just need time to set in? My brakes squeak BADLY around 80% of the time. PLZ help!

98transamtx
03-14-2009, 11:35 PM
did you applied the grease to the long bolts that hold the caliper on place? also autozone has a kinda glue thingy that makes the pads stick to the caliper and piston... that worked for me....

murrayfan97m
03-14-2009, 11:38 PM
I didn't put them on so i'm not sure if they applied grease. All i know is it's been going on the whole time i've had my car, and no new parts seem to be helping the problem! Oh and i forgot to mention that it's usually only when i push the brake in a little bit or intermediately, when i push all the way down hard on the brake there's no sqeaking.

wssix99
03-15-2009, 02:47 AM
I didn't put them on so i'm not sure if they applied grease. All i know is it's been going on the whole time i've had my car, and no new parts seem to be helping the problem! Oh and i forgot to mention that it's usually only when i push the brake in a little bit or intermediately, when i push all the way down hard on the brake there's no sqeaking.

This definitely like a bearing issue. Exact same behavior as described in this post: http://www.ls1tech.com/forums/general-maintenance-repairs/1082568-squeaking-breaks-help.html

murrayfan97m
03-15-2009, 02:34 PM
Ttt!!