View Full Version : Mysterious oil pressure issue. HELP!!!


smgbad
03-22-2009, 07:20 PM
So I noticed my car is running slightly above the 40 mark on oil pressure instead of slightly below 40 while idling (which has always been the norm). It is also being just a tad wavy instead of solid in it's reading. The cars exhaust has been sounding slightly choppy at idle and on decel lately too (not sure if it matters). So today, I turn the key to the off position to take out the key and the oil pressure gauge stays where it was when the ar was turned off. Then I turn the key to ACC and the coolant temp goes up to show the current coolant temp as normal, and the oil pressure gauge drops to 0. Then when turned back to off (to remove the key) the coolant temp gauge drops to 0 as normal, but then the oil pressure gauge reads around 20 (instead of 0). So right now, the key is out of the car for the night and the oil pressur gauge as of when I left the car still reads just above 40. Anyone know whats going on? Should I be worried, and if so how do you correct this problem? Thanks very much for all help on this!

P.S. I also tried reseting the PCM w/ a friend's programmer, and even though I've had no SES light on, I had to clear a P0327 Knock Sensor code. What the h*ll... Is my car taking a dump on me? Any ideas?

linebacker50
03-22-2009, 08:34 PM
don't feel like your the only one. mine does the same thing. when you shut it off the oil pressure stays just below 40 and i got back out in the morning and its still right there below 40. no idea what the cause is, but i sure would like to know.

smgbad
03-22-2009, 08:38 PM
still trying to figure it out... grrrr.. and also why the single knock sensor code went off but didnt throw an SES or Engine light... Now I don't know if they are related problems or if I should even drive it. I'm supposed to drive it about 30 miles from here on Tuesday for a custom tune and Dyno, but now I don't know if them revving the engine on a Dyno is the smartest move...

linebacker50
03-22-2009, 09:35 PM
not sure if it is a great idea to have it go to the dyno but i doubt that are oil pressure gauge problem is anything to worry about. i have had a check engine light for ever cuz of a bad cat and i get it checked once every 2 weeks just to make sure that there arn't any other codes. and nothing else has come up ( knocks on wood ). but i would get some input from someone about that knock sensor goin off.

smgbad
03-22-2009, 10:10 PM
Thanks... I just want it to run correctly again. It seems every single time I fix something, it either breaks again within a week or something even more expensive breaks within a day or two. I just spent $1000 switching gears to 3.73 trying to make them quiet and they still whine like hell on accel after 3 sets of gears, a pushrod broke clear in half about 2 weeks ago and sent me into limp mode, my engine is making a very slight ringing sound from the valve cover, the knock sensor code is being thrown even though there is NO light which came on to even tell me about it (I had to find out by accident when I tried to reset the PCM), and now my oil pressure needle is all screwed up with no idea whatsoever on what may cause it or if my car is even safe to drive seeing how since the last two problems (which I don't even know if they are connected somehow) have showed up the exhaust sounds choppy on decel and at idle (although the idle itself seems fine). ::sigh:: Should I just give up and buy a minivan?

::side note... also got laid off week before last for the third time in 12 months. Not relevent but just throwing that out there for anyone who wants to feel slightly better about their lives. Hope it helps =o) ::

smgbad
03-22-2009, 11:46 PM
refresh. Any of you super techs out there ever run into this?

smgbad
03-23-2009, 03:50 PM
refresh.

BigBirdLS1
03-23-2009, 04:02 PM
The gauge thing is probably nothing to worry about myself and and two of my other friends who all have V8 f-bodies I asked them and I know that my oil pressure gauge and theirs all do the same thing. We have had our cars for along time and drive them everyday without a single oil pressure related issue. The knock sensor code was probably a fluke I know that during normal driving you can sometimes get a knock and it will store that info. but won't throw a code it did it to me on the interstate a few months back. I saw it on my programmer checked for code there was one I reset it. And it hasn't done it sense. I hope this helps and you get your problem sorted out.

02WS6SSZ71
03-24-2009, 06:26 AM
:stupid:
Both my cars are the same way with the oil pressure thing. Probably something along the lines of cutting power off to the sending unit while there is still pressure. As long as your car has good pressure when running, and reads zero with the car off but the key turned forward, you're in good shape.
As far as the knock sensor, I believe there typically needs to be a repeat offense for it to throw an SES code. The code stored on yours could be from hitting a pot hole or something of that nature...they are pretty sensitive.
Whoever is tuning your car would hopefully be better suited to explain the knock sensor issue. Good luck

WS6Power
03-24-2009, 10:55 PM
It sounds like your oil pressure sending unit is going bad. It just controls your gauge not the oil pressure so your car should be OK to drive. The sensor is behind the intake a real pita to replace!

McCs WS6
03-26-2009, 02:45 AM
not tryin to hijack this thread but would the sending unit cause the check gauges light to come on, the oil pressure drops to zero, and the car dies??