View Full Version : Fays watts link and BIG PROBLEMS!!!


C Murda
06-25-2009, 08:53 PM
Ok so I'm installing my watts link today and I ran into some serious problems... Ordered from Strano he asked me the necessary questions and I answered. I have a moser 9" with 3" axle tubes and a spohn 1" solid rear drag bar with spohn moser 9" swaybar brackets. Problem 1 is on the driverside of my rear end it has the axle vent tube and it is right where my axle clamp for the link needs to be. I may be able to modify it a little (cut a 3/8" hole) to get the tube to go thru the clamp. Problem 2 and major!!! The passenger side axle clamp is too wide. It will not fit whatsoever between where my center section is welded to axle tubes and the sway bar bushing .

Seems like the only solution would be an axle clamp that is similar to the driver side (3" wide) and it would need to have the rod bolt tube as long as the supplied passenger axle clamp.

Just sucks $680 later and some serious problems. I'm broke! Hope Sam can help me out...

MeentSS02
06-25-2009, 08:55 PM
I was under the impression that this would not work for 9" applications...guess I must have misread something.

Got any pics you can post up to see what you are looking at?

xXxSilveradoxXx
06-25-2009, 09:31 PM
I was under the impression that this would not work for 9" applications...guess I must have misread something.

Fabricated 9"s are a no go for the Watts link.

Just sucks $680 later and some serious problems. I'm broke! Hope Sam can help me out...

It sounds like you talked to him and let him know everything before you purchased the watts link. I'm sure he'll help you out.

C Murda
06-25-2009, 10:40 PM
no pics yet sorry got dark and i picked up. yea the only other 9" it wont work with is a fabricated 9. i just have a standard Moser 9" with 3" axle tubes which was supposed to work fine. im just bummed out ive been waiting so long to get one of these and spent al that money just to run into this big of a problem. usually i can get creative and make things work but this problem requires a whole nother passenger side axle clamp.

z28bryan
06-26-2009, 09:50 AM
I thought the watts link was only supposed to to work with the 10 bolt and 12 bolt. Can't be completely sure though. You might have to come up with some custom fitment.

Big_Bird_WS6
06-26-2009, 10:03 AM
this is why i am getting my watts form Eric at midwest. and it is built for my fab 9"

TheBlueKnight
06-26-2009, 11:45 AM
Give Sam a call, he is gonna help you out if he helped you pick out the watts link and you ordered from him. On another note, did you say you're broke? Then why the heck did you buy a $680 watts link? :confused:

Sam Strano
06-26-2009, 01:11 PM
We've had it on various 9" housing, but there is no way to insure it fits every different housing. The first call would be to Fays2 to see what he can do. If he can't come up with a solution then I guess it'll be back to a PHB setup and we'll work out a return situation.

The link was designed on a stock 10-bolt and later tested to a 12-bolt. Subsequently it has been used on a few 9's, apparently those haven't been Moser housings, with Spohn brackets... The issue here is just so many different parts that were never designed with each other in mind.

firebird6786
06-26-2009, 02:55 PM
venting problem is not a big deal. weld a plug in and relocate it and as far as the clamp goes. you need to call the manufacture and tell them the situation and im sure they can build a clamp thats for a 3.125(im guessing) axle housing,

C Murda
06-26-2009, 04:38 PM
^^^^ it has nothing to do with the axle tubes as they are 3" and the clamps fit around them fine. It's just that passenger side that the clamp is too wide by 2" and there is no room for it to fit

C Murda
06-27-2009, 06:32 PM
well heres an update.....
i called jim fays and left a message. he quickly returned my call, i old him my problem and what seemed to be needed to make this work and he right away was fine with shipping me out a new passenger side axle clamp with a return slip so i can send him back the 5" wide one. great guy and definately backs up his products. thanks Sam and thanks Jim Fays! now just some down time but its gonna be raining all week anyways....

VIPRETR2
06-27-2009, 07:51 PM
Awesome, mine just came in a couple of days ago and I might install it tomorrow. I was very impressed with the product, packaging, and color install booklet. It's good to know that the product support is great as well (although I never really had a doubt). Good luck with your installation,

Larry

MeentSS02
06-27-2009, 08:48 PM
well heres an update.....
i called jim fays and left a message. he quickly returned my call, i old him my problem and what seemed to be needed to make this work and he right away was fine with shipping me out a new passenger side axle clamp with a return slip so i can send him back the 5" wide one. great guy and definately backs up his products. thanks Sam and thanks Jim Fays! now just some down time but its gonna be raining all week anyways....

Please let us know if that works out for you.

I really wish he could make one that would clear an exhaust like mine that requires the upper panhard bar relocation kit :( Oh well...probably wouldn't end up with the best geometry anyway.

UnZFeat'd
06-29-2009, 05:26 PM
Nice to hear. When i was installing my Watts Link i called Jim at around 12 midnight or 1 o clock his time, because i had to widen the sway bar spacers, and he was totally cool with helping me out. I live in California, and i thought he did too, but i was wrong. Very cool guy, and would do business again with him or Sam in a heartbeat.

2002_Z28_Six_Speed
06-29-2009, 05:33 PM
Jim Fayes will supply you with longer links for the Moser's that have vents in the middle of the axle tube.

I know.

I ran into the exact same situation.



But, I was able to install in correctly without longer links and still avoid limiting the prop rotation.

LS1HIGHLIFE
05-06-2012, 02:00 PM
I'm reviving this thread as I am experiencing some problems also...

I had the same issue with the vent tube but I got around that by notching both clamps so the 9/16" breather vent would clear and still give me vertical adjustment. The issue I'm running into now is the clamp horizontal clearance (see pics below). I set my bars to the exact same length as each other with the instructions saying to leave 5-7 threads on the propeller side and 2 threads on the axle clamp side (roughly 12"). My drivers side mount is in there tight against the housing weld and the Strano adj swaybar mount. I can't move the passenger side mount any further out (I've tried w/ BFH getting the clamps pushed out as far as they will go). The Moser 9" housing is about 1" wider to the drivers side.

If You read this and see these pics, Sam, please give me a call. I'm at a loss for what to do.

http://i256.photobucket.com/albums/hh187/cdh6969/prepellarview.jpg
http://i256.photobucket.com/albums/hh187/cdh6969/passengersideoffset.jpg
http://i256.photobucket.com/albums/hh187/cdh6969/passengersidemeasurement.jpg
http://i256.photobucket.com/albums/hh187/cdh6969/passengersideaxleclampfitment.jpg
http://i256.photobucket.com/albums/hh187/cdh6969/driverssidemeasurement.jpg
http://i256.photobucket.com/albums/hh187/cdh6969/driverssideaxleclapfitment.jpg

VinR1
05-06-2012, 02:11 PM
dumb question, the mount looks offset - can it be flipped?

LS1HIGHLIFE
05-06-2012, 02:19 PM
I've got the passenger side clamp on the way the instructions say to do it, with the gusset facing to the right. I believe I can flip it; however, I don't know if that is the right thing to do...

--UPDATE. I did flip the passenger side mount and it lines up ok. The other two issues I'm having are: The propeller is at 11 o'clock & 5 o'clock instead of what the manual says of 1 & 7. And the drivers side large bolt is stripped and the threads are jacked up in the axle tube mount.... I don't have a large enough tap and die set to address this one.

LS1HIGHLIFE
05-07-2012, 06:22 PM
Bump for some answers... Still questioning if the propeller is going to be alright in the opposite (time) locations.

I found a guy that has a 3/4" by 16 tap to clean out the axle tube mounting bracket but I also need a die to repair the bolt...

Added: https://docs.google.com/file/d/0B5yhXDk1xbMtaEhZLUpfbURUNEtqUm0wQ0lCbWlBZw/edit?pli=1
To show I'm not crazy.... I'll call Jim today.

vatechguy3
05-08-2012, 06:33 AM
why don't you give fays2 a call?
his number is on the website.

tony

Sam Strano
05-08-2012, 04:24 PM
Call Fays2, he'll probably get you some different length arms (the tubes) to rock the propeller back to where you need it.

LS1HIGHLIFE
05-08-2012, 06:57 PM
Call Fays2, he'll probably get you some different length arms (the tubes) to rock the propeller back to where you need it.

WORD.... I did give him a call and he will be sending me some longer arms and a new bolt. after that I should be god to go.

94m6Z28
05-20-2012, 02:34 AM
so this is a little off topic but are any of you running a narrowed rear end with the fays unit

tt383lt1
05-20-2012, 02:37 AM
what does that do?? its a dumb qustion but i never seen one of these befor