View Full Version : WTF weird noise from clutch/slave cylinder. VIDEOS


bcbosley
06-30-2009, 09:15 PM
Soon after I installed a LS7 clutch, new master and slave cylinders, I have been getting this weird noise. Its kind of like a creaking/popping noise. It only makes the noise when it sits overnight, when its completely cold. Once my car warms up it won't do it. I don't know if it is my slave cylinder or my pressure plate? I have about 2,500 to 3,000 miles on setup and it seems to be getting worse. I have also been having more trouble with it being notchy going into gears. Watch the videos, Does anyone have any suggestions?

http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=59816332

http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=59817355

NBM-LS1
06-30-2009, 09:56 PM
There is something wrong with your shit. If its getting notchyer and notchyer, it seems like it is having trouble disengaging the clutch.

It also sounds like its coming from your pressure plate/ throwout bearing.

KurtRardin
07-01-2009, 07:47 AM
:eek2: I dunno what those kind of noises would be from. What kind of Master cylinder/slave cylinder did you use? GM?

bcbosley
07-01-2009, 05:00 PM
It kind of sounds like the creaking might be the slave and then the popping noise sounds like the pressure plate. Its pretty loud, but once it warms up it don't make the sound. The master cylinder and slave cylinders are just from Autozone, i think LuK brand. I bought the LS7 clutch off of ebay, it was from a brand new crate motor.