View Full Version : Failed Smog!


EkS
07-03-2009, 11:28 AM
Hey guys, had my LT1 B-Body tested today and it failed. Anyone know what I can do to make it pass? I have 10 days to get a free retest. Below is a scan of the results. EGR was turned off in the tune, should it be turned back on?

http://www.chevelles.com/showroom/data/500/medium/smog1.jpg

Nacho SS
07-03-2009, 12:22 PM
Hey guys, had my LT1 B-Body tested today and it failed. Anyone know what I can do to make it pass? I have 10 days to get a free retest. Below is a scan of the results. EGR was turned off in the tune, should it be turned back on?

http://www.chevelles.com/showroom/data/500/medium/smog1.jpg

Did you drive the piss out of the car and get it nice and hot before you tested it?

EkS
07-03-2009, 12:23 PM
Oh yeah, I actually drove it on the freeway between 75-85mph and right to the smog place. They put it right on. The tech even revved it before taking the actual test.

ZexGX
07-06-2009, 07:41 PM
All smog equipment should be put back on, as well as a good clean tune loaded.

bigtls1
07-06-2009, 07:46 PM
i had the smae thing on my tpi, try replacing the o2 sensors. once i did that, it helped alot

ss.slp.ls1
07-06-2009, 07:48 PM
How old are the cats?
You can seafoam the car.

Omegalis
07-08-2009, 04:49 PM
just re-enabling EGR should bring your NO down as that is what it is designed to do. should leave it enabled, doubt your getting much if any performance gain, and likely doing your engine harm.

ss.slp.ls1
07-08-2009, 05:40 PM
just re-enabling EGR should bring your NO down as that is what it is designed to do. should leave it enabled, doubt your getting much if any performance gain, and likely doing your engine harm.

Care to elaborate on the possible harm caused from deleting EGR?

BlueMagicSS
07-08-2009, 10:46 PM
Get the EGR working right to bring the NOx down and then do a tune-up to get your HC's down. You'll be good...