View Full Version : Took the SS to the track


badboy4life
10-25-2009, 03:44 AM
60ft 2.0
1/4 12.69
mph 112

Kooks 1 7/8 with GMP exhaust
AFE CAI
HP Tuners

Tried to make another pass but something snapped. Input shaft i think

I would like to thank My brother and the Guys @ Icon Autosports for the awsome install and tuning. Also Mikey @ G-Force for saving me some time and have the headers in stock.

blackjack325
10-25-2009, 08:36 AM
good time.... is that an auto or manual?? the kooks headers, do they go to 2.5" pipes??

badboy4life
10-25-2009, 01:27 PM
M6 and headers go to 3"

Mike TexaSS
10-25-2009, 03:33 PM
Ouch!

Are you going to try and fix it under warranty?

badboy4life
10-25-2009, 03:52 PM
Ouch!

Are you going to try and fix it under warranty?

Worth a shot

Carlos Garza
10-25-2009, 03:55 PM
did you use DRs at the track?

badboy4life
10-25-2009, 04:09 PM
did you use DRs at the track?

No DR just the tires that came with the car:drive:

Camaro-Sutra
10-25-2009, 05:14 PM
Which car was this out there? I was in the white one. I was trying to get into the 12's but just fell shy again. DA was decent yesterday but not best I've run in. I got new best 60ft but .02s off my fastest so far.

badboy4life
10-25-2009, 06:09 PM
Black with silver strips

Camaro-Sutra
10-25-2009, 07:16 PM
Ah ok, you broke the input shaft? The GF was shooting vids and pics and said every time you'd launch wheel hop was BAD. How are you launching the car? All driving assistance turned off?

William

unit213
10-25-2009, 07:22 PM
Tried to make another pass but something snapped. Input shaft i think

Good pass for the mods! :thumb:

How many spline input shaft?

badboy4life
10-25-2009, 08:40 PM
Ah ok, you broke the input shaft? The GF was shooting vids and pics and said every time you'd launch wheel hop was BAD. How are you launching the car? All driving assistance turned off?

William


Yea i had some bad wheel hop. I even let out and got back on it and it still would break lose and wheel hop. I was launching it at about 2400 and slipping the clutch a little. This is my second time at the track with it so i need to work on getting it out of the hole.