View Full Version : Bought a fuel pump but never seen a in-line hose like this...


FastRidesOnly
01-23-2010, 03:46 PM
bought this fuel pump off ebay brand new with a lifetime warranty.
suppose to fit 98-02 3.8 camaro/firebird

its for my 3.8

cant figure out the "black inline" hose is for..
my stock pump doesnt have one. which way does it go on?
the intructions doesnt say

http://www.ls1tech.com/forums/attachments/general-maintenance-repairs/211867d1264279552-bought-fuel-pump-but-never-seen-line-hose-like-p_00176.jpg
http://www.ls1tech.com/forums/attachments/general-maintenance-repairs/211868d1264279552-bought-fuel-pump-but-never-seen-line-hose-like-p_00174.jpg

http://i.ebayimg.com/08/!BYD+,BgB2k~$(KGrHgoH-D8EjlLl)cYWBKfnUBKFh!~~_12.JPG

the_merv
01-24-2010, 04:11 AM
WTF is that..:confused:

94'BLKBRD
01-24-2010, 05:51 AM
I've seen that black inline hose on a 3.8 v6, but it was a Grand Prix GTP.

Maybe the seller sent you the wrong pump?

FastRidesOnly
01-24-2010, 11:28 AM
well i instaled it and it cranks up but shuts right back off.
i figured its just a breather hose but the stock pump already has a breather hose right? one of the big black tubes.

i was looking closely at the stock pump and it kinda looks like it has a spot where u could put a small black hose there but its "plastic welded" shut.


the listing actually said for 99-02..i'm using it on a 98.. but the 98 3.8 is the same as a 99 3.8 right?

it says "in line hose"...so that confuses me.

but it cranks up the car.. put it sputters and shuts off. i did have a problem with the coil packs. do they sell coil pack testers? i can try to test them at ngiht time and see which ones spark...IF the car will stay on long enough.


heres the instructions it came with:
http://www.globalautomotiveofmiami.com/uploads/TEC1620.pdf

i read something on one of those "ripoffreports.com" sites.. where they send the guy the wrong pump..cuz it has 3 holes n was suppose to only have 2. and the guy sent the pump back for exchange and they kept the pump and his money.

wonder if i can just block off that "black inline" hose? seems to me like its a breather? but wouldnt a breather say "out line hose". should it face downwards towards the tank or upwards as a breather?

hotrod 80
01-24-2010, 11:36 AM
the listing actually said for 99-02..i'm using it on a 98.. but the 98 3.8 is the same as a 99 3.8 right?

IIRC the 98' 3.8 is all by itself . 97' down & 99'-02' are differentI have a 98' with 3800 and tried to replace just the pump . It ran , but poorly . I bought the Delphi factory replacement unit problem solved .

FastRidesOnly
01-24-2010, 11:46 AM
IIRC the 98' 3.8 is all by itself . 97' down & 99'-02' are differentI have a 98' with 3800 and tried to replace just the pump . It ran , but poorly . I bought the Delphi factory replacement unit problem solved .

the 2 cars im trying to put them on are
97 3.8
and 98 3.8
both of those 2 97/98 had the same exact pump with no inline hose.
even my 93 z28 fits up the same way.

what do i do with the black inline hose and whats the purpose of it?
can i block it off.

could just be my coil packs... only way i know of testing them is in the dark. see which ones are sparking. car runs but sputters. has half a tank of gas. gonna clear the codes and read the codes.

O2Form
01-24-2010, 01:16 PM
you got the wrong pump...that black hose is for the venturi in the fuel bucket.......

FastRidesOnly
01-24-2010, 01:24 PM
sorry but what is a venturi?

could i block the black hose off or something?

car starts but runs rough but that could just be the coilpacks. i was already having problems with the the coilpack

the_merv
01-24-2010, 02:01 PM
A venturi is a small hole..from the sound of it that little black line sucks in Gas from the Bucket and sends it in the Lines.

FastRidesOnly
01-24-2010, 02:04 PM
hhmm. still confused.
isnt nothing to hook the other end of the black inline hose to.
its not just a breather that sticks up towards the top of the tank?

the_merv
01-24-2010, 02:22 PM
I think it's supposed to suck from inside the Gas tank..don't take my word for it, I'm just going off of looks.

FastRidesOnly
01-24-2010, 06:44 PM
i originally had it pointing up as a breather.
i pointed it down and it ruined the pump. so theres one replacement.

this is a shop installing it by the way.

the instructions say nothing about the black inline hose.

i already mailed the warranty back..so it'll be under warranty.

Deviant LS1
01-24-2010, 06:50 PM
You purchased the wrong fuel pump. Steel tanks use a universal style walbro as they suck from the bottom of the bucket. 93-98 Fbodies use a steel tank. The plastic tanks (99+) use the style of fuel pump you purchased. The venturi system feeds the pump through a provision built into the bucket. Buy a universal style pump and it will work fine.

FastRidesOnly
01-24-2010, 07:07 PM
damn. hope i can get my money back

so the 99-02's have that tiny black tube"

if not...how much could i sel them for on here for the 99-02 people?

Deviant LS1
01-25-2010, 03:15 AM
damn. hope i can get my money back

so the 99-02's have that tiny black tube"

if not...how much could i sel them for on here for the 99-02 people?
Yes, 99-02's use a plastic fuel tank with a venturi fuel bucket. The tiny black tube goes to a small pickup in the fuel bucket.

FastRidesOnly
01-25-2010, 09:08 AM
theres no way to modify it to work on a 98?

FastRidesOnly
01-25-2010, 12:53 PM
everything was fine..til i pointed the black hose downwards...
what if i block that hole off?

i got a warranty.
PM if anyone wants the good pump..its for 99-92 with a lifetime warranty. i havent filled the warranty card out yet...

venom99
01-25-2010, 08:25 PM
get a ls1 pump it will bolt right up to everything i did this so you know ran it for 100k with my v6 and beat the piss out of it

FastRidesOnly
01-26-2010, 09:37 AM
i already did that... that one went bad.

the ebay pump didnt go bad. i had a blown fuse.

the ebay company emailed me and said its a breather hose and points down. i guess outside of the sending unit. i'm gonna mess with it today.

FastRidesOnly
02-07-2010, 08:28 PM
update..
from what i understand. this pump is for the later models.. a 98v6 and earlier is different.

i held the pump up out of the tank while someone started the car and gas comes out of the the regular see-thru hose and out of the small black hose.. so i guess its not a breather hose.

i'd hate to waste 50 on another pump if i can make this one work. its hooked up right now but the car will just start and shut off after 2 seconds.

heres the instructions



Ok, here is our install guide that is posted on our ebay store home page.



This will show you exactly where these hoses go.

As previously stated, our fuel pump kit will ONLY fit the OEM Delphi assembly. It will not fit any aftermarket assemblies.

http://i235.photobucket.com/albums/ee236/mdzgroup/FUELPUMPREPAIRKITINSTRUCTIONS.jpg

FastRidesOnly
02-07-2010, 08:29 PM
so from i understand...the later models have a place where this thin black hose hooks up into...

FastRidesOnly
02-07-2010, 08:34 PM
i re-read the picture. its called a 'return valve hose'. my sending unit shell doesnt have a place for this to attach. the pump does. i currently have it hooked to the pump then faced down outside of the pump shell.

its possible something else went bad on my 97 v6. so i'm gonna take the pump like i have it now and try it on my 93 z28. but the car will start but shut right back off

FastRidesOnly
02-09-2010, 11:02 PM
damn nobody on here knows?

O2Form
02-11-2010, 03:38 PM
Look just block the small hose off....you don't have a venturi cto connect it to.

FastRidesOnly
02-11-2010, 07:39 PM
i tried blocking it off and it didnt work

O2Form
02-11-2010, 07:43 PM
i tried blocking it off and it didnt work
:bang:

FastRidesOnly
02-11-2010, 08:08 PM
what?

what can i block it off with?
i was just holding my thumb over it. its a return valve hose..it wouldnt blow the motor up?